1 Copper

Dell Inspiron 1525 Wireless 1395 WLAN Card Utility not working properly after Factory Restore

I recently performed a Factory Restore on my Inspiron 1525. After the restore my Wireless LAN Card Utility seems to work fine. I can actually open the application. After a series of restarts, I noticed that the application fails to work properly. When I tried running the utility the error I got is that there was no wireless adapter installed or enabled. The funny thing is the wireless adapter is working properly. I can actually connect to any wifi, in my house and in public areas. When I shutdown my laptop, it takes a long time logging off (about 10-15 minutes). After the restart, I got a different error, this time the error says that there is something wrong with the internal configuration. And still it takes a long time to logoff or shutdown. This is getting to be annoying. Has anyone encountered this same problem? What can I do to resolve this problem?

By the way, when I tried uninstalling the WLAN Card Utility, it took only seconds to logoff or shutdown.

Any advice will be highly appreciated.

 My laptop is:

Dell Inspiron 1525, Dual Core T2390 with 3Gb RAM running Windows Vista Basic SP1, BIOS version A16

0 Kudos