cooljen1
1 Copper

Dell Inspiron 1750 Laptop stopped connecting to WIFI. It's been a full day now. Network shows - won't connect. Ethernet cable works but NO WIFI. All other devices in house connect fine wirelessly - PLEASE HELP!

Jump to solution

Hello, I've been going crazy for a whole day searching and trying what seems like 1000 different things to get the wifi working and nothing is working.

My wifi adapter is Intel Wifi Link 5100 AGN

My laptop was connected yesterday morning. The connection went away, so I put the computer to sleep and woke it back up again (since in the past this has helped). That worked, temporarily, then it went out again. I put it to sleep again for a little longer, woke it up - it worked then went out again. This time I thought I just need to restart the computer. So I did, and since then I have not been able to reconnect!

Things I've tried:

  • I have tried uninstalling and reinstalling the drivers (wireless and Ethernet) - *have since discovered the Ethernet is fine though*
  • I've uninstalled the adapters and drivers and installed drivers I managed to download from a different computer. - still no luck 
  • I've ran chkdsk, sfc/scannow, memory diagnostic, etc. 
  • I've typed ipconfig /release and /renew - It tells me media disconnected
  • I've typed a few series of the 'netsh int reset...' commands and restarted the computer (I've seen different versions on different sites - none worked) 
  • I've tried resetting the router back to factory defaults and when I did so, I was still unable to connect to the original router's SSID

Please someone help!! I feel like I have tried everything. I'm sure I'm leaving out some other thing I've tried. Not to mention I've restarted the computer about a 100 times now.

Thanks in advance.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
cooljen1
1 Copper

RE: Dell Inspiron 1750 Laptop stopped connecting to WIFI. It's been a full day now. Network shows - won't connect. Ethernet cable works but NO WIFI. All other devices in house connect fine wirelessly - PLEASE HELP!

Jump to solution

I had already removed and reinstalled the driver, as well as downloading a fresh driver and installing that instead, as mentioned in my original post. Neither thing worked.

I saw on another forum that someone who also had this problem ended up getting a new card and after installing that, it worked fine immediately. So that is what I did. I bought a new WIFI card off of Amazon.

I installed it yesterday and it connected immediately and has been working great thus far!

0 Kudos
2 Replies
Moderator
Moderator

RE: Dell Inspiron 1750 Laptop stopped connecting to WIFI. It's been a full day now. Network shows - won't connect. Ethernet cable works but NO WIFI. All other devices in house connect fine wirelessly - PLEASE HELP!

Jump to solution

Thank you for your message.


Download & install bios from this link dell.to/2sFtQNn  


Download the wireless driver here http://dell.to/2u8J5Th and the chipset here http://dell.to/2v2kHzb  & save to your computer.


Open device manager – expand network adapter & right click on the wireless driver & click on uninstall (check the box that says delete driver) do not restart the computer. Install the chipset driver first followed by the wireless driver & restart the computer.


Disable the anti- virus on your computer & the wireless password & try connecting to the network & check if there is any error listed.


What is the operating system installed?


Click on my Dell username & send a private message with the service tag, registered name & email address.


Dell-SreejithRamesh
Social Media Support
#IWork4Dell
To help us troubleshoot, send us via a private message: Dell PC or Monitor Service Tag number
Out of Warranty Support
Would you like to be a Dell Community Rockstar?

0 Kudos
Highlighted
cooljen1
1 Copper

RE: Dell Inspiron 1750 Laptop stopped connecting to WIFI. It's been a full day now. Network shows - won't connect. Ethernet cable works but NO WIFI. All other devices in house connect fine wirelessly - PLEASE HELP!

Jump to solution

I had already removed and reinstalled the driver, as well as downloading a fresh driver and installing that instead, as mentioned in my original post. Neither thing worked.

I saw on another forum that someone who also had this problem ended up getting a new card and after installing that, it worked fine immediately. So that is what I did. I bought a new WIFI card off of Amazon.

I installed it yesterday and it connected immediately and has been working great thus far!

0 Kudos