Highlighted
eeehw
1 Copper

Dell XPS L502X Wireless Adapter Problem

I recently bought a Dell XPS L502X system and have been using it for around 2 weeks, until this problem suddenly came up.

First of all, the network connection was lost during a MSN chat. I tried to restart the computer, but it takes a very long, stuck at 'Logging Off' screen for more than a few minutes. So I manually turned it off (POWER button), and since the next restart, I notice the Wifi indicator on my laptop was gone, and I was never able to connect via wireless.

1) From the Intel My Wifi Technology utility, it says 'No supported Intel wireless network adapter was found'.

2) Then I run the Manual Diagnostics Tool from Intel, and it straightaway fails the first test, Hardware Test. Error message being 'Driver version does not support Intel PROSet/Wireless WiFi Software version 14.0.1.0'

Here are some of my system info:

OS Name:                   Microsoft Windows 7 Home Premium
OS Version:                6.1.7601 Service Pack 1 Build 7601
OS Manufacturer:           Microsoft Corporation
System Manufacturer:       Dell Inc.         
System Model:              Dell System XPS L502X
System Type:               x64-based PC
Processor(s):              1 Processor(s) Installed.
BIOS Version:              Dell Inc.          A01, 15/02/2011

Windows IP Configuration

   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 12:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft 6to4 Adapter
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

In the Device Manager -> Network adapters, these are the active devices

- Bluetooth Device (Personal Area Network)

- Bluetooth Device (RFCOMM Protocol TDI)

- Realtek PCIe GBE Family Controller

Does this look like a hardware problem (that I need to revert to Dell warranty), or some system settings that have been possibly corrupted?

Please advice and help.

Thank you.

0 Kudos
13 Replies
8 Krypton

Re: Dell XPS L502X Wireless Adapter Problem

eeehw,

 

Can you run the Finding System Information Tool and post everything back here.

 

 

Rick

#DellRockstar

What is a Dell Service Tag and how do I locate it? 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

#DellWorld 2012

#DellWorld 2015

#DellEMCWorld 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

0 Kudos
eeehw
1 Copper

Re: Dell XPS L502X Wireless Adapter Problem

Thank you so much for the quick response.

After posting the above problem, I was giving another try on system restoring to an early point of yesterday.

It starts nicely afterwards, with the Wifi fully functional as usual. The only thing weird was in the Intel My Wifi Technology window, it shows 'Disabled', though I am having a successful wireless connection to my ADSL router and the internet.

However, bad thing happens after a while. It simply drops out on its own. The Wifi indicator is gone (although pressing Fn+F2 still seems to toggle, but there is no actual Wifi function running) and all wireless connection is again dead. Same thing could happen after every reboot. Wifi being alive for a while, before drops out on its own (even if I disabled my router to have no actual internet connection).

I am now quite sure the hardware is fine (or at least it runs for a while).

Here is the full system info:

OS Name:                   Microsoft Windows 7 Home Premium

OS Version:                6.1.7601 Service Pack 1 Build 7601

OS Manufacturer:           Microsoft Corporation

Original Install Date:     29/12/2011, 11:05:40 AM

System Boot Time:          13/01/2012, 8:44:54 PM

System Manufacturer:       Dell Inc.        

System Model:              Dell System XPS L502X

System Type:               x64-based PC

Processor(s):              1 Processor(s) Installed.

BIOS Version:              Dell Inc.          A01, 15/02/2011

System Locale:             en-au;English (Australia)

Input Locale:              en-us;English (United States)

Time Zone:                 (UTC+10:00) Canberra, Melbourne, Sydney

Windows IP Configuration

  Host Name . . . . . . . . . . . . : HW-XPS

  Primary Dns Suffix  . . . . . . . :

  Node Type . . . . . . . . . . . . : Hybrid

  IP Routing Enabled. . . . . . . . : No

  WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Bluetooth Network Connection:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)

  Physical Address. . . . . . . . . : BC-77-37-0A-68-A0

  DHCP Enabled. . . . . . . . . . . : Yes

  Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller

  Physical Address. . . . . . . . . : 14-FE-B5-99-05-2F

  DHCP Enabled. . . . . . . . . . . : Yes

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 12:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft 6to4 Adapter

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{032FFE81-2950-4C44-979E-272F891D8FD3}:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft ISATAP Adapter

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{09EDA860-3225-4D21-A934-F296BB8DE958}:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes

Thanks again.

0 Kudos
8 Krypton

Re: Dell XPS L502X Wireless Adapter Problem

eeehw,

 

Did you try pressing F2 to see if the wireless adapter is turned on?

 

I would try contacting Dell Tech Support. I do not see the wireless adapter listed in the log. You can look in these places to see if your Connection is enabled, but from what I'm seeing, even if it was turned off, it should show in the log.

 

 

Rick

#DellRockstar

What is a Dell Service Tag and how do I locate it? 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

#DellWorld 2012

#DellWorld 2015

#DellEMCWorld 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

0 Kudos
eeehw
1 Copper

Re: Dell XPS L502X Wireless Adapter Problem

Here is the system info I've got after reverting to a previous restore point.

Surprisingly, it now has the wireless adapter listed!

By the way, I don't see the status of wireless adapter status after pressing F2 during boot-up.

OS Name:                   Microsoft Windows 7 Home Premium

OS Version:                6.1.7601 Service Pack 1 Build 7601

OS Manufacturer:           Microsoft Corporation

Original Install Date:     29/12/2011, 11:05:40 AM

System Boot Time:          14/01/2012, 9:07:38 AM

System Manufacturer:       Dell Inc.        

System Model:              Dell System XPS L502X

System Type:               x64-based PC

Processor(s):              1 Processor(s) Installed.

BIOS Version:              Dell Inc.          A01, 15/02/2011

System Locale:             en-au;English (Australia)

Input Locale:              en-us;English (United States)

Time Zone:                 (UTC+10:00) Canberra, Melbourne, Sydney

Windows IP Configuration

  Host Name . . . . . . . . . . . . : HW-XPS

  Primary Dns Suffix  . . . . . . . :

  Node Type . . . . . . . . . . . . : Hybrid

  IP Routing Enabled. . . . . . . . : No

  WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection 3:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter #2

  Physical Address. . . . . . . . . : BC-77-37-0A-68-9D

  DHCP Enabled. . . . . . . . . . . : Yes

  Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection 2:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter

  Physical Address. . . . . . . . . : BC-77-37-0A-68-9D

  DHCP Enabled. . . . . . . . . . . : Yes

  Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Bluetooth Network Connection:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)

  Physical Address. . . . . . . . . : BC-77-37-0A-68-A0

  DHCP Enabled. . . . . . . . . . . : Yes

  Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Intel(R) Centrino(R) Wireless-N 1030

  Physical Address. . . . . . . . . : BC-77-37-0A-68-9C

  DHCP Enabled. . . . . . . . . . . : Yes

  Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller

  Physical Address. . . . . . . . . : 14-FE-B5-99-05-2F

  DHCP Enabled. . . . . . . . . . . : Yes

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 12:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft 6to4 Adapter

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{103AE78E-74DF-4D72-96D1-91D02214C8D5}:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft ISATAP Adapter

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{4AD3253C-A9C3-4ADD-92A7-F8E554AF0220}:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{09EDA860-3225-4D21-A934-F296BB8DE958}:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft ISATAP Adapter #5

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{032FFE81-2950-4C44-979E-272F891D8FD3}:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{E18493A9-0DC7-4F1A-8C09-FFE6AFF15661}:

  Media State . . . . . . . . . . . : Media disconnected

  Connection-specific DNS Suffix  . :

  Description . . . . . . . . . . . : Microsoft ISATAP Adapter #6

  Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

  DHCP Enabled. . . . . . . . . . . : No

  Autoconfiguration Enabled . . . . : Yes



0 Kudos
8 Krypton

Re: Dell XPS L502X Wireless Adapter Problem

eeehw,

 

Try reading...

 

Power Save Polling (PSP) causes connection issues with some access points

 

 

Rick

 

#DellRockstar

What is a Dell Service Tag and how do I locate it? 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

#DellWorld 2012

#DellWorld 2015

#DellEMCWorld 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

0 Kudos
hsn.ahmed
1 Copper

Re: Dell XPS L502X Wireless Adapter Problem

I have exactly the same problem here !!!

0 Kudos
hsn.ahmed
1 Copper

Re: Dell XPS L502X Wireless Adapter Problem

i have exactly the same problem !!!! did you find a solution yet ??

0 Kudos
hsn.ahmed
1 Copper

Re: Dell XPS L502X Wireless Adapter Problem

I have exactly the same problem here !!!! did you manage to find a solution ???

0 Kudos
hsn.ahmed
1 Copper

Re: Dell XPS L502X Wireless Adapter Problem

Its a hardware problem ... i got it replaced