Highlighted
1 Copper

Error code 10 after upgrading to Intel wireless AC 7260

Hi everyone.
I have an Inspiron 1545 with Windows 7 Ultimate 64-bits and just upgraded to a Intel wireless AC 7260.
I downloaded and installed intel bluetooth and proset drivers. Bluetooth installation went well but the pro set ended with a problem. Under properties for the wireless adapter, it shows code 10 error...
I have already unistalled the old driver, reinstalled pro set and bluetooth several times, tried to run repair, reisntalled everything after unistalling antivirus, installed an older version instead... but all I get is the code 10 error.
It is getting a little frustrating at this point so, if anyone has any suggestion, I'm all ears !
Thanks,
Anderson.

Reply
3 Replies
Highlighted
7 Thorium

Re: Error code 10 after upgrading to Intel wireless AC 7260

Did you actually change the network card on the board in your laptop or did you add a usb network device? A usb device is always the best option in a laptop. Remember--Windows 7 is old and might not recognize newer hardware. Windows 7 drivers for that series of Intel network cards only go up to N models. Also your 1545 model is not listed as compatible on the Dell site. See this from the listing--

Designed For
Inspiron 11 3147, 13 7347, 14 5447, 15 5547; Latitude 14 Rugged (5404), 14 Rugged Extreme (7404), 3340; OptiPlex 3020 (micro), 9030 (all-in-one); Precision Mobile Workstation M3800; XPS 13 (9333), 18 (1820)
 
 
 
 
 
Reply
Highlighted
1 Copper

Re: Error code 10 after upgrading to Intel wireless AC 7260

Thanks for the reply, Mary !

Yes, I actually replaced the network card. While choosing which one to use, I followed the advice on the following thread: https://www.dell.com/community/Inspiron/upgrading-a-WIFI-adaptercard-for-a-INSPIRON-1545/td-p/606920...

I may need to upgrade that Windows as well but was postponing it the more I could, although I may consider it soon if no other option is left.

Thanks again.

Reply
1 Copper

Re: Error code 10 after upgrading to Intel wireless AC 7260

I had this "Code 10 driver couldn't start" Intel AC-7260 problem on my Win 7 Pro x64 system for over 2-years before I solved it. Resorted to using an Asus USB Wifi adapter in meantime.

Started out with issues of Intel Wiifi getting turned off after random amount of time, light would go out on dash. Setting all power-savings settings in Windows AND in driver to never sleep did no good. I upgraded to Proset 19, no change. Upgraded to Proset 20 when it came out and things got WORSE! Now Wifi doesn't work at all due to Code 10 driver can't start error.

Then I remembered something our CIO mentioned, "If it's not broken, don't break it!" So I figured this Wifi card worked when laptop came out, what changed to break it? AHAH!!! I went through update list in reverse order using WMI command to see items that ControlPanels hides from you. There's usual app updates, Windows updates, security updates, and there it was DRIVER UPDATE!!!  

So I uninstalled driver update and rebooted. I went back to driver working, but still had issues with Wifi turning off. I figured I'd uninstall Proset software, but that still left current driver in place. I removed that by uninstalling NIC in DeviceManager and choosing to delete device driver as well. Rebooted and it reinstalled NIC with older driver. Which I uninstalled and deleted driver as well, rebooted. Repeated until everything was uninstalled and it was asking for driver disk.

At this point, I tried various drivers from around time laptop was released. What finally worked to:

- start driver without Code 10 error and

- not randomly turn off Wifi was

DRIVER ONLY install using .inf using version 17.0.6.1. Date was from around time I bought laptop and it works 100% all time! Connects at full AC speeds and no disconnects!!! i've since disabled all driver-updates and all Windows updates. Only security-updates are allowed!

Reply