Highlighted
soyeso
Bronze

Ethernet Port stopped working

Inspiron 1545 with XP Pro

Some months ago, after a nearby lightning strike, the Ethernet port stopped working.

I called Dell Tech Support. They walked me through some tests and the port started working again.

My warranty has since expired, and the same thing just happened again. This time the port was connected to the net through a surge suppressor, but the port does not work. Device manager says the Ethernet controller is working.

Any suggestions what I might try?


Thanks,

Tomas

Tags (1)
0 Kudos
9 Replies
Moderator
Moderator

Re: Ethernet Port stopped working

soyeso,

Thank you for using the Dell Community Forum.

Bypass the surge protector to see if it will work. The network card may be just showing the driver is loaded but the port on the motherboard could be burnt out if you had a lightning strike.

0 Kudos
soyeso
Bronze

Re: Ethernet Port stopped working

If I connect the line from the surge protector to the wireless router it functions, so I assume that the surge protector is not the problem.

I assumed that I would need to replace the Motherboard the last time this happened, but it started working again, which is why I am exploring possible options this time. Is there any diagnostic I can run to tell if something is burned out?

 

Thanks,

Tomas

0 Kudos
ieee488
Diamond

Re: Ethernet Port stopped working

How can connecting a line from the surge protector to the router "function"?????

I am not understanding this at all.

The suggestion is to connect directly from the Ethernet port to the router. If the router light is not lit then it doesn't see the Ethernet port and the Ethernet port is bad.

 

 

0 Kudos
soyeso
Bronze

Re: Ethernet Port stopped working

I guess I have not been clear.

The firs time this happened, lightning hit nearby and I actually got a shock from the computer. I figured the port was dead and contacted a Dell tech to arrange for Motherboard replacement. he began to walk me through some verification procedures and I discovered that the port was functioning. That was 5 months ago.

Now it happened again, except this time I was using a surge protector on the cable (which obviously did not work). To test the surge protector, I connected the line from it to the WiFi router, and it works fine.

However, if I connect the line direct to the computer, it tells me it is unplugged. The ONLY reason I am not assuming MB replacement is the only cure is my previous experience. I wish I could remember what the tech had me do, but I do not, and the warranty expired 14 days ago!

So I am looking for some diagnostic info to verify the Ethernet port.

 

Thanks,

Tom

0 Kudos
Moderator
Moderator

Re: Ethernet Port stopped working

Tom,

 

Try running the Dell Diagnostics but run the full version and see if it shows up there.

 

How to Run the Dell™ Diagnostics Utility

 

 

Rick

#DellRockstar

What is a Dell Service Tag and how do I locate it? 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

#DellWorld 2012

#DellWorld 2015

#DellEMCWorld 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

0 Kudos
muto
Platinum

Re: Ethernet Port stopped working

.

0 Kudos
soyeso
Bronze

Re: Ethernet Port stopped working

Dell Diagnostics seems to test memory only. I tried it multiple times...

I have tried all the other options suggested.

Looks like the only option is a new Motherboard. So I guess the surge suppressor does not work.

An expensive lesson.

I am still puzzled how the machine recovered the first time...

Now I'll just unplug everything as soon as it starts raining, which these days is a lot...

 

Thanks to all for their suggestions.

Tom

0 Kudos
muto
Platinum

Re: Ethernet Port stopped working

.

0 Kudos
muto
Platinum

Re: Ethernet Port stopped working

.

0 Kudos