1 Copper

Firmware update for D6000 docking station failure

Tonight 12/30/2018 - I ran update utility Dock_D6000_FW_Updater_A02_73F77.exe on my D6000 purchased new when I got my system with a date code on the back of June 2017. The utility connected via the USB-C connection and froze mid update about a third of the way through the update and bricked the dock in that the computer was no longer recognized by the computer when connecting via USB-C. I have a picture of the freeze because I know that firmware updates don't play nice if they fail. Next step was to call support.

Three calls to three different support teams each of which required that I reexplain the issue and reprovide my express code to see if I was covered. The focus of support was all about seeing if I had a warranty and not addressing the reason that I was calling. About mid way through the dialog with the second rep I asked the rep if they could help me or not and what was the cost, because up until that point no material support was provided. The express code on my Latitude 7280 system in good for another two years, however the dock isn't supported. The final support rep offered a new dock for $40 more than the cost of Amazon then had the audacity to tell me that Dell stands behind their products as a reason that I should purchase from him...I let him know that if that where the case I would not be in a situation needing to repurchase when the cause of the problem was a firmware package that failed to update and left the dock unusable.

Update 12/31 - I tried the same firmware update again tonight this time connecting the dock to the computer via the USB cable rather than the USB-C. Thankfully this approach worked and I am back on my feet again!

1 Reply
1 Copper

Re: Firmware update for D6000 docking station failure

Thanks for this. I tried to update my D6000 via USB-C and it also hung. Switched to USB and it worked. That really should be in the instructions.