Inspiron N7010 WiFi gone west!

I've been using my trusty laptop (Inspiron with Win7) for better than a year now, with no untoward difficulties.

Suddenly, today, poof! The WiFi adapter just 'isn't there'.

I was browsing BBC News Olympic stuff, when the internet connection failed. Nothing unusual there - I live in a 'bad reception area', but when that problem manifests itself, I get at least a message in IE, and the problem 'goes away' after a while. (curiously enough, these kind of failures occur during times of bad weather - I didn't know that raindrops could affect the kind of transmission spectrum in use here Smiley Happy )


This time around, IE tells me that I'm not connected to a network.

Looked around and saw the 'Internet Access' icon in the system tray featured a red 'X'. Clicked on that and could not see the network name (from a Sky Broadband D-Link router) did not feature in the list. Restarted the laptop and there was no change. I'm now reduced to using a T-Mobile 'dongle'.

I have another laptop here - my 'work' one - and that is working fine on the Sky network. Also my Windows-based Nokia mobile is not having any difficulties with internet access - not sure if that's applicable, though...

I've tried toggling the laptop antenna with the 'Fn-F2' key-pair, but get no difference there. How do you tell anyway? There's no separate indication that the antenna is 'on' or 'off'.


Anyone got any further ideas? Is my laptop truly 'broken' in this regard? How can I check further?

Thanks in advance


0 Kudos
2 Replies

Re: Inspiron N7010 WiFi gone west!

*sigh*...   Now(2 hours later)  things are working again perfectly.      Hopefully, I fumbled the antenna switch key or something stupid like that.

Moderator - please kill this thread



0 Kudos

Re: Inspiron N7010 WiFi gone west!

Don't kill it yet! I ran into an identical problem with an N7010. Reloaded the wireless driver to no avail.

The FN-F2 toggle combination to turn the wireless on and off did not work.

I booted the PC into setup (by pressing F2 at startup) and under Advanced and networking turned off the toggle function, but left networking, bluetooth, etc. turned on. I then saved and exited the BIOS setup.

When the PC started normally the wireless was on again and able to detect (and connect to) networks in the area. It appears the toggle function quit working when the toggling had wireless set to off. Turning off toggling in the BIOS did the trick. Wireless works, speed is good.

0 Kudos