Highlighted
buspau
Copper

Intel® Centrino® Wireless-N 1030 and slow internet connection

Jump to solution

Hi,

I've just purchased a new Dell laptop from Currys (Dell Insprion Q15R, which has the follwing spec;

The issue I have is regarding wireless connection to my Virgin Media Super Hub. When I hard-wire the laptop into the router, I am getting approx 30mbs down and 3mbs up. When I connect wirelessly however, that drops to about 0.17mbs down and 0.2 up. I have made sure that the wireless adapter drivers are up to date so I rang a local IT company who had to change the 802.11 mode: from 300mbs to 54mbs on the hub before I could get a decent internet connect (about 20mbs down and 2mbs up).

Currys then called me to check I was happy with my purchase and I explained the above, their KnowHow staff member then came on the line to discuss ways of problem fixing the issue. Firstly he uninstalled the driver, downloaded the driver form the Dell support site and installed it. We then went into power management and made sure that the computer wouldn't reduce power to the card when running on battery.This however didn't fix the problem as when I turned my hub back to 300mbs my internet speed crashed back down to the figures above.

The KnowHow staff member suggested that there may be an issue with this particular network adapter and Windows 7 and explained that he couldn't fix the problem.

I know that if I use my laptop in the house only, I could change the hub settings, but I'm obviously concerned that if I take it elsewhere, I would have paid £700 for dial-up internet speed laptop!

If I can get a solution/fix for the issue, that would be beneficial as I would like to keep the laptop but otherwise I'll have to get a refund.

If anyone has any ideas/suggestions, i would appreciate it.

Many thanks in advance,
Paul

0 Kudos
53 Replies
A1010A
Bronze

Re: Intel® Centrino® Wireless-N 1030 and slow internet connection

Jump to solution

I have exactly the same problem.  I purchased an Inspiron 15R directly from Dell.  It comes with the Intel Centrino 1030 card.  It works fine in Wireless G mode but switch to Wireless N mode though and the download speed is terrible.  Upload seems to be better.  The Dell engineer came out and installed a new 1030 card but the problem persists.

I too use the Virgin Media Super Hub but this worls flawlessly with 2 other PCs.  I have not yet managed to try the Inspiron with another Wireless N router elsewhere.

All drivers are the most recent.  I use Windows 7 64-bit.  For the time being I am using the Wireless in G model only and will soon recontact Dell.  I suspect wither an Intel 1030 driver issue or an incompatibility with the Virgin Media router.  The latter can be checked when I can test with another Wireless N router.

 

0 Kudos
criskoe
Copper

Re: Intel® Centrino® Wireless-N 1030 and slow internet connection

Jump to solution

deleted...

0 Kudos
criskoe
Copper

Re: Intel® Centrino® Wireless-N 1030 and slow internet connection

Jump to solution

Hey I came by this thread because I am experiencing the same issue with the Intel Centrino Wireless-N 1030 Wifi adapter but with a HP DV6-6100 Series laptop and my new BroadBand Cisco Modem/Wireless Router. I Understand that the 2 products are completely different but the symptoms you explain fit my problem exactly for both of these posts.

Now I havent fully fixed the problem but in my case i have discovered the root of my problem and found some thing that might work for you 2 as well...

In my last attempt to get it to work before i just gave up, I decided to go into device manager and disable the bluetooth device completely on the Intel Centrino Wireless-N 1030 and volia! More than acceptible speeds right away! Solid 48.6Mbs eveytime. Solid connection and super fast.. I went back to device manager and re enabled the bluetooth and slow slow slow..... Problem came right back! .3 Mbs

Now I relize that this is definatly not a full fix but if you are not ever going to use bluetooth then this might be all the fix you need. As for me this sucks cause i like using the bluetooth for my razr bluetooth mouse but turning on the Intel Centrino Wireless-N 1030 bluetooth cripples the Wireless N mode to unusable wifi speed of .3Mbs!

And I Just got off the phone with HP and they have advised me that there is nothing wrong with my Wifi card.

The rep stated that because the Intel Centrino Wireless-N 1030 is a 2in1 bluetooth/Wireless Card that the speed is limited when using both bluetooth and Wireless N at the same time.

I asked then why did my bluetooth and older 25 mb connection Wireless N router/modem work together fine? He stated that because i am trying to now use it on a high power broadband 50mb connection Wireless N router/modem and that the little 2in1 isnt powerfull enough to handle the 50 mb speeds and bluetooth together at the same time and is why it is causing problems.

So thats as far as Ive been able to get.. And have posted a discussion on the intel support forums hoping to get some other in site as to why when bluetooth is enabled in the device manager does it cripple the wifi card on a high bandwith router/modems or is it some setting in the bluetooth i am missing...

So try and disable Bluetooth in the device manager and see if it fixes your Wireless N speed issues as it did for me. Smiley Happy You will need to disable bluetooth completely even if you dont have anything connected to it or are not even using the bluetooth. Because if the device is enabled, it causes the problem even if you are not even using it....

Ne ways please let me know if this fixes you problem as well. Hope it does Smiley Happy

0 Kudos
A1010A
Bronze

Re: Intel® Centrino® Wireless-N 1030 and slow internet connection

Jump to solution

Thanks for the suggestion.  I tried this, disabling the 2 places in Device Manager where Bluetooth appears.  However, in my case the Wireless N problems remain.  I also note from some other searches I did that there have been similar issues reported with the Centrino 6230 card.  My present thinking is that it is an incompatibility of some routers with these cards.

0 Kudos
markjv
Copper

Re: Intel® Centrino® Wireless-N 1030 and slow internet connection

Jump to solution

My son just recently had a similar problem. When he connected using an ethernet cable, speed was OK. When he connected to the router at school (type??) with wireless (Centrino 1030), his web pages loaded extremely slow. We removed Internet Security software (McAfee) and disabled Bluetooth.... no help. What fixed it for him was to enable his Wi-Fi devices (which are virtual devices derived from the wireless 1030 card).

0 Kudos
CelicaStorm
Copper

Re: Intel® Centrino® Wireless-N 1030 and slow internet connection

Jump to solution

I was also having issues with my wireless connections. Only thing that worked for me was going in to the advanced power saving options and selecting maximum performance for wireless adapter when on battery. Appears to have resolved my problems.

Hope this helps

0 Kudos
Kieran79
Bronze

Re: Intel® Centrino® Wireless-N 1030 and slow internet connection

Jump to solution

Hello,

I have recently purchased a XPS L702x which came with the N 6230 wireless network card and have the same issue connecting to my Virgin Media SuperHub.

The only solution that is working for me is to disable N mode in the adapter settings and make a few changes in the router which as mentioned above post caps @ 20MB which does not help people like me who have just paid to upgrade to the 30/50MB services.

None of the suggestions about disabling Bluetooth helped in my case but it may work for you Smiley Happy

- Right click my computer and open properties

- Device Manager

-  Network Adapters 

- Right click on the Intel Advanced N 6230

- Advanced tab

- Highlight  802 11n Mode and change to disabled and press ok

- Close to desktop and the wireless connection will reconnect 

- Open web browser and go to http://192.168.0.1

- Enter you username and password for the router which if you have not changed is Admin and changeme

- Click advanced settings link at bottom 

- Untick Firewall and IP Flood Detection

- Save and close

- You should now have a stable connection

If this is the only device you connect to your Virgin SuperHub via wireless and or all other devices support 5GHZ wireless N then you can get full speed and do not need to disable wireless N in device manager.

- Open web browser and go to http://192.168.0.1

- Enter you username and password for the router which if you have not changed is Admin and changeme

- Click on Wireless settings box

- Move from 2.4 Ghz to 5 Ghz and save

- Click advanced settings link at bottom 

- Untick Firewall and IP Flood Detection

- Save and close

- You should now have a stable connection at you full max connection rate.

Please can anyone post a reply if they can connect to their SuperHub using an Intel N 6230 wireless card with N mode enabled.

I hope the steps above help for now!

0 Kudos
mc-obesity
Copper

Re: Intel® Centrino® Wireless-N 1030 and slow internet connection

Jump to solution

bought the exact same laptop as you with the same router and the EXACT same problem

The disabling the bluetooth devices worked a treat for me, (never use bluetooth so no issue for me)

Just make sure you disable them all, theres like 6 dotted around device manager

I like how dell dont seem phased about this issue at all, typical dell for me ha

just a heads up on what worked for me Smiley Happy (Dell get your act together! test your products...)

0 Kudos
J Hoop
Copper

Re: Intel® Centrino® Wireless-N 1030 and slow internet connection

Jump to solution

All the items discussed in this thread sound exactly what I am experience.  I just bought a XPS 15 with a 6230 Intel card.  Internet speeds seem to be fine with loading pages, but my problem is with streaming videos.  There is excessive buffering when streaming videos.  Have the rest of you experieced this as well.  I have updated all drivers and have set the power settings to maximum performance.  I have disabled 2 of the bluetooth items but it sounds like there may be more that I should locate an disable.  I have not turned of the N mode for my router but will try. 

Just looking for a sanity check to make sure I'm trying the right things.  Any other recommendations would be greatly appreciated.  Thanks

0 Kudos