Networking, Internet, & Bluetooth

Last reply by 02-18-2013 Unsolved
Start a Discussion
2 Bronze
2 Bronze
170392

Laptop will not connect to wireless automatically after sleep mode

Hi there, 

I have a Dell Inspirion M5110. Windows 7, 64 bit.

When ever I open the lid to the laptop it takes 5-10 mins before it will automatically connect to a network. Diagnose this network does not find anything, nor provides any troubleshooting.  Typically if I open the network connections center and disable the wireless, let it sit for 30 secs or so, and re-enable, it will finally connect.

I know it's not my router, as the laptop does the same thing at work, and multiple different friends house.

I've confirmed that DHCP is set to automatic connect. I've also checked Device Manager/Network adapters/ and unchecked the box "allow the computer to turn off this device to save power"

Any suggestions would be greatly appreciated.

Replies (3)
Dell Technologies
3752

Hi kiellew,

There are a few steps that you can try, Please follow the below mentioned steps:

  1. Click “Start”, type “Power options”, and then click “Settings” on the right hand side. Click “Power options” from the search results.
  2. On the Select a power plan page, click Change plan settings for the plan that you want to change.
  3. On the Change settings for the plan page, click “Change advanced power settings”.
  4. On the “Advance settings” tab, expand “Wireless adapter settings”, expand “Power saving mode” and change the settings to “Maximum Performance”.
  5. Click Apply and then Ok to save changes and exit.
  6. Restart the computer and check.

If the above options do not work please try changing the settings for wireless card in Device manager.

Please follow the below mentioned steps;

  1. Click “start”.
  2. Type “Device Manager” in the search box.
  3. Select “Device Manager “in the list.
  4. Double click “Network Adapters”.
  5. Right click the wireless card.
  6. Select “Properties” and set "Transmit Power" to maximum and "Roaming Aggressiveness" to lowest setting.
  7. Restart the computer to save changes and check.

Please post the results.

2 Bronze
2 Bronze
3752

Nikhill,

Thank you for the help. I was able to check the first steps. Both on and off battery are set to Max Performance. I restarted the laptop and still had to manually connect to my network.

With the second steps, when I view the properties of my wireless card, I don't find anything that in regards to Transmit Power. I did see  "Roaming Tendency" and it's set to moderate, which is the lowest.

Any other suggestions would be appreciated.

Thank you

Dell Technologies
3752

Hi kiellew,

Please check in safe mode with networking if you are able to go online.

To check in safe mode with networking follow the below steps:

  1. Restart the computer.
  2. Keep tapping F8 on the Dell Logo Screen.
  3. Once the computer enters Advanced Boot Option, select Safe Mode with Networking.
  4. Press Enter.

Check if the computer is able to go online wirelessly in safe mode with networking.

If you are able to go online using the wireless network in safe mode with networking reboot the computer normally and run MS fixit. Use the below link

Link: http://bit.ly/HPsyBy

Click the link above and select Run now.

Please post the results.

Latest Solutions
Top Contributor