Highlighted
2 Bronze

M4800 Owners : Linux Problems. Finding Drivers.

Jump to solution

My Config:
Intel Core i7-4900MQ Processor (Quad Core, 8M Cache, 2.8 GHz, w/HD Graphics 4600)
16GB (2x8GB)600MHz DDR3L
39.6cm (15.6") UltraSharp QHD+ (3200x1800) Wide View Anti-Glare LED-backlit Premium Panel Guarantee
NVIDIA Quadro K2100M w/2GB GDDR5
2.5 inch 500GB Solid State Hybrid Drive(Will be replacing this with the Samsung 840 Pro 256GB SSD I already own)
2X Blu-Ray Writer Tray Load
9-cell (97Wh) Lithium Ion battery with ExpressCharge
Dell Wireless1550 2X2 802.11ac + Bluetooth 4.0
Internal English Backlit Dual Pointing Keyboard

Smartcard Reader Base for QHD+ Panel and Windows 8
SWIPE Fingerprint Reader and Smart Card Reader (Contact and Contactless) Palmrest,Dell Precision M4800
Bezel cam/mic QHD+
Back cover QHD+ panel WiGig
180W AC Adapter
Red Hat Linux Enterprise 6.4 English Year RHN
ProSupport 3 years: 7x24 Technical Support & Assistance, NBD, Global

Linux Problems:

Removed RHEL 6.4 and got Fedora 19(due to habitual use) setup with dual boot Windows 7.

Have been facing some touchpad issues. It some times does not recognize the touch! Cant' find dedicated drivers.

Got Nvidia video drivers installed. Screen looks good but cannot set to a lower resolution(1920x1080)! Screen overflows! i.e. I can only see about 25~30% of a fully maximized window rest overflows out of the screen. If anyone was able to set this up properly, please share your xorg.conf. I believe this is a panning issue. Am I right?

And have not been able to find network drivers for DELL 1550.
PCI ID : BCM4352

b43 and b43legacy says it's still not supported.

Broadcom BCM94352HMB with Chip 1: Broadcom BCM4352 says there is a driver available here Broadcom : Linux STA driver Although the readme says support for 4352(not BCM4352) has been added, trying to build a kernel loadable module gives a Error 2: no rule to make target 4352. Just indicates that DELL 1550's chipset is not yet supported which contradicts the readme file!

Has anyone has been able to find a linux network driver for Dell Wireless 1550 ?

TIA

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Not applicable

RE: M4800 Owners : Linux Problems. Finding Drivers.

Jump to solution

You can find a driver in rpmfusion-nonfree-updates

akmod-wl.x86_64                                                     6.30.223.141-1.fc19.2                                        @rpmfusion-nonfree-updates
broadcom-wl.noarch                                                  6.30.223.141-1.fc19                                          @rpmfusion-nonfree-updates

This driver seems to work but I have difficulties : wirless link survives at most one hour and sometime during only a few seconds. I have posted a bug report to  bugzilla.rpmfusion but at the present time I don't know if the problem comes from the kernel, NetworkManager or the driver.

Looking to the Netlink messages with

iw --debug event -t

I notice some frames with a nlmsg_len=44 and a payload length of 28 bytes wich generate the message "disconnected (by AP)" and after that all the attempts to reconnect fail

So at the present time my wireless link is still nearly unusable.

Any information about this problem  ( successful or unsuccesful)will be welcome

View solution in original post

0 Kudos
7 Replies
Highlighted
7 Gold

RE: M4800 Owners : Linux Problems. Finding Drivers.

Jump to solution

questions best asked at http://www.fedoraforum.org

0 Kudos
Highlighted
Not applicable

RE: M4800 Owners : Linux Problems. Finding Drivers.

Jump to solution

You can find a driver in rpmfusion-nonfree-updates

akmod-wl.x86_64                                                     6.30.223.141-1.fc19.2                                        @rpmfusion-nonfree-updates
broadcom-wl.noarch                                                  6.30.223.141-1.fc19                                          @rpmfusion-nonfree-updates

This driver seems to work but I have difficulties : wirless link survives at most one hour and sometime during only a few seconds. I have posted a bug report to  bugzilla.rpmfusion but at the present time I don't know if the problem comes from the kernel, NetworkManager or the driver.

Looking to the Netlink messages with

iw --debug event -t

I notice some frames with a nlmsg_len=44 and a payload length of 28 bytes wich generate the message "disconnected (by AP)" and after that all the attempts to reconnect fail

So at the present time my wireless link is still nearly unusable.

Any information about this problem  ( successful or unsuccesful)will be welcome

View solution in original post

0 Kudos
Highlighted

RE: M4800 Owners : Linux Problems. Finding Drivers.

Jump to solution

Have you found a solution to get the Smart Card reader to work by now?

I'm just starting to look into getting my M4800 to run with Debian or (X)ubuntu.

Cheers

  Mike

0 Kudos
Highlighted
Not applicable

RE: M4800 Owners : Linux Problems. Finding Drivers.

Jump to solution

Got Nvidia video drivers installed. Screen looks good but cannot set to a lower resolution(1920x1080)! Screen overflows! i.e. I can only see about 25~30% of a fully maximized window rest overflows out of the screen. If anyone was able to set this up properly, please share your xorg.conf. I believe this is a panning issue. Am I right? 

My solution:
1. turn off NVIDIA Optimus at BIOS, and then install a Linux distro (mine is Debian wheezy 7.3.0),
2. download NVIDIA K2100M driver from : http://www.nvidia.com/Download/index.aspx?lang=en-us
3. and run the driver with sudo in init 3 text-mode environment : http://rolling-ubuntu.blogspot.com/2012/06/ubuntu-1204-tip-booting-to-text-mode.html 
4. most probably NVIDIA installer will request you to install gcc, make, kernel headers, etc, so you just follow the requirement as the installer is your boss now,
5. reboot 

So far, I have not found a stable Linux distro bundled with kernel which is enable to run switchable VGA in Intel processor and dedicated NVIDIA VGA. Perhaps, some gurus can provide a better solution here... 🙂

 

0 Kudos
Highlighted
Not applicable

RE: M4800 Owners : Linux Problems. Finding Drivers.

Jump to solution

Has anyone had any success with the dell supplied ubuntu image:

http://linux.dell.com/files/ubuntu/precise/12.04-OSP1/

I haven't been able to get the wireless working on it even after installing the dell drivers:

M4800_M6800_A03.fish.tar.gz

0 Kudos
Highlighted

RE: M4800 Owners : Linux Problems. Finding Drivers.

Jump to solution

The current 14.04 (X)Ubuntu works reasonably well.

SD Card Reader               OK

WLan (1601)                  OK

LAN                          OK

Smartcard/Fingerprint Reader NOK

4G Modem (DW5570)            NOK

DPMS: X Wake up the display  NOK 

 

My current priority is to get the DW5570/MC8805 working, then the Smartcard Reader (0a5c:5802).

For the moment I forbid DPMS to shut down the display, but that is definitely not a longterm solution. ie I change the timeout values from  Standby: 1200, Suspend: 2400, Off: 3600 to 0, 0, 0 --> xset dpms 0 0 0

The drivers enclosed in the M4800_M6800_A03.fish.tar.gz archive
were of not much use to me since they do not match the for me relevant devices.

 

0 Kudos
Highlighted
Not applicable

RE: M4800 Owners : Linux Problems. Finding Drivers.

Jump to solution

Fedora 20 "success" with 3rd party network card here:

I tried the latest broadcom drivers under fc20 via rpm - no luck - they disconnected frequently (within 30s). I also tried via building from source and they failed to build.

I had similar problems on my x220 laptop 2 years ago. So I bought a replacement card on ebay for it. Pulled that from the x220, slotted in the dell, and presto! Solid internet and no headaches.

>lspci

...

03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

Also running a 750GB 840EVO ssd and 16gb of additional ram I picked up from newegg. I haven't figured out how to use an integrated headset (mic+headphones on single connector like the iphone headphones). Anyone got that working?


NVIDIA drivers were also a problem. Noveau worked but had tearing and mouse ptr update issues on screen #2. Tried installing NVidia drivers which blacklisted noveau and black screened on 2nd boot. Also tried rpm nv drivers from repoforge, but no luck. Bumblebee worked, but no HDMI/DP out. This was all on Bios v3. Drop nv drivers and reinstall, no luck.

So I updated the bios to v7, did a fresh fc20 install, turned off dual-card support in bios, and rpm-installed the NV drivers. That worked and I've got HDMI+DP. working. Better power support might be nice, but it works for now. Has anyone gotten Bumblebee running with HDMI+DP out on this laptop? I'd like to get the better power profile of the intel graphics if possible.


Trackpad appears to work fine for me. Shift+PgUp on the numeric keypad doesn't work in xterms, but num-pg-up works in emacs/elsewhere.


Only other anomaly I've seen is on hitting mute on the speakers and then plugging in a headset. The volume control goes back on for the headset but distorts sound. Unmute when speakers out, and then replug headset, and I'm clean on audio again.

Skype also fails under fc20, but that's a pulseaudio problem:

PULSE_LATENCY_MSEC=30 skype

works to invoke it.

0 Kudos