Network Controller gives a explanation mark and Question mark in Device manager

Hi all,

Since today, I am not able to connect to my wireless network through my computer (Dell Latitude E5430) with OS Windows 10 64-bit.

I made sure that the "airplane" mode is off. It just gives the WiFi signal with a red cross.

Yesterday, this red cross appeared as well, but then I was able to fix it with the "troubleshooter"

When I check now the device manager, it shows

 Uninstalling this "Network Controller" through the device manager, Scan for Hardware changes and trying to install the driver again as shown below, doesn't work.

If I check then the properties, it gives me the following message:

The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.

To find a driver for this device, click Update Driver.

 


Updating the driver as instructed shows me;

I have already tried to install the driver through the Dell Website, but then I get the following error;

After this didn't help me at all, I did a reset of my PC, where I installed my Windows 10 again. Clean installation.

This also didn't help me fix this issue.

Can someone please help me out on this one? Please let me know if you need some more information.

Best Regards,

Richard Heerink

0 Kudos
7 Replies
Highlighted
8 Krypton

RE: Network Controller gives a explanation mark and Question mark in Device manager

0 Kudos

RE: Network Controller gives a explanation mark and Question mark in Device manager

Hi ieee488,

First of all I would like to thank you for your quick reply. Unfortunately, this did not resolve my issue.

When installing the Dell Wireless 1540/1550/1560 WiFi Driver:  Network_Driver_P73MT_WN32_7.35.317.0_A02.EXE | Update Package for Microsoft® Windows® (65 MB)

It gives me the following error;

Dell Wireless 1540/1550/1560 WiFi Driver  

v7.35.317.0 (A02) October 15, 2015  

 The update installer operation is unsuccessful.


I have saved as well the Installation Log of this error. If needed, I can provide this.

In the device manager, it keeps showing up as an "other devices" with a rectangular ! symbol, and a round ? symbol. Updating the driver from there still doesn't work.

I really have no Idea how this happened. It happened from 1 day to another without me making any changes.

Are there some other idea's / tips that can help me?

Thanks in advance.

0 Kudos
8 Krypton

RE: Network Controller gives a explanation mark and Question mark in Device manager

You followed the install order?

0 Kudos

RE: Network Controller gives a explanation mark and Question mark in Device manager

Hi ieee488,

Indeed I did follow the correct order.

Drivers for Service Tag <Admin Note: removed per privacy policy~RK>:

Shows the following categories.

- Application

- Audio

- BIOS

- Chipset

- Mouse, keyboard & input devices

- Network

- Serial ATA

- System Management

1. I started with the System Management;

- Systems-Management_Application_K82GG_WN32_2.1.0_A00.EXE

2.Then I started with the 3 chipset drivers;

- Intel(R) Management Engine Components Installer Driver

- ST Microelectronics Free Fall Data Protection

- Intel Chipset Driver

3. Because there is no Security category, I skipped 3, and went to 4. Intel Matrix Storage Manager.

- Intel Rapid Storage Technology Driver and Management Console

This download doesn't work. Intel Rapid Storage Technology gives me the following error;

* The setup program ended permaturely because of the following error:

"This platform is not supported"

5. Audio drivers:

- IDT 92HD93 High-Definition Audio Driver (Success)

6. Video Driver -> Because this was not in the list, I went to 7. Network Interface card or ethernet drivers. There were no Network Interface Card or Ethernet drivers (Just Dell Wireless 1540 WiFi driver and a Dell Wireless Bluetooth Driver).

I skipped point 7 as well, and went to 8. Point 8 was also not on my list, so I went to point 9. Dell Quickset. There is an application category, but this shows only: "Dell Digital Delivery Application". So I skipped this one as well and went to point 10.

10. Wireless Network Drivers:

- Dell Wireless 1540/1550/1560 WiFi Driver (Network_Driver_P73MT_WN32_7.35.317.0_A02.EXE)

This goes download gives me an error: The update installer operation is unsuccessful.

!!Installation log is safed on my desktop!!

11. Bluetooth drivers:

- Dell Wireless 380/1550/1560 Bluetooth Driver. Installation successful.

Unfortunately, the problem remains. Any other tips?

0 Kudos
8 Krypton

RE: Network Controller gives a explanation mark and Question mark in Device manager

No idea.  Maybe try A01 version of the wifi driver?

0 Kudos

RE: Network Controller gives a explanation mark and Question mark in Device manager

No success either.

Both V01 and V00 give me the same error.

I have also entered the BIOS mode, and the WiFi card is enabled there.

I forgot to mention, maybe it will help. My computer is a: Latitude E5430 non-vPro

0 Kudos
8 Krypton

RE: Network Controller gives a explanation mark and Question mark in Device manager

How about try re-seating the wifi card?

Otherwise, I am out of ideas.

0 Kudos