Highlighted
MrAkamai
Bronze

Optiplex 990 & Intel 82579LM NIC issues

Hi everyone,

I purchased an Optiplex 990 desktop and it has an integrated Intel 82579LM NIC and Win 7 Pro 64-bit. I am currently on my third PC/motherboard and all have had the same issue.

I boot the PC and go through the set-up process. Then I enter my network settings. But the icon for the NIC alternates between "Network cable unplugged" and "Enabled" and sometimes "Identifying". I am using a known good cable and port as I have a Dell Vostro that uses that same cable and port and can access the internet. I have a short video I can post somewhere to show what is going on.

I have a SonicWALL firewall but I added the NIC's MAC address to the DHCP server so that should not be an issue. I do not need to add this PC to the domain controller unless I want to grant access to other network resources. The Vostro I mentioned earlier does not have access to the domain controller but has internet access. This should rule out the firewall.

Dell tech came on site to swap out the original motherboard (2ND motherboard) and same issue. Dell built a new PC (3RD motherboard/new PC), same configuration, and it, too has the same issue.

Here is what I have tried so far:

1. I tried several different cables and different ports on the switch but nothing changes.

2. I performed a secure erase of the drive and fresh install of the OS and drivers off the recovery media, no change.

3. Install of drivers off Dell support site, no change.

4. Install of "generic" Intel driver, no change.

Now I have ordered a real PCIe NIC (Intel EXPI9301CTBLK) and should arrive soon. Assuming it works, it should prove to Dell that there is something wrong with the on-board Intel NIC and perhaps they got a bad batch of this particular one and I got three from that batch. How unlikely? Somewhat but that's all I can think of at the moment.

Has anyone else ordered an Optiplex 990 desktop with Win 7 64-bit recently and having the same problems? My Dell tech originally stated that I was the only one with this problem but then I received an email from his manager and he said that they are busy with similar problems which is why I am getting delayed responses from my Tech. I wish I could get a straight answer what is going on with these PCs. Anyone else care to guess?

Thanks,

GregW

PS: Here is the video in the "Files" section:

http://en.community.dell.com/support-forums/network-internet-wireless/m/networking_internet_wireless/19874463.aspx

0 Kudos
49 Replies
Moderator
Moderator

Re: Optiplex 990 & Intel 82579LM NIC issues

GregW,

 

2. I performed a secure erase of the drive and fresh install of the OS and drivers off the recovery media, no change.

Did you install the desktop/notebook system utility and the chipset drivers first? If not, the rest of the drivers will fail to install. How to Download and Install Drivers in the Correct Order

 

I don't have QuickTime installed, so I could not view the video.

 

Is the network adapter enabled in the BIOS?

 

What do you see in the device manager?

 

Try running Finding System Information remove your product Id and post the rest of the information back here.

 

Are you getting any error messages? If so, the exact error message.

 

 

Rick

#DellRockstar

What is a Dell Service Tag and how do I locate it? 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

#DellWorld 2012

#DellWorld 2015

#DellEMCWorld 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

0 Kudos
MrAkamai
Bronze

Re: Optiplex 990 & Intel 82579LM NIC issues

Hi Rick,

Thanks for your reply!

1. I did not see that file about correct install order but I will perform another erase and follow that.

2. I posted another version of the video (m4v format) so I hope you can view that one. I apologize as I cannot figure out how to rotate the video so you'll have to turn your head to view. Sorry.  Smiley Happy

3. I did not verify BIOS settings but that is something I will look into. But I'd imagine it would be if I can install drivers for it and it's recognized once I do.

4. If I remember correctly it is not in device manager until I install drivers. I will verify.

 

Thanks!

GregW

0 Kudos
Moderator
Moderator

Re: Optiplex 990 & Intel 82579LM NIC issues

GregW,

 

My suspicions are you didn't install the desktop/notebook system utility and the chipset drivers, first.

 

Start installing the desktop/notebook system utility and the chipset drivers, then follow the order. Everything should start working. The desktop/notebook system utility and the chipset drivers have some drivers for the devices that are connected to your computer, like USB ports, wireless adapters, webcams, etc. It doesn't contain the complete drivers for some on the items but enough to connect the devices to install the drivers. Hope that made sense.

 

 

Rick

#DellRockstar

What is a Dell Service Tag and how do I locate it? 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

#DellWorld 2012

#DellWorld 2015

#DellEMCWorld 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

0 Kudos
MrAkamai
Bronze

Re: Optiplex 990 & Intel 82579LM NIC issues

Hi Rick,

The drive is getting brainwashed at this time so I need to wait for that to complete before I can start over. I printed the install order sheet and will follow that religiously. starting with the chipset drivers. But what I find very strange is the 990 performed the same way out of the box. Which means, if you are correct in your theory, Dell imaged the 990's drive incorrectly, too, and any other 990s for that matter. At least the ones I've received, anyway.

Brainwash should be complete in 1.5 hrs or so then I can resume software installation.

Thanks!

GregW

0 Kudos
Moderator
Moderator

Re: Optiplex 990 & Intel 82579LM NIC issues

GregW,

 

That's long.

 

Restoring Your Computer´s Software to the Factory Settings might be quicker and it puts everything back to the way it was when you got the computer, unless it is corrupt or removed. A new Hard drive doe not have it.

 

How To Restore or Reinstall Microsoft® Windows® on a Dell™ Computer

 

 

Rick

#DellRockstar

What is a Dell Service Tag and how do I locate it? 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

#DellWorld 2012

#DellWorld 2015

#DellEMCWorld 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

0 Kudos
MrAkamai
Bronze

Re: Optiplex 990 & Intel 82579LM NIC issues

Rick,

I think the last time I used something like that I ended up with an OS selection menu that showed up after POST. I guess I feel better performing a secure erase so I won't get that menu for sure. I know it takes a while but I just like the assurance. Usually it doesn't take that long, I'm just going by what the device is telling me. It could say 150 min now but in ten minutes it might be 100 or so. I just start that and do other things and I check on it periodically until it's done.

 

GregW

0 Kudos
MrAkamai
Bronze

Re: Optiplex 990 & Intel 82579LM NIC issues

Rick,

I reinstalled the OS and followed the install order sheet with a few exceptions for items that do not apply such as items for notebooks. I did not see the Intel Matrix Storage installer on the CD or on Dell's support site. I performed the following steps: 1, 2, 5, 6, 7

Here is the system info you requested:

In Device Manager, it says this: Intel 82579LM Gigabit Network Connection

Even after following the steps I still have the same problem. Not sure if you've been able to view the other video but nothing has changed.

PS: I forgot to mention that the integrated NIC is enabled in the BIOS.

0 Kudos
Moderator
Moderator

Re: Optiplex 990 & Intel 82579LM NIC issues

 MrAkamai,

 

These look like Vista 64-bit drivers, so I would install these in the Vista Compatibility mode. Please read How to by-pass the Dell Download Manager Most of these will install and there may be a few that don't. Install these in the order posted and see if you can connect.

 

 

 

You installed theses in the Vista Compatibility mode ...

 

Dell System Software <ADMIN NOTE: Broken link has been removed / replaced from this post by Dell> and the Intel Chipset Software Installation Utility followed by the

 

Intel Unified AMT 7 Management Interface Driver <ADMIN NOTE: Broken link has been removed / replaced from this post by Dell>and Intel Identity Protection Technology (IPT) <ADMIN NOTE: Broken link has been removed / replaced from this post by Dell> and NEC USB 3.0 <ADMIN NOTE: Broken link has been removed / replaced from this post by Dell>

 

Broadcom 57XX Gigabit Controller <ADMIN NOTE: Broken link has been removed from this post by Dell>

 

Intel 825xx Gigabit Platform LAN Network Device

 

Dell Wireless 1520 802.11n PCIe WLAN for Desktops <ADMIN NOTE: Broken link has been removed / replaced from this post by Dell> 

 

Foxconn Serial / Parallel port PCIE add-in card<ADMIN NOTE: Broken link has been removed / replaced from this post by Dell>

 

 

Rick

#DellRockstar

What is a Dell Service Tag and how do I locate it? 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

#DellWorld 2012

#DellWorld 2015

#DellEMCWorld 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

0 Kudos
MrAkamai
Bronze

Re: Optiplex 990 & Intel 82579LM NIC issues

Rick,

I did not install Vista 64-bit drivers in Vista compatibility mode unless Dell's recovery media for Windows 7 64-bit does that automatically (which I doubt). Additionally, why would I need to install NEC USB 3.0, Broadcom and wireless drivers when my 990 doesn't have that hardware? Doesn't make sense to me. A friend of mine did some research on his own and told me that there seems to be an overwhelming number of issues regarding this particular NIC (and not just with Dell) and maybe that's the underlying cause especially with such a new OS such as Win 7. I think I will just wait for my Intel NIC to arrive and try that instead. I'm also getting tired of waiting for "ProSupport" from Dell to give me a straight answer, as well. They just leave me hanging.

 

Thanks,

GregW

0 Kudos