Highlighted
Jalapeno_Lt
1 Copper

SLOW WIFI (Browsers) when not charing (AC). Dell xps 13, 9360, i7 16 GB, 512 ssd, Killer wireless.

Jump to solution

Hi, i have read many answers / solutions. I have struggling with slow browsers for a few days already (almost a week). So maybe anyone could help:

COMPUTER: dell xps 13 9360, 16 gb, 512 ssd, i7. killer wireless 1353. Bios newest. Win 10). New fresh computer from shop (only few days), so no malware or anything.

Very slow browser. Chrome is jittering. Firefox is a little bit faster. Struggling with YouTube, Facebook, even this forum. But sometimes everything works. (when it is good speedtest: local server: 100/100 mbps. To usa 40/15 mbps). but sometimes its feel like i'm running windows 8 on Pentium 2 Smiley Very Happy. Impossible.

I googled a lot, and tried a lot. What i have determined:

  • Main problem is with browsers. because torrent is quite good. (up to 12 mbps). But it is not fair results (sometimes everything is good).
  • Sometimes everything is working quite good. Sometimes not.
  • Tired turn of/on hardware deceleration on browsers, changed plugins. etc.
  • Sometimes slower (dual band router from Cisco, 2,4 & 5 mhz) 2,4 bandwitch is working better than 5. (but not always. Maybe change of network is improving temporary experience or just feeling). Other PC's and mobile devices is working PERFECT. Not router problem.
  • At work, (where internet is slower and have many limits (ports, etc)) everything is working better.
  • After computer restart i see improvements. After sleep - problems appear more annoying.
  • Downloading new drivers from dell.com (not updating from device manager) has improved a little bit
  • Disabling the QOS packet sheduler option  worked only very little. But not overall & not always.
  • Uninstalling OneDrive & OneNote improved performance but not this current problem.
  • CMD: netsh interface tcp set global autotuninglevel=highlyrestricted - has helped a little but not a lot.
  • BIOS: SpeedStep disabling (performance) - helped (one of best improvements). But problem still exists.


Last observation (Just now) everything works almost good (of course after all steps above). But only wen AC cable (charging) is in. When everything is running on battery - Houston, we have a problem.

So my question is:

what could i try, to make this problem WIFI (without charging cable) improvement???
And overall browser speed ?








0 Kudos
1 Solution

Accepted Solutions
nikhiljaps
1 Nickel

RE: SLOW WIFI (Browsers) when not charing (AC). Dell xps 13, 9360, i7 16 GB, 512 ssd, Killer wireless.

Jump to solution

https://www.eightforums.com/tutorials/54127-power-options-add-remove-wireless-adapter-settings.html 

Use this link and then set power saving mode to max performance.

2 Replies
Luveno
1 Nickel

RE: SLOW WIFI (Browsers) when not charing (AC). Dell xps 13, 9360, i7 16 GB, 512 ssd, Killer wireless.

Jump to solution

I have the exact same experience on my 9360.  I went through all the troubleshooting and resolution steps mentioned here and the other "slow wifi" related thread.

I'm about to initiate a RMA.

0 Kudos
nikhiljaps
1 Nickel

RE: SLOW WIFI (Browsers) when not charing (AC). Dell xps 13, 9360, i7 16 GB, 512 ssd, Killer wireless.

Jump to solution

https://www.eightforums.com/tutorials/54127-power-options-add-remove-wireless-adapter-settings.html 

Use this link and then set power saving mode to max performance.