Abdullah 91
1 Copper

Vostro 3300 slow internet after upgrade to Win8

hi all,

I have a Vostro 3300, which was working very well, and when I upgraded my OS from Win7 to Win8 my internet speed through wireless connection became very low, I checked for a driver update but did not find any that is compatible with windows 8. I also tried some old Windows 7 drivers with and without "compatibility Mode" but still not working. I should also mention that when I connect to the internet through Ethernet, I get the full speed.

0 Kudos
3 Replies
DELL-Rajath N
4 Beryllium

Re: Vostro 3300 slow internet after upgrade to Win8

Hi Abdullah 91,

I suggest you to uninstall and reinstall the wireless adapter. This will refresh the drivers and may fix the issue and the drivers for Windows 8 are not available for Vostro 3300. To perform this, please follow the steps provided below:

1. Move the mouse pointer to the top right corner of the screen for the “Charms” bar to appear.
2. Click on “Search” and then on “Settings”.
3. In the Settings Search dialog box, type “Device Manager” and press Enter to open the Device Manager.
4. Click on the arrow beside “Network Adapters” and right click on the wireless network adapter listed.
5. Click “Uninstall”.
6. Restart the computer. Windows should load the driver automatically.

I hope the information provided is helpful. Please reply to this message if you need further assistance.

Thanks and Regards,
Rajath N
Dell Social Media and Community Professional
Order Status : http://dell.to/1fgKSTr
Download Drivers : http://dell.to/1hcxG98

0 Kudos
stthebeast
1 Copper

Re: Vostro 3300 slow internet after upgrade to Win8

Hi!

Had the same issue and I solved it after uninstalling the current driver and using the next driver instead:

www.dell.com/.../vostro-3300

Good luck!

Satha84
1 Copper

Re: Vostro 3300 slow internet after upgrade to Win8

Hi,

I have the same problem. My internet speed has dropped significantly after a windows 8 upgrade. I have tried uninstalling the network adapters and restarting, but that did not resolve the problem. My computer says that my network adapter is updated to the latest version. I also tried to install the driver from the link provided above, but I received an error during installation. Please let me know if there is a fix for this.

Thanks,

Satha

0 Kudos