Highlighted
sandeep.ydv2
1 Copper

Wifi not working

My brother bought me this laptop from US, I am usig it in India. I also have a Sony Vaio 1511AENB. While using the Wifi/ Broadband on the VAIO, it always worked fine since a year when I bought it. On this laptop it always showed Limited Connectivity through Wifi or using a LAN Cable. On diagnosing it showed IP Config problem with the WIFI. But when I took the laptop to the other room it used to get connected from the Wifi and also had a good connectivity. After a few days it used to work with the Wifi but once in a week only (in close range). Rest all days it used to show Limited Connectivity. But still my VAIO, with the same WIFi connection was working excellent.

Once I tried connecting this machine with the wifi and got the LIMITED CONN on my screen. I disconnected from the WIFI and swithced on to AIRPLANE MODE. I Swithc off the AIRPLANE MODE off and connected to the WIFI and there, it was working showing excellent connectivity. But it used to show LIMITED CONN sometimes and I repeated the steps and worked fine then. 

Now, I had got used to this solution and one day when I switched off the AIRPLANE MODE, the Lappy stopped detecting any WIFI connections(there are many around my place). And when I went to the SWITCH ON WIFI Settings, I saw my WIFI was off, when I turnedit on it showed the loading circles and then the on button shifted to OFF itself prompting-- "Could Not Turn On".

I am fed up of this machine as it is now only working with the LAN Cable. Pushed back to the early 2000's.

Please give a solution.

0 Kudos
1 Reply

RE: Wifi not working

Hi sandeep.ydv2,

I recommend you to flash BIOS and update the wireless drivers. Click on the link below, enter the system service tag and click Submit. Select the Operating system from the drop down list to get drivers for your system model:

http://dell.to/14Xsnmd

Next change the settings of the wireless care by following the steps given below:

1.     Open ‘Device Manager’ by clicking the Start button . In the search box, type ‘Device Manager’, and then, in the list of results, click ‘Device Manager’.
2.     When the device manager pops up, in the list please check for ‘Network adapter’.|
3.     Please click on the arrow mark beside ‘Network adapter’.
4.     You will find the wireless network card available on your computer.|
5.    Right click on Wireless card and select ‘Properties’.

  1. Next click on ‘Advanced tab’.
  2. Change Roaming Aggressiveness to Medium.
  3. Change the wireless channels in the ‘advanced card properties’ to 11 or 6 and Disable Bluetooth Collaboration.

Check if this helps. Also share the system model and Operating system information.

Thanks and Regards,
DELL-Sujatha K
Dell Social Media and Community Professional
#iwork4Dell
Order Status
Download Drivers

0 Kudos