Highlighted
ucsb94
1 Copper

Windows 8 SMB Issue

My wife wanted a new Dell Laptop to replace her aging Inspiron 1521 with Windows XP Pro (32-bit). On April 2nd, I bought her an Inspiron 15z Ultrabook 5523 Touchscreen with Windows 8 (64-bit) thinking it would be an upgrade. I can honestly tell you this is far from one. Connecting to my server via SMB is horribly slow be it via wireless (300Mb) or Cat5e ethernet (Gigabit). The laptop can mount the network shares after 3-5 minutes, but browsing them takes 10 minutes or more, then the connection either times out or File Explorer crashes if I try to do a file transfer or open a document on the server. My self-built Windows 7 64-bit Enterprise PC and her pink six year old Dell XP laptop take seconds to connect. Double and triple checked all the settings and cannot find a solution.  Ran all the Microsoft updates.  Installed the latest drivers for the wireless and built-in ethernet.  Mind you, the issue has nothing to do with Internet connectivity - that works fine.
 
Contacted Microsoft via TechNet and it appears all my settings server side are ok on top of the fact my other Windows PCs and Macs can connect to the server. (FYI, I'm a systems administrator, by trade.  Please don't tell me to reset my router or reboot the server.)
 
Attempted to do a factory restore using the Dell Backup and Recovery within Windows 8. But when I insert a 16GB USB Flash Drive for the restore, the clock spins asking me to Select Drive Below and does nothing. I tried using DVDs but after creating the first disk, the second disk gets an error.  I tried several times till I read on the forums there was an issue with the software.  I had been at it for hours and I could not proceed. Yet, I can mount and format the Flash Drive and the DVD drive could read and write to disks. When going into Task Manager to quit the application, it hangs there as well. Required a hard shutdown and restart.  After spending half the day looking for a lead, I discovered I had to flash the BIOS from A02 to A03 in order for the Dell Backup and Recovery Tool to work.  Brand new laptop (one week old) and I had to flash the BIOS.  Ridiculous!  Using the USB flash drive, I have done TWO factory restores including replacing the partitions and the issue still persists.
 
Wrote a review for this laptop and DonaldDforDell, Customer Reviews suggested I try one of his recommended links.  I don't have a Twitter account and the Facebook link he provided is broken.  His last link lead me to this forum.
 
Unless someone can explain to me why it takes so long to mount a network share via SMB and why File Explorer crashes so often, then I've pretty much given up on this laptop.  Hopefully, I can return this for a refund. So far, I have initated TWO emails for RMA and have yet to hear back.  I am really not happy at the moment and my wife is disappointed as well. She chose Dell out of all the brands out there based on her previous experience with the Inspiron 1521.  Not sure if the problem is with the hardware or the software but the overall experience has been a terrible one so far.
0 Kudos