RoscoeJames
1 Copper

Re: Wireless card seems slow on my XPS 14z

My son's problem appears to be fixed. Sort of. We've been watching it for about 10 days now to be sure it doesn't stop working again. Having enough technical background to understand what took place, here's what was done.

First the tech replaced the wireless card. No change. Then he replaced the antenna (just the physical antenna housed behind the screen), no change. Then he replaced the interface from the antenna to the motherboard. Change. This is a long black rectangular box item that sits below the keyboard and is surrounded by several components. Small cables in and out.

Once changed the laptop started working as it had the first three weeks my son had the machine. I say that because even then the machine didn't 'find' as many available connections as any of our other machines, and the signal strenghth was never as good as our other electronics in the house, but it worked. And it does again.

After watching the repair and given the location of this 'part' my best guess is that the problem is heat. This particular part is surrounded by other electronics and the ventilation is pretty limited. So my son is being careful about setting the machine down on his bed or a chair when it might not be able to get enough air through the bottom ventilation.

He now has his bluetooth back, his speed is solid, if just a little slower than his Sony Vaio and my own Dell, and he can work from anywhere in the house.

I only say sort of at the start of the post because the speed is off a little and he still doesn't appear to receive (find) as many available connections as every other piece of technology in the house, but it works.

So let me say thanks to Terry for taking notice and getting involved.

And let me just say - I still believe this is a design problem. Either the component replaced was (or still is) of poor quality, or the location of the component (where it can easily overheat) is the true design problem.

Thanks again, Terry.

RJ

0 Kudos

Re: Wireless card seems slow on my XPS 14z

Thanks for the update RJ

I am happy to read that wireless performance on your son's notebook is better and that the service seems to have helped.

TB

Specialize in Laptops, Mobile Devices
#IWork4Dell

0 Kudos
Highlighted
Ken in Chatt
1 Copper

Re: Wireless card seems slow on my XPS 14z

I have been following this thread and it suddenly ends when one person has a connection part replaced restoring it back to "fair" service.  Is everyone suddenly satisfied with their WiFI?  Has Dell contacted all the complainers and offered the fix?  If so, why have they not made comment?

Ken

0 Kudos
Wrenchead
1 Nickel

Re: Wireless card seems slow on my XPS 14z

We have two XPS 14Z's and funny enough I received a phone call from Dell yesterday asking about their performance. When I mentioned the wireless concerns, he said he would have a specialist contact me. I'll post here once I hear more.

0 Kudos
Wrenchead
1 Nickel

Re: Wireless card seems slow on my XPS 14z

I did receive a call from Dell tech support and they directed me to the following site: downloadcenter.intel.com/Detail_Desc.aspx. He instructed me to download and install the 15.1.1 driver and software. It is the "S" version. I told him that I already had that version installed and he stated that the software was also required as it had been modified to ensure correct settings on the wireless card. He also said that I would need to remove or roll back the 15.1.1 driver that was already installed.

The installation was uneventful and my connection appears stable. Although it will take more evaluation to determine how well this set up is, one positve thing I noticed immediately is that I have full bars on my connection icon for the first time at approximately 40' from my router. Previously it was two to three bars.

I will continue updates over the next couple of days.

0 Kudos
Drian
1 Copper

Re: Wireless card seems slow on my XPS 14z

Hi,

I tried to refresh my wireless card, but it told me I use the latest version.

If you want to solve this problem follow me and buy these items:

ogemraywireless.en.made-in-china.com/.../Sell-Mini-150Mbps-WiFi-USB-Adapter-Ralink-Rt5370-Chipset.ht...

or

TL-WN722N

It helps, but the dell not!

0 Kudos