davidperez74
1 Nickel

Wrong WWAN Card? No connection.

Hello all. New E7450 with antenna wires for the WWAN card. I purchased a Sierra Wireless EM7305/DW5809E card. Installed it and inserted my sim card. My card is an AT&T data card that is current and used only for Data on my Samsung Laptop. Works fine on there. Here is a few scenarios of what happened and how it is right now. My assumption is that I have the wrong card. When I read the description it says its for 4G/LTE, etc but carriers supported are Vodafone, Telstra. It does not say anything about AT&T. When I look at the Sierra Wireless website it shows the EM7355 as the correct card for AT&T. I know what you are all thinking, why not just return it and order the right card. Well, when I first the card in and inserted the sim card, I started the laptop up and went to connection manager and did a search for carriers under the  Mobile Broadband  section and it searched and found AT&T and actually worked for about 2 minutes. I then remembered that the seller had a link on his listing for the driver. I uploaded the driver and after that nothing. So here is what is happening and what I have tried.

1. Card Installed with windows driver installed automatically. Says no service, and when I try to find a service it just searches and searches. I know its installed and working because if I remove the sim it says, "insert sim". 

2. Download the driver from Dell after installing the card and the card goes away, I cannot see it anymore under the connection manager. I have to uninstall driver, remove card, restart and then install the card again.

Any ideas or suggestions?

0 Kudos
1 Reply
Azuj
1 Copper

Re: Wrong WWAN Card? No connection.

I have exactly the same problem with DW5809E and Latitude E5450. First install it worked fine with Windows 10 default driver. When I upgraded my driver to the Dell driver then something went terribly wrong. I even reinstalled the whole Windows 10 but the wwan card never worked again. I think that the Dell driver did something to the wwan card firmware and it stopped working. Very frustrating.

0 Kudos