Highlighted
johnnyontheweb
1 Copper

dell studio 1555 intel wifi link 5100 stopped working

Hi all,

in my laptop Dell Studio 1555 the wifi card Intel Link 5100 AGN has stopped working without any error messages when I tried to connect to and Andriod AP on a Cyanogenmod phone (I specify this because I was already using wifi network form android phones without any problem, but never with cyanogenmod rom).

After that, my wifi card has been corrupted in some way, and it doesn't connect to any network, but it is still able to see them. No matter if the network is protected or not.

I read many similar messages in this forum, and I tried almost all the advices I found. Amongst them, I checked:

1- the My Intel WiFi 5100 AGN Connectivity Settings from Rock-Star Rick K

2- any issue in ipconfig /all

3- I've reinstalled the driver, enabled/disabled many times this and other network interfaces, no solution

4- I tried to disable and then re-enabled the card in BIOS.

5- I tried almost any known versions of the intel drivers (actually, I'm not able to install the PROset, it terminates without no errors!!!)

6- I disabled the power saving in device manager

Finally, I'm running Windows 7 64bit. Now i'm using another USB wifi card but I want to revert to my intel 5100! Any clue? Is it possible that the card has been broken by a "misconfigured" wifi network (like the one from a cyanogenmod phone)?

thanks to any that will answer,

Giovanni

0 Kudos
1 Reply
Moderator
Moderator

RE: dell studio 1555 intel wifi link 5100 stopped working

Hi,

Sorry to hear about the problems you're having with that card.  I wouldn't think the card has been "broken" by a connection to that phone.  Well, broken as in "won't ever work again" or "physically broken".   It could be that the card has failed, physically, but I doubt that would happen due to a network connection. 

If this is a software issue I wonder about you not being able to install the Intel Proset.  You say it terminates without an error?  But the software doesn't install?  Do you know what version of Proset you're trying to install?  I'll see if I can find out more information about whichever specific version you're using.  Most of what I'm seeing doing a simple Google search so far are articles and threads that are a few years old.  Have you gone to the Intel support pages? ( https://communities.intel.com/community/tech/wireless )

You may be able to find someone there with a quick answer to why Proset won't install.  

Next quick question is have you tried to connect that system, using the Intel card, to an unsecured wireless network?  See if it connects, and if so, that would lead me to think it's an issue with any security settings.

Let me know the answers to the above questions, and if you're able to find out any information on the Intel pages and we'll see how else we can try to help you.

Todd

0 Kudos