compworks
1 Copper

network controller error "device cannot start code 10" (Dell D600 xp Pro)

Jump to solution

Hello All: I can't connect to the internet via integrated wireless card. I put a fresh copy of XP Pro on a formatted Dell D600. Everything works fine except for the network controller. The drivers seemed to install fine but It Displays an exclamation mark in the device manager. Only LAN shows in the network connections. I have uninstalled it and reinstalled it, in both regular and safe mode but same problem. I tested the wireless card in another unit and it worked (Broadcom. Bcm94306MPSG) so it's not the card. I updated the drivers using the Dell drivers and I tried the Broadcom drivers from their site as well. I also updated the BIOS and made sure wireless was enabled within the BIOS and Fn+F2. I checked for IRQ conflicts, I also reinstalled the OS again. I can connect to the internet via rj45 Ethernet but nothing seems to correct my integrated wireless card problem.

 

0 Kudos
1 Solution

Accepted Solutions
Davet50
6 Indium

Re: network controller error "device cannot start code 10" (Dell D600 xp Pro)

Jump to solution

Ok in know this sound silly but have seen it before are you sure your installing the correct driver for the card?

Another thing to try would be to boot into safe mode and try installing the driver there.

 Home Built Sandy Bridge P8P67 i7 2600k @ 4.5 GHz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
Dell Studio XPS 1645  Window 10 Pro

Forum member since 2003

6 Replies
Davet50
6 Indium

Re: network controller error "device cannot start code 10" (Dell D600 xp Pro)

Jump to solution

when you did the install did you reload your drivers as per these steps?

You might want to try loading/reloading the Chipset driver

 Home Built Sandy Bridge P8P67 i7 2600k @ 4.5 GHz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
Dell Studio XPS 1645  Window 10 Pro

Forum member since 2003

0 Kudos
Highlighted
compworks
1 Copper

Re: network controller error "device cannot start code 10" (Dell D600 xp Pro)

Jump to solution

I follow the correct order when I installed the drivers. I just tried reloading the chipset driver , still no luck Thanks.

0 Kudos
Davet50
6 Indium

Re: network controller error "device cannot start code 10" (Dell D600 xp Pro)

Jump to solution

Ok in know this sound silly but have seen it before are you sure your installing the correct driver for the card?

Another thing to try would be to boot into safe mode and try installing the driver there.

 Home Built Sandy Bridge P8P67 i7 2600k @ 4.5 GHz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
Dell Studio XPS 1645  Window 10 Pro

Forum member since 2003

compworks
1 Copper

Re: network controller error "device cannot start code 10" (Dell D600 xp Pro)

Jump to solution

I'm going to double check the driver and try it in safe mode again, Thanks!

0 Kudos
compworks
1 Copper

Re: network controller error "device cannot start code 10" (Dell D600 xp Pro)

Jump to solution

Yes, that does sound silly but per your advice I triple checked the drivers that i had installed and yes as "you have seen before", the drivers were the WRONG ones. I now haved installed the correct ones. Problem solved. I hope that does'not make me silly :). Thanks for the help because i was not going to check that I had the right drivers again because I thought I was sure. Thanks again!!

0 Kudos
Davet50
6 Indium

Re: network controller error "device cannot start code 10" (Dell D600 xp Pro)

Jump to solution

Nope don't worry about it. I wish Dell would cut down on the number of wireless cards they put into systems. I had this very issue when reloading a laptop for a friend and was even using the supplied Dell Driver disk. Tried for about 3 hours before I  double check the adapter that was installed into the system and wouldn't you know it the adapter that was in the computer was not listed on the drivers disk.

Anyways. Glad you are up and running. Happy computing and if you would be so kind as to mark this thread as solved for the benifit of others who may have a simular issue.

 

 Home Built Sandy Bridge P8P67 i7 2600k @ 4.5 GHz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
Dell Studio XPS 1645  Window 10 Pro

Forum member since 2003

0 Kudos