Highlighted
hbalmeida
Copper

Erro ao criar Espelhamento de Porta (Monitor Session) Force 10

Ir para a Solução

Boa tarde, Pessoal.

Estou tentando criar um espelhamento para monitorar a porta Gi0/48 na porta Gi0/13 de um Switch Force 10 denominado PMA01, porém ao tentar executar o comando Monitor Session, conforme abaixo, o console retorna a seguinte mensagem:

% Error: MG port is in L2 mode.

PMA-01(conf-mon-sess-3)#source gi0/48 destination gi0/13 direction both
% Error: MG port is in L2 mode.

Entendendo que a porta MG seria a porta de destino, tentei retirar a porta Gi0/13 do L2 Mode, com o comando "no switchport", porém retornou o seguinte erro:

PMA-01(conf-if-gi-0/13)#no switchport
% Error: Gi 0/13 Port is part of a non-default VLAN.

Abaixo segue as configurações de VLAN do Switch:

PMA-01#sh vlan

Codes: * - Default VLAN, G - GVRP VLANs, P - Primary, C - Community, I - Isolated
Q: U - Untagged, T - Tagged
x - Dot1x untagged, X - Dot1x tagged
G - GVRP tagged, M - Vlan-stack

NUM Status Description Q Ports
1 Inactive
101 Active T Po1()
T Po3(Gi 0/3-4,Gi 1/3-4)
U Gi 0/5-48
U Gi 1/5-36,46-48
641 Active VLAN-VIDEO T Gi 0/47-48
T Gi 1/46-48
U Gi 1/37-45
* 4094 Inactive

Após retirar a porta Gi0/13 da Vlan 101:

PMA-01(conf)#int vlan 101
PMA-01(conf-if-vl-101)#no untagged gi0/13

Tentei executar o comando "no switchport" novamente e o seguinte erro foi exibido: 

PMA-01(conf-if-gi-0/13)#no switchport

% Error: Port has Layer-2 config on it Gi 0/13.

A configuração da porta Gi0/13 é:

PMA-01(conf-if-gi-0/13)#show config
!
interface GigabitEthernet 0/13
no ip address
switchport
no spanning-tree
no shutdown

Notem que a VLAN que está selacionada com um *, que indica a VLAN default é a de número 4094 que está inativa. Tentei incluir a porta Gi0/13 nesta VLAN, mas isso não é permitido pelo console, por não existir o comando "untagged", conforme abaixo:

PMA-01(conf-if-vl-4094)#untagged gi0/13
^
% Error: Invalid input at "^" marker.
PMA-01(conf-if-vl-4094)#?
description Interface description
end Exit from configuration mode
exit Exit from interface configuration mode
mtu Configure interface MTU
name Configure vlan name
no Negate a command or set its defaults
show Show interface configuration information

Preciso de ajuda. Alguém poderia me auxiliar com esta configuração?

Desde já, agradeço.

Humberto Almeida

4 RESPOSTAS
Moderador
Moderador

RE: Erro ao criar Espelhamento de Porta (Monitor Session) Force 10

Ir para a Solução

Olá Humberto! Tudo bem?


Muito legal a sua dúvida! É bom ver que as pessoas estão tirando máxmo proveito do que os equipamentos oferecem.


Essas mensagens do F10 'as vezes não ajudam... Podia dizer logo a qual VLAN a porta está vinculada, não é mesmo?!


Mas ok, você está no caminho certo. Primeiro retirou a porta gi 0/13 da VLAN 101.


O detalhe é que a porta vai ficar vinculada 'a default VLAN. Neste seu caso, esta é a VLAN 4094 que por sinal está inativa.


Se você for no modo privilegiado e der outra vez o comando show vlan, vai confirmar isto.


E você bateu "na trave" ao tentar incluir na VLAN default. Na realidade você tem é que tirar a porta de destino de qualquer VLAN. O detalhe é que não se pode deixar uma porta sem nem sequer a VALN defaul associada. Então devemos transformar a porta em uma porta roteada (layer 3). Por isso, o correto seria dar o comando "no switchport" no modo de config da porta gi 0/13 logo após retirar da VLAN 101.


Depois disso você roda os comandos de port mirror normalmente.


Esperamos ter ajudado.

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

hbalmeida
Copper

RE: Erro ao criar Espelhamento de Porta (Monitor Session) Force 10

Ir para a Solução

Bom dia, Antonio.

Primeiramente eu gostaria de agradecer pela atenção à minha postagem.

Eu realizei todo o procedimento que você orientou. Retirei a GI0/13 de qualquer Vlan, conforme log abaixo:

PMA-01#sh int status
Port Description Status Speed Duplex Vlan
Gi 0/1 Uplink Rede Down Auto Auto --
Gi 0/2 Uplink Rede Down Auto Auto --
Gi 0/3 PMA-03 - Gi Up 1000 Mbit Full --
Gi 0/4 PMA-03 - Gi Up 1000 Mbit Full --
Gi 0/5 M1000e - CM Up 1000 Mbit Full 101
Gi 0/6 Down Auto Auto 101
Gi 0/7 Up 100 Mbit Full 101
Gi 0/8 Down Auto Auto 101
Gi 0/9 Down Auto Auto 101
Gi 0/10 Down Auto Auto 101
Gi 0/11 Down Auto Auto 101
Gi 0/12 Down Auto Auto 101
Gi 0/13 Interface d Down Auto Auto --
Gi 0/14 Up 100 Mbit Full 101
Gi 0/15 Down Auto Auto 101
Gi 0/16 Down Auto Auto 101
Gi 0/17 Down Auto Auto 101
Gi 0/18 Up 100 Mbit Full 101
Gi 0/19 Down Auto Auto 101
Gi 0/20 Down Auto Auto 101
Gi 0/21 Down Auto Auto 101
Gi 0/22 Down Auto Auto 101
Gi 0/23 Up 100 Mbit Full 101

Repare que a interface GI0/13 não está em nenhuma Vlan.

PMA-01#sh vlan

Codes: * - Default VLAN, G - GVRP VLANs, P - Primary, C - Community, I - Isolated
Q: U - Untagged, T - Tagged
x - Dot1x untagged, X - Dot1x tagged
G - GVRP tagged, M - Vlan-stack

NUM Status Description Q Ports
1 Inactive
101 Active T Po1()
T Po3(Gi 0/3-4,Gi 1/3-4)
U Gi 0/5-12,14-48
U Gi 1/5-36,46-48
641 Active VLAN-VIDEO T Gi 0/47-48
T Gi 1/46-48
U Gi 1/37-45
* 4094 Inactive Interface description

Ao executar o comando "no switchport" dentro do modo de configuração da interface gi0/13, o erro persiste, conforme abaixo:

PMA-01#config
PMA-01(conf)#int gi0/13
PMA-01(conf-if-gi-0/13)#show config
!
interface GigabitEthernet 0/13
description Interface description
no ip address
switchport
no spanning-tree
no shutdown
PMA-01(conf-if-gi-0/13)#no switchport
% Error: Port has Layer-2 config on it Gi 0/13.

PMA-01(conf-if-gi-0/13)#

Qual seria o próximo passo? 

Obrigado.

Humberto

Moderador
Moderador

RE: Erro ao criar Espelhamento de Porta (Monitor Session) Force 10

Ir para a Solução

Olá Humberto!


De fato, a interface Gi 0/13 não está associada a nenhuma VLAN.

Apenas mais um detalhe que eu mesmo esqueço dos Force 10: para poder tirar a porta de modo de operação em Layer-2 e colocar em Layer-3 (em outras palavras dar o "no switchport") você precisa primeiro desligar a interface com "shutdown".

Sim, essa pegadinha é muito chata!

Então:

shutdown

no switchport

no shutdown

Espero que você consiga resolver o problema fazendo a captura do tráfego com wireshark.

Até mais!

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

Moderador
Moderador

RE: Erro ao criar Espelhamento de Porta (Monitor Session) Force 10

Ir para a Solução

Olá, Humberto!

Tudo bem?

Olha, eu andei testando aqui em laboratório com um Force 10 S55 (firmware FTOS 9.9). Não foi possível conectar uma máquina nas portas de origem e destino do mirror mas pude reproduzir de modo bem similar o seu ambiente.

Veja, abaixo eu rodei um “show interfaces status” e podemos ver que a porta Gigabit 0/0 está na VLAN 10 e a porta giga 0/2 está na VLAN 20.

FTOS#show int status

Port     Description Status Speed    Duplex Vlan

Gi 0/0               Down   Auto     Auto   10

Gi 0/1               Down   100 Mbit Auto   --

Gi 0/2               Down   Auto     Auto   20

Gi 0/3               Down   Auto     Auto   --

Gi 0/4               Down   Auto     Auto   --

Vou usar a porta Giga 0/1 como origem (source) e a Giga 0/2 como destino (destination) no monitor session.

Isto vai ser próximo do que você tem, pois se eu usar aqui a porta Giga 0/2 antes de retirá-la da VLAN 20, o comando de monitor session vai falhar com a famigerada mensagem que você já conhece.

O comando show vlan nos comprova a que VLAN cada porta está vinculada. Segue abaixo:

FTOS#sh vl

 

Codes: * - Default VLAN, G - GVRP VLANs, P - Primary, C - Community, I - Isolated

Q: U - Untagged, T - Tagged

   x - Dot1x untagged, X - Dot1x tagged

   G - GVRP tagged, M - Vlan-stack, H - VSN tagged

   i - Internal untagged, I - Internal tagged

 

   NUM   Status   Description                     Q Ports

   10     Inactive                                 U Gi 0/0

   20     Inactive                                 U Gi 0/2

*   4094   Inactive                                

Portanto devemos agora retirar a porta Gi 0/2 da VLAN 20 para usar como destination. Apenas para comprovar a configuração, fiz um show running-config da interface VLAN 20.

FTOS#show run int vl 10 20

!

interface Vlan 20

no ip address

untagged GigabitEthernet 0/2

no shutdown

FTOS#

FTOS#conf

FTOS(conf)#int vl 20

FTOS(conf-if-vl-20)#no untag gig 0/2

FTOS(conf-if-vl-20)#end

FTOS#1w2d17h: %STKUNIT0-M:CP %SYS-5-CONFIG_I: Configured from console by console

 

FTOS#

FTOS#sh vl

 

Codes: * - Default VLAN, G - GVRP VLANs, P - Primary, C - Community, I - Isolated

Q: U - Untagged, T - Tagged

   x - Dot1x untagged, X - Dot1x tagged

   G - GVRP tagged, M - Vlan-stack, H - VSN tagged

   i - Internal untagged, I - Internal tagged

 

   NUM   Status   Description                     Q Ports

   10     Inactive                                 U Gi 0/0

   20     Inactive                                  

*   4094   Inactive                                 U Gi 0/2

Repare que a interface Gi 0/2 agora ficou vinculada a VLAN 4094 que é a default. Isto não deve ser um problema, pois a default VLAN é apenas para não deixar a porta desvinculada a qualquer VLAN. Tecnicamente, podemos agora dar um “no switchport”, transformando a porta Gi 0/2 em uma porta que não participa de VLAN (Layer 3). E de fato, foi o que eu fiz como vemos abaixo:

FTOS(conf-if-gi-0/2)#

FTOS(conf-if-gi-0/2)#no switchport

FTOS(conf-if-gi-0/2)#

FTOS(conf-if-gi-0/2)#exit

FTOS(conf)#

FTOS(conf)#monitor session 1

FTOS(conf-mon-sess-1)#source int gig 0/1 destination gig 0/2 direction both

FTOS(conf-mon-sess-1)#end

O que pode estar acontecendo para você é que a porta precisa ser colocada em Shutdown antes de ser configurada como L3. Ou ainda você vai ter que entrar na interface VLAN 4094 e configurar para Untag a porta gig 0/2. Talvez isso seja necessário em razão do seu firmware ser um pouco antigo ou o seu modelo de switch da família Force 10 ser diferente do meu de laboratório.

Espero que isto seja esclarecedor e que você consiga não apenas fazer o port-mirror mas acima de tudo resolver o problema que você está investigando.

Até mais!

 

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.