Highlighted
Sanl3n
Bronze

Excluir Roteamento entre VLANs

Ir para a Solução

Olá, 

Temos um Switch PowerConnect 7048 configurado com algumas VLANs e agora foi necessario alterar o Gateway da minha rede e preciso alterar o roteamento desse Switch, apontando para meu Firewall.

Meu roteamento estava assim:

 S 0.0.0.0/0 [1/0] via 10.105.111.16, Vl2

C 10.10.105.0/24 [0/1] directly connected, Vl1
C 10.105.109.0/24 [0/1] directly connected, Vl3
C 10.105.110.0/24 [0/1] directly connected, Vl4
C 10.105.111.0/24 [0/1] directly connected, Vl2
C 10.105.112.0/24 [0/1] directly connected, Vl5
C 10.105.113.0/24 [0/1] directly connected, Vl6
C 10.105.114.0/24 [0/1] directly connected, Vl7

Acrescentei em uma das Vlans o Roteamento apontando para meu Firewall.

S 10.105.112.0/24 [1/0] via 10.105.111.50, Vl2

Agora tenho 2 roteamento nessa VLAN e não estou conseguindo desativar o roteamento antigo.

S 0.0.0.0/0 [1/0] via 10.105.111.16, Vl2
C 10.10.105.0/24 [0/1] directly connected, Vl1
C 10.105.109.0/24 [0/1] directly connected, Vl3
C 10.105.110.0/24 [0/1] directly connected, Vl4
C 10.105.111.0/24 [0/1] directly connected, Vl2
C 10.105.112.0/24 [0/1] directly connected, Vl5    <- Roteamento antigo
S 10.105.112.0/24 [1/0] via 10.105.111.50, Vl2     <- Roteamento Novo
C 10.105.113.0/24 [0/1] directly connected, Vl6
C 10.105.114.0/24 [0/1] directly connected, Vl7

Preciso excluir o roteamento antigo e deixar apenas o novo. Tentei user o comando "no ip route" mas ele não exclui esse tipo de roteamento.

APAC-CC-01(config)#no ip route 10.105.112.0 255.255.255.0 10.105.112.254

Failed to delete static route

Creio que eu esteja fazendo alguma coisa errada, e gostaria muito de uma ajuda.

6 RESPOSTAS
Moderador
Moderador

RE: Excluir Roteamento entre VLANs

Ir para a Solução

Olá, Sanl3n!

Como é que tá? Tudo certo?

Sanl3n, esta dúvdia é bem oportuna pois muita gente não sabe que uma interface local também tem rota. Parece absurdo pois é uma rede diretamente conectada, mas os equipamentos que fazem roteamento usam isto para saber qual é a interface que eles vão usar para entregar o pacote no destino.

Tenho a impressão que você já sabe disso, Sanl3n, mas deixou passar batido a letra "C" antes do roteamento antigo e outros que estão na tabela de rotas.

É normal! Eu também faço isso de vez em quando. hehehehehe

Sanl3n, se você der o comando "show ip interface" , vai ver que a VLAN 5 deve ter o endereço 10.105.112.254 . Por isto existe aquela rota antiga que você não consegue retirar. E nem tem como!

Pelo que deu para ver do seu roteamento, tem a linha "S 0.0.0.0/0 [1/0] via 10.105.111.16, Vl2" então este é o seu default gateway atual, correto?

E você deseja passar a usar como gateway da rede o "10.105.111.50" , certo?

Se a resposta é positiva nas duas perguntas acima, então teremos que corrigir a rota que você adicionou:

  1. Remover a rota "S 10.105.112.0/24 [1/0] via 10.105.111.50, Vl2"
  2. Remover a rota "S 0.0.0.0/0 [1/0] via 10.105.111.16, Vl2"
  3. Adicionar o novo gateway da rede com "ip route 0.0.0.0 0.0.0.0 <ip correto do firewall>"

Se você quiser, pode me enviar o show running-config em msg. privativa aqui do fórum que depois eu coloco aqui somente a parte que interessa na solução com os comandos todos.

Espero ter ajudado.

Até mais!

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

Sanl3n
Bronze

RE: Excluir Roteamento entre VLANs

Ir para a Solução

Olá Antonio, 

Obrigado pela rápida resposta. 

Entendi perfeitamente, porem esqueci de mencionar alguns detalhes nessa minha dúvida, 

Eu vou precisar manter o gateway 10.105.111.16 porque não vou alterar a ourtras VLANs, portanto não posso mexer nessa configuração. 

S 0.0.0.0/0 [1/0] via 10.105.111.16, Vl2

Para uma outra realidade (WI-FI)eu criei uma VLAN que não existia e fiz o roteamento da seguinte forma. 

S 10.105.116.0/23 [1/0] via 10.105.111.50, Vl2 (essa é uma outra vlan)

Fazendo isso funcionou perfeitamente, porque foi uma VLAN nova. 

Porem agora tenho essa VLAN 5, e só nela quero apontar o roteamento para o IP 10.105.111.50

C 10.105.112.0/24 [0/1] directly connected, Vl5

Desculpa a ignorância, posso estar falando besteira, será que eu teria que tirar o IP e Mascara dessa VLAN 5 para não ter mais o roteamento "automático" dessa VLAN? E como fazer isso?

Obrigado.  

Moderador
Moderador

RE: Excluir Roteamento entre VLANs

Ir para a Solução

Perdão e obrigado pela correção, Sanl3n!

Realemente eu não vi direito que era outra range.

Pelo que estou entendendo, sim, Sanl3n, você vai ter que tirar o IP e máscara da VLAN 5.

Se eu entendi certo, você vai deixar o firewall rotear esta VLAN e não mais o switch mas somente para esta range, não é pra toda rede. Se for este o caso, o switch não precisa de IP na VLAN 5. Basta que o firewall esteja em uma porta da VLAN 5 e que os hosts desta VLAN usem o IP dessa interface do firewall como seu default gateway.

Espero não estar fazendo mais confusão, se não terei que fazer o diagrama de rede para entender! hehehehehe

Até mais!

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

Sanl3n
Bronze

RE: Excluir Roteamento entre VLANs

Ir para a Solução

Perfeito, é isso mesmo.. rs 

Então terei que tirar o IP da VLAN 5. Como faço isso?

Sanl3n
Bronze

RE: Excluir Roteamento entre VLANs

Ir para a Solução

Consegui resolver, retirei e funcionou...

APAC-CC-01>enable

APAC-CC-01#configure

APAC-CC-01(config)#interface vlan 5

APAC-CC-01(config-if-vlan5)#no ip address

Obrigado pela ajuda.. =D

Moderador
Moderador

RE: Excluir Roteamento entre VLANs

Ir para a Solução

Opa! Maravilha, Sanl3n!

Desculpa não responder antes.

Só não esqueça de salvar as configurações com

APAC-CC-01>enable

APAC-CC-01#configure

APAC-CC-01#copy running-config startup-config

Fico satisfeito por ter podido ajudar!

Abraço e até a próxima!

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.