Robsoncb1
2 Bronze

Limites em Link Agregation 6224 e 5424

Ir para a Solução

Pessoal,

Pretendo fazer LAG entre alguns switches 6224 e 5424, porém tenho algumas dúvidas antes, podem me ajudar:

1) O que é o limite de 8 que tem na configuração de LAG, seriam 8 canais possíveis de link agregation? Eu poderia nesse caso usar todas as portas do switch no canal 1?

2) Eu li mas não entendi muito bem, qual a diferença no link agregation passivo e ativo? No meu caso seria só para ligar um switch principal, fazendo LAG para os outros switches em portas trunk, seria melhor o ativo ou passivo? O tráfego é para cópia de arquivos, aumento de velocidade.

3) As portas que participam de link agregation são perdidas para conexão de servidores correto?

10 RESPOSTAS 10
Moderador
Moderador

RE: Limites em Link Agregation 6224 e 5224

Ir para a Solução

Olá, Robson!

Tudo tranquilo?

Legal você querer tirar mais proveito dos switches. Link Aggregation é um recurso muito bom para isso que você pretende pois você vai formar uma interface lógica que fisicamente são várias portas. Dessa forma, quando uma porta estiver ocupada transmitindo, ainda vão ter outras para outras transmissões simultâneas.

Mas vamos as suas dúvidas pontuais:

  1. O limite é de oito portas físicas para cada LAG. É o contrário do que você falou!
  2. O LAG tem dois modos de operação. No modo ativo vai ter uma negociação com o outro switch nas portas físicas para formar a interface lógica Port-Channel. No modo passivo isto não ocorre. Não há uma vantagem na performance do ativo sobre o passivo, Robson. Apenas no modo ativo caso o outro switch esteja cabeado errado ou mal-configurado, você vai estar protegido contra loop.
  3. Sim, você não vai mais poder usar as portas que participam da agregação a não ser que você desmanche o LAG por completo. Note que alguns servidores com placas de rede dual-port ou até quad-port podem fazer LAG. Geralmente os fabricantes de placa de rede chamam isso de "NIC Teaming" ou de "NIC Bond".

Era isso então! Espero ter ajudado!

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

Robsoncb1
2 Bronze

RE: Limites em Link Agregation 6224 e 5224

Ir para a Solução

Ok, Obrigado pelas respostas.

Voltando a pergunta 1:

1) O que é o limite de 8 que tem na configuração de LAG, seriam 8 canais possíveis de link agregation? Eu poderia nesse caso usar todas as portas do switch no canal 1?
RSmiley surpreso limite é de oito portas físicas para cada LAG. É o contrário do que você falou!

=> Então eu só poderia fazer um LAG com oito portas, correto ?
Vamos supor que no 5424 (A), eu use faça um LAG com 4 portas correto e este LAG conectado:
1) A um Switch 6224 (B) (4 Portas)
2) E a outro Switch 6224 (C) (4 Portas)
Eu esgotaria todos os Link Agregrations do 5224 (A) ?

Moderador
Moderador

RE: Limites em Link Agregation 6224 e 5224

Ir para a Solução

Muito bem, Robson!

Estamos no caminho certo!

No caso, como você vai conectar dois switches diferentes no LAG vai ter que fazer dois LAGs diferentes.

Vai ser um LAG para cada switch 6224.

LAG 1 vai usar 4 portas físicas para conectar no switch B. Depois tem ainda o LAG 2 para conectar 4 portas físicas no switch C.

Você ainda pode fazer outros LAGs se precisar.

Veja bem, Robson, o limite de 8 é a quantidade de portas físicas que fazem parte do LAG.

Então, se o switch tem 24 portas, você pode ter três LAGs de 8 portas físicas (3x8=24). Aí não sobra mais porta física para fazer nada. Mas isso é um caso extremo. Geralmente as pessoas criam LAGs com duas ou quatro portas físicas.

Espero ter ajudado!

Até a próxima!

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

Highlighted
Robsoncb1
2 Bronze

RE: Limites em Link Agregation 6224 e 5424

Ir para a Solução

Ok, entendi.

Tenho mais algumas dúvidas, se puder me ajudar:
Todos os Switches A, B e C, estão na VLAN 4.
1) Configurei o LAG do 6224 (B) entre as portas 19-22 correto. É necessário por o canal desse LAG na VLAN 4 ? OBS.: O mesmo se conecta ao A, também com as portas na VLAN 4.




2) Estou tentando configurar o LAG no 5424 (Corrigi o tópico, antes havia falado 5224) por linha de comando e não estou tendo sucesso:

console# config
console(config)# interface range ethernet g(19-22)
console(config-if)# channel-group 1 mode on
Port g19 belongs to a vlan
Port g20 belongs to a vlan
Port g21 belongs to a vlan
Port g22 belongs to a vlan

console# show interfaces port-channel 1

Load balancing: Layer 2.

Gathering information...
Channel Ports
------- -----
ch1

Não vejo o LAG criado no comando final, nem na interface WEB.
Recebo informaçoes ao rodar o comando:
Port X belongs to a vlan

Tem idéia do que devo fazer no 5424 para configurar ? 

No 6224 usei as linhas de comando dele e funcionou.







Moderador
Moderador

RE: Limites em Link Agregation 6224 e 5424

Ir para a Solução

Excelente, Robson!

Você vai precisar deixar as portas físicas com a configuração default antes de juntar em um LAG.

Basta você retirar da VLAN4.

Inclusive o LAG 1 depois não deve ser da VLAN4. O correto é o LAG ser uma porta TRUNK. Ou seja: "T" de Tagged, "T" de Transporte , "T" de Trunk.

Por favor, Robson, leia com atenção os posts aqui do fórum sobre interligar switch com trunk.

Até mais!

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

Robsoncb1
2 Bronze

RE: Limites em Link Agregation 6224 e 5424

Ir para a Solução

Ok, eu realmente tirei as portas 19 até 22 da Vlan e coloquei na default 1. E fiz com sucesso no 6224.






-----------

Só que no 5424 - Habilitei o LAG entre essas portas 19-22, o mesmo tipo de configuração do 6224:


Mas quando tento no Browser adicionar as portas 19-22 em modo Trunk na Vlan 4, ocorre este problema como na foto:




No terminal até consigo por eles na Vlan 4, mas quando vou na interface web, não vejo a mesma ativada:

Comandos:
interface ethernet g19
switchport mode Trunk
switchport trunk allowed vlan add 4

Realmente já limpei e fiz as configuração no 5424 umas 3 vezes e não sei onde posso estar errando, andei vendo nos tópicos e como os comandos variam entre os Switches um pouco, não achei uma referência muito clara para o 5424.
Andei vendo pela internet e parece que ele parece não aceitar Trunk + Lag, alguns falam em configurar como General, mas ainda não consegui achar uma solução.





Moderador
Moderador

RE: Limites em Link Agregation 6224 e 5424

Ir para a Solução

Olá Robson!

Que legal ver a sua evolução!

Eu acho que o seu 5424 está com um firmware muito antigo. Não reconheço esta sintaxe na linha de comando.

De qualquer forma, você está passando a VLAN 4 nas portas físicas. O ideal é fazer isso apenas no LAG que então as portas físicas vão herdar a config.

Segue aqui o que fiz no laboratório:

interface gigabitethernet1/0/19
 channel-group 1 mode auto
interface gigabitethernet1/0/20
 channel-group 1 mode auto
interface gigabitethernet1/0/21
 channel-group 1 mode auto

interface gigabitethernet1/0/20
 channel-group 1 mode auto

interface Port-channel1
 switchport mode trunk
 switchport trunk allowed vlan all

end

write

# show version

       Unit             SW version         Boot version         HW version
------------------- ------------------- ------------------- -------------------
         2               4.1.0.20            1.0.0.14            00.00.02

Se esta sintaxe não funcionar, tente como está abaixo, ok?

switchport trunk allowed vlan add 4 tagged

Fazendo isso tanto no 5524 quanto no 6224 deve aceitar o comanto.

Até a próxima!

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.

Robsoncb1
2 Bronze

RE: Limites em Link Agregation 6224 e 5424

Ir para a Solução

Olá Antônio,

Refiz as configurações nos switches 5424 e 6224, e realmente vi que agora o T ficou nas interfaces que compõem a LAG.

Tive que adaptar alguns comandos, vou postar aqui as configurações como ficaram:


5424:

interface ethernet g19
channel-group 1 mode auto
interface ethernet g20
channel-group 1 mode auto
interface ethernet g21
channel-group 1 mode auto
interface ethernet g22
channel-group 1 mode auto

interface port-channel 1
switchport mode trunk
switchport trunk allowed vlan add all

Esses comandos eu não consegui:
*switchport trunk allowed vlan add 4 tagged
*switchport trunk allowed vlan all
=> Corrigi para: switchport trunk allowed vlan add all

---------

show interfaces port-channel 1

Load balancing: Layer 2.

Gathering information...
Channel Ports
------- -----
ch1 Non-candidate: g(19-22)

Os ícones das interfaces 19, 20, 21, e 22 ficaram meio estranhos mesmo no Chrome:








6224:

interface ethernet 1/g19
channel-group 1 mode auto
interface ethernet 1/g20
channel-group 1 mode auto
interface ethernet 1/g21
channel-group 1 mode auto
interface ethernet 1/g22
channel-group 1 mode auto

interface port-channel 1
switchport mode trunk
switchport trunk allowed vlan add 4

Esses Comandos no 6224 não tive sucesso:
* switchport trunk allowed vlan add all
* switchport trunk allowed vlan add 4 tagged
* switchport trunk allowed vlan all
=> Tive que usar esse: switchport trunk allowed vlan add 4


---------------

show interfaces port-channel 1

Channel Ports Hash Algorithm Type
------- ----------------------------- -------------------
ch1 Inactive: 1/g19, 1/g20, 3
1/g21, 1/g22

Hash Algorithm Type
1 - Source MAC, VLAN, EtherType, source module and port Id
2 - Destination MAC, VLAN, EtherType, source module and port Id
3 - Source IP and source TCP/UDP port
4 - Destination IP and destination TCP/UDP port
5 - Source/Destination MAC, VLAN, EtherType, source MODID/port
6 - Source/Destination IP and source/destination TCP/UDP port






=> Aqui realmente não apareceu o 1 no PVID, será que há algum problema nisso ? 







Vou fazer o cabeamento e testar.

Será que agora está tudo certo ? 

Moderador
Moderador

RE: Limites em Link Agregation 6224 e 5424

Ir para a Solução

Olá, Robson!

Creio que está tudo certo! Não se apegue muito a sintaxe da linha de comando porque muda com a versão do firmware mas sempre se mantém a lógica/estrutura geral.

Podemos cabear e testar!

Até mais!

  Antonio Moraes
 Forum Moderator
 Enterprise ProSupport

Chat | Twitter | Facebook | 0800 970 3300

Clique em   aqui em baixo caso esta postagem tenha respondido à sua pergunta.