NTLDR is missing

I just replaced a hard rive on an OptiPlex GX280 given to my wife because all I could get from it was "NTLDR is missing."  I replaced a 40 Gb Western Digital HD with a new 160 Gb Western Digital HD and downloaded a Dell version of Windows XP Home Edition onto it.  Worked fine for an old Gateway with a new Western Digital and I thought surely it would work for another Dell.  Unfortunately, after installing the new HD we still get the message "NTLDR is missing."   Can't say how terribly disappointing it is.   I used a different computer to download the OS, but I'd gotten the "NTLDR is missing" from the old HD on three different computers (my way of troubleshooting); and could not boot it from my Installation CD.  Which is why I went for new.  Can anyone tell me why the "NTLDR is missing" message still comes up even on a new HD with a fresh updated OS?  What other hardware problem could it be?   

0 Kudos
1 Reply

Re: NTLDR is missing

Hi, bigotha:

If you get the "NTLDR is missing, press any key to restart", what's going on is that the BIOS didn't look for the right drive, didn't find the right partition, it wasn't active, didn't find the MBR, the MBR didn't list NTLDR in the right place,  the location of NTLDR changed, etc. 

If I understand correctly, you tried to install XP onto the 160GB drive while it was in a different computer, then installed it in the GX280. I'm not sure why you did that, but that's not the correct way to install XP. In fact the "NTLDR is missing" error is exactly what you should expect when moving a drive into a different computer.

Let me suggest you boot the GX280 using your XP disc and run the installation that way. During the installation process, delete all existing partitions and create a single system NTFS partition.

0 Kudos