Highlighted
2 Bronze

SupportAssist 3.5.0 will not load....

Jump to solution

SupportAssist 3.5.0 will not load. It just keeps saying to reboot and try again.

Optiplex 7010

Rebooted and reinstalled program and it still does not work.

 

0 Kudos
2 Solutions

Accepted Solutions
Highlighted
8 Xenon

Re: SupportAssist 3.5.0 will not load....

Jump to solution

The current version of support assist is not version 3.5

(CVE-2019-12280) Dell SupportAssist software is one of the reasons that its updated and a critical update.

 

its 3.5.0.448

https://downloads.dell.com/serviceability/catalog/SupportAssistInstaller.exe

 

The requirement for DOTNET 2.0 and 3.5 remains for support assist 3.5

 

To update manually, download and install the latest product version from:

Dell SupportAssist for Business PCs
https://downloads.dell.com/serviceability/Catalog/SupportAssistx64.msi
https://downloads.dell.com/serviceability/Catalog/SupportAssistx86.msi

Dell SupportAssist for Home PCs
https://downloads.dell.com/serviceability/catalog/SupportAssistInstaller.exe

 

Symptom

A windows-based PC displays the following error message while installing Dell System Detect.
Cannot continue. This application is improperly formatted. Contact the application vendor for assistance.


Cause

This error message occurs if Microsoft .NET Framework 4.5 is not installed on the PC or needs to be updated.

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

View solution in original post

0 Kudos
Highlighted
8 Xenon

Re: SupportAssist 3.5.0 will not load....

Jump to solution

Unfortunately every time they plug a hole in DOT NET 3.5 another one pops up.

July 14, 2020-KB4565627 Cumulative Update for .NET Framework 3.5 and 4.8 for Windows 10 Version 2004

I tried to reinstall Support Assist and got the DOTNET Missing Error because an update was issued today to address yet another flaw.

You may have to remove support assist and then reinstall it more than one time.

https://support.microsoft.com/en-us/help/4565627/kb4565627-cumulative-update-for-net-framework
CVE-2020-1147

http://catalog.update.microsoft.com/v7/site/Search.aspx?q=4565627

A remote code execution vulnerability exists in .NET Framework when the software fails to check the source markup of XML file input. An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the process responsible for deserialization of the XML content. To exploit this vulnerability, an attacker could upload a specially crafted document to a server utilizing an affected product to process content. The security update addresses the vulnerability by correcting how .NET Framework validates the source markup of XML content.

This security update affects how .NET Framework's System.Data.DataTable and System.Data.DataSet types read XML-serialized data. Most .NET Framework applications will not experience any behavioral change after the update is installed. For more information on how the update affects .NET Framework, including examples of scenarios which may be affected, please see the DataTable and DataSet security guidance document at https://go.microsoft.com/fwlink/?linkid=2132227.

To learn more about the vulnerabilities, go to the following Common Vulnerabilities and Exposures
https://nvd.nist.gov/vuln/detail/CVE-2020-1147

Windows 10 version history Date of availability End of service End of service
Windows 10, version 2004 May 27, 2020 December 14, 2021 December 14, 2021
Windows 10, version 1909  November 12, 2019 May 11, 2021  May 10, 2022**
Windows 10, version 1903 May 21, 2019 December 8, 2020 December 8, 2020
Windows 10, version 1809 November 13, 2018 November 10, 2020*** May 11, 2021
Windows 10, version 1803 April 30, 2018 November 12, 2019 November 10, 2020
Windows 10, version 1709 October 17, 2017 April 9, 2019 October 13, 2020

 




 

 

 

 

 

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

View solution in original post

0 Kudos
10 Replies
Highlighted
8 Xenon

Re: SupportAssist 3.5.0 will not load....

Jump to solution

SupportAssist does not support models from 2011 that came with XP Vista and Windows 7.

It requires windows 8.1 or 10 because windows XP/VISTA/7/8 are all end of life.

Its not for supporting models that were end of life in 2016 that parts are no longer available for. It also requires Microsoft .NET Framework 4.5 or higher.

https://www.dell.com/support/article/en-us/sln117738/dell-supportassist-formerly-dell-system-detect-...

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
Highlighted
2 Bronze

Re: SupportAssist 3.5.0 will not load....

Jump to solution

I appreciate your response, although it does lead to more questions... my PC does have Windows 10 which comes with .NET and also the link you posted doesn't say anything that would lead me to believe that this PC is not supported, it does however say that OptiPlex machines are supported.

Looking forward to your response.

 

0 Kudos
Highlighted
8 Xenon

Re: SupportAssist 3.5.0 will not load....

Jump to solution

DOTNET is not installed on ANY version of windows by default.

Older software also needs DOTNET 2.0 and 3.5 installed.

With 10 you launch the offline installer and it must download new features from the internet.

https://www.microsoft.com/en-us/download/details.aspx?id=25150

 Optiplex models go back 30 years now.  Models from 1990 to 2011 are not supported.  Parts are not available and Windows 10 is not supported on those models.   Newer systems with UEFI Class 2.3.1 bios like the 3020 7020 9020 are supported with windows 10 and have windows 10 drivers.

Dell OptiPlex computers that have been tested for update to Windows 10 May 2020 Update. If your computer model is too old, Dell is not testing the device, and drivers have not been updated for that model.

5 years is standard max support.  6 years and older are End of Life.

windows 10 started in 2015,   windows 8.1 in 2013,

all windows from 1.0 to 8.0 are end of life end of support.

Windows 10 1511 is not supported anymore by microsoft or dell

Current supported versions are

Windows 10 version history Date of availability End of service End of service
Windows 10, version 2004 May 27, 2020 December 14, 2021 December 14, 2021
Windows 10, version 1909  November 12, 2019 May 11, 2021  May 10, 2022**
Windows 10, version 1903 May 21, 2019 December 8, 2020 December 8, 2020
Windows 10, version 1809 November 13, 2018 November 10, 2020*** May 11, 2021
Windows 10, version 1803 April 30, 2018 November 12, 2019 November 10, 2020
Windows 10, version 1709 October 17, 2017 April 9, 2019 October 13, 2020

 

 

 

 

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
Highlighted
2 Bronze

Re: SupportAssist 3.5.0 will not load....

Jump to solution

You should do a little research before posting... dotnet framework is installed by default all the way back to Windows XP!

 

https://docs.microsoft.com/en-us/archive/blogs/astebner/mailbag-what-version-of-the-net-framework-is...

0 Kudos
Highlighted
8 Xenon

Re: SupportAssist 3.5.0 will not load....

Jump to solution

Windows 10 now comes with .NET framework 4.X pre-installed but earlier builds did not,  older apps developed in XP / Vista 7 and Windows 8 era require the .NET framework v3.5 installed along with 4.X

Windows has the .NET Framework 2.0/3.5  is an  OS component but it is NOT installed by default. 

https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/how-to-determine-which-versions-ar...

 

Thats why they have had a stand alone installer for some time now.

When you invoke the 3.5 sp1 standalone installer it will prompt you to install the "features"

https://www.microsoft.com/en-us/download/details.aspx?id=25150

https://support.microsoft.com/en-us/help/4054530/microsoft-net-framework-4-7-2-offline-installer-for...

Newer versions of 10 will have DOT NET 4.8 or higher partial install but the 2.0 3.5 and sp1 etc will not be installed.

Default installs from CD for XP and DVD for vista 7 8 10 etc do not have DOTNET installed by default.  These apps will not run unless you will install the required versions. When you try to run any such older app, Windows 10 will prompt you to download and install .NET framework 3.5 from the Internet. 

The current version of support assist is 4.x not 3.5

https://downloads.dell.com/serviceability/catalog/SupportAssistInstaller.exe

 

If you have OEM DVD you can

  1. Open ‘Command Prompt’ via ‘RUN As Administrator’ mode
  2. Type following command

C:\Windows\system32>Dism /online /enable-feature /featurename:NetFX3 /All /Source:G:\sources\sxs /LimitAccess

Note: Be sure to replace the G:\ with the drive letter where sxs media file present in  your local system, It may need to download from internet and need to copy manually if not present.

Now just hit Enter  and wait for the installation process to finish. Typically, the process will take a couple of minutes.

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
Highlighted
8 Xenon

Re: SupportAssist 3.5.0 will not load....

Jump to solution

You may not like The answer but the facts are unchanged.

NET Framework 2.0/3.5 is not included by default in Windows 10

https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/microsoft-net-framework-35-dep...

You can get the .NET Framework 3.5 payload files from Windows Update or the installation media in the \sources\sxs folder. For more information, see Installing the .NET Framework 3.5. After the .NET Framework 3.5 feature is enabled, the files are serviced just like other operating system files from Windows Update.

 

net35net35


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
Highlighted
2 Bronze

Re: SupportAssist 3.5.0 will not load....

Jump to solution

https://www.dell.com/support/contents/en-us/article/product-support/self-support-knowledgebase/softw...

 

Minimum Device Requirements:
Operating system: Windows 10, Windows 8.1, Windows 8, Windows 7, and selected Dell Chrome OS products (Not available on Linux, Windows RT, Windows 10S, Android)
Processor: 1.33 gigahertz (GHz)
Memory: 2 Gigabytes (GB)
Hard disk space: 2 Gigabytes (GB)
Display: 1024X768 screen resolution, 16-bit mode
Connectivity: Internet access required
Administrator rights on system installed
Network ports: 5700 (For opening the SupportAssist user interface ) and 9012 (For communication with Dell)

0 Kudos
Highlighted
8 Xenon

Re: SupportAssist 3.5.0 will not load....

Jump to solution

The current version of support assist is not version 3.5

(CVE-2019-12280) Dell SupportAssist software is one of the reasons that its updated and a critical update.

 

its 3.5.0.448

https://downloads.dell.com/serviceability/catalog/SupportAssistInstaller.exe

 

The requirement for DOTNET 2.0 and 3.5 remains for support assist 3.5

 

To update manually, download and install the latest product version from:

Dell SupportAssist for Business PCs
https://downloads.dell.com/serviceability/Catalog/SupportAssistx64.msi
https://downloads.dell.com/serviceability/Catalog/SupportAssistx86.msi

Dell SupportAssist for Home PCs
https://downloads.dell.com/serviceability/catalog/SupportAssistInstaller.exe

 

Symptom

A windows-based PC displays the following error message while installing Dell System Detect.
Cannot continue. This application is improperly formatted. Contact the application vendor for assistance.


Cause

This error message occurs if Microsoft .NET Framework 4.5 is not installed on the PC or needs to be updated.

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

View solution in original post

0 Kudos
Highlighted
8 Xenon

Re: SupportAssist 3.5.0 will not load....

Jump to solution

Unfortunately every time they plug a hole in DOT NET 3.5 another one pops up.

July 14, 2020-KB4565627 Cumulative Update for .NET Framework 3.5 and 4.8 for Windows 10 Version 2004

I tried to reinstall Support Assist and got the DOTNET Missing Error because an update was issued today to address yet another flaw.

You may have to remove support assist and then reinstall it more than one time.

https://support.microsoft.com/en-us/help/4565627/kb4565627-cumulative-update-for-net-framework
CVE-2020-1147

http://catalog.update.microsoft.com/v7/site/Search.aspx?q=4565627

A remote code execution vulnerability exists in .NET Framework when the software fails to check the source markup of XML file input. An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the process responsible for deserialization of the XML content. To exploit this vulnerability, an attacker could upload a specially crafted document to a server utilizing an affected product to process content. The security update addresses the vulnerability by correcting how .NET Framework validates the source markup of XML content.

This security update affects how .NET Framework's System.Data.DataTable and System.Data.DataSet types read XML-serialized data. Most .NET Framework applications will not experience any behavioral change after the update is installed. For more information on how the update affects .NET Framework, including examples of scenarios which may be affected, please see the DataTable and DataSet security guidance document at https://go.microsoft.com/fwlink/?linkid=2132227.

To learn more about the vulnerabilities, go to the following Common Vulnerabilities and Exposures
https://nvd.nist.gov/vuln/detail/CVE-2020-1147

Windows 10 version history Date of availability End of service End of service
Windows 10, version 2004 May 27, 2020 December 14, 2021 December 14, 2021
Windows 10, version 1909  November 12, 2019 May 11, 2021  May 10, 2022**
Windows 10, version 1903 May 21, 2019 December 8, 2020 December 8, 2020
Windows 10, version 1809 November 13, 2018 November 10, 2020*** May 11, 2021
Windows 10, version 1803 April 30, 2018 November 12, 2019 November 10, 2020
Windows 10, version 1709 October 17, 2017 April 9, 2019 October 13, 2020

 




 

 

 

 

 

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

View solution in original post

0 Kudos
Highlighted
2 Bronze

Re: SupportAssist 3.5.0 will not load....

Jump to solution

https://www.dell.com/support/contents/en-us/article/product-support/self-support-knowledgebase/softw...

 

Minimum Device Requirements:
Operating system: Windows 10, Windows 8.1, Windows 8, Windows 7, and selected Dell Chrome OS products (Not available on Linux, Windows RT, Windows 10S, Android)
Processor: 1.33 gigahertz (GHz)
Memory: 2 Gigabytes (GB)
Hard disk space: 2 Gigabytes (GB)
Display: 1024X768 screen resolution, 16-bit mode
Connectivity: Internet access required
Administrator rights on system installed
Network ports: 5700 (For opening the SupportAssist user interface ) and 9012 (For communication with Dell)

0 Kudos