Highlighted
admingirl
3 Silver

solaris super cluster server cannot mount /nfs mount on vnx even though...

Hello,

I created an NFS mount point on the VNX, added the hosts for read/write, root privileges. A new Oracle Super Cluster has been installed and I added the Super Cluster hosts.

We opened network ports for NFS to/from the the hosts to the VNX control station and primary data mover. Yet they still cannot mount the slices. Other hosts(not on the Super Cluster) on a different network can mount the nfs slices.

They are also using data pump.

Any input you have is greatly appreciated.

Admin

Tags (2)
12 Replies
dynamox
6 Gallium

Re: solaris super cluster server cannot mount /nfs mount on vnx even though...

super cluster, sounds important

can they run "showmount -e  datamover_interface"  from one of these hosts ?  This command will display all nfs exports available on that datamover.

admingirl
3 Silver

Re: solaris super cluster server cannot mount /nfs mount on vnx even though...

Thank you Dynamox! I will ask him to do that now.

0 Kudos
admingirl
3 Silver

Re: solaris super cluster server cannot mount /nfs mount on vnx even though...

I got the group to give me a login and I executed the command it just hangs. The version is Solaris 11.

0 Kudos
dynamox
6 Gallium

Re: solaris super cluster server cannot mount /nfs mount on vnx even though...

what firewall ports did you open ? Something is still blocking it.

admingirl
3 Silver

Re: solaris super cluster server cannot mount /nfs mount on vnx even though...

Thank you Dynamox, we opened

(UDP, TCP both ways) on the primary data mover and control station. Did not open for the failover datamover. Could that be causing it?


111

2049

4045

1110

0 Kudos
admingirl
3 Silver

Re: solaris super cluster server cannot mount /nfs mount on vnx even though...

2049, 4045 are for data pump

0 Kudos
zhaos2
3 Silver

Re: solaris super cluster server cannot mount /nfs mount on vnx even though...

If other hosts can mount the NFS from the same VNX, it is more likely that the issue is with Solaris itself or network side.  Here are steps for troubleshooting:

  1. From Solaris, ping the IP of data mover (the same IP which you use to mount the NFS export from VNX).  If ping is not working, it is a network issue.

  1. If ping works fine, use “/usr/sbin/rpcinfo –p <datamover’s IP>” on Solaris to check if the ports 2049/1234/111 on data mover can be connected.  A normal output should be as below:

   

    # /usr/sbin/rpcinfo -p server_2 |egrep "portmap|nfs|mount"

    100003 2   udp   2049  nfs

    100003 3   udp   2049  nfs

    100003 2   tcp   2049  nfs

    100003 3   tcp   2049  nfs

    100005 3   tcp   1234  mountd

    100005 2   tcp   1234  mountd

    100005 1   tcp   1234  mountd

    100005 3   udp   1234  mountd

    100005 2   udp   1234  mountd

    100005 1   udp   1234  mountd

    100000 2   udp    111  portmapper

100000 2   tcp    111  portmapper

If there is no output or it is timed out, the issue should be that the network router between Solaris and VNX filters traffic on these ports.

  1. If step 1 and 2 pass, on Solaris use “/usr/sbin/showmount –e <datamover’s IP>” to check the list of NFS exports.  If you can see the NFS export you want to mount, you can go ahead to mount it and see if there is any error.  Then the issue would be related with the NFS permission.

As per the problem description, I suppose the issue would be found from step 1 or step 2. 

admingirl
3 Silver

Re: solaris super cluster server cannot mount /nfs mount on vnx even though...

Thank you! Here is my output:

baulisano@efsdzdbclient010101:~$ ping 10.129.226.16

10.129.226.16 is alive

baulisano@efsdzdbclient010101:~$ /usr/sbin/rpcinfo -p 10.129.226.16

-bash: /usr/sbin/rpcinfo: No such file or directory

baulisano@efsdzdbclient010101:~$ rpcinfo -p 10.129.226.16

   program vers proto   port  service

824395111    1   tcp  50682

824395111    1   udp  49628

    100011    1   tcp  55233  rquotad

    100011    1   udp  62062  rquotad

536870914    1   udp   4658

536870914    1   tcp   4658

    100021    3   udp  63498  nlockmgr

    100021    2   udp  63498  nlockmgr

    100021    1   udp  63498  nlockmgr

    100021    4   udp  63498  nlockmgr

    100021    3   tcp  64240  nlockmgr

    100021    2   tcp  64240  nlockmgr

    100021    1   tcp  64240  nlockmgr

    100021    4   tcp  64240  nlockmgr

    100024    1   udp  49162  status

    100024    1   tcp  49162  status

    100003    2   udp   2049  nfs

    100003    3   udp   2049  nfs

    100003    2   tcp   2049  nfs

    100003    3   tcp   2049  nfs

    140391    1   udp  31491

    100005    3   tcp   1234  mountd

    100005    2   tcp   1234  mountd

    100005    1   tcp   1234  mountd

    100005    3   udp   1234  mountd

    100005    2   udp   1234  mountd

    100005    1   udp   1234  mountd

536870919    3   tcp  12345

536870919    1   tcp  12345

536870919    3   udp  12345

536870919    1   udp  12345

    102660    1   udp  50170

    102660    1   tcp  56752

    100000    2   udp    111  rpcbind

    100000    2   tcp    111  rpcbind

baulisano@efsdzdbclient010101:~$

It looks good, however, showmount -e just hangs. It's so odd, again, the nfs mount point is working on the other network.

Thanks so much!

0 Kudos
admingirl
3 Silver

Re: solaris super cluster server cannot mount /nfs mount on vnx even though...

baulisano@efsdzdbclient010101:/etc$ cat vfstab

#device         device          mount           FS      fsck    mount   mount

#to mount       to fsck         point           type    pass    at boot options

#

/devices        -               /devices        devfs   -       no      -

/proc           -               /proc           proc    -       no      -

ctfs            -               /system/contract ctfs   -       no      -

objfs           -               /system/object  objfs   -       no      -

sharefs         -               /etc/dfs/sharetab       sharefs -       no      -

fd              -               /dev/fd         fd      -       no      -

swap            -               /tmp            tmpfs   -     

0 Kudos