Highlighted
addavid
Bronze

alienware et linux

Je possède un alienware 15R3. J'ai installer linux dessus (opensuse Leap)

Mon problème, est impossible d'installer la carte nvidia gtx1060, que se soie via le dépôts openssuse nvidia ou depuis la version télécharger sur le site nvidia.

de plus impossible d'utiliser la sortie hdmi, je pense que problème soit lié.

avez vous une solution au problême?

merci

Balises (1)
0 Compliments
9 RÉPONSES
Modérateur
Modérateur

RE: alienware et linux

Bonjour Addavid,

L'Alienware 15 R3 n'a pas été testé avec Linux et nous ne disposons pas des pilotes nécessaires pour ce système d'exploitation.

Je vous oriente à poser la question au support de Nvidia (c'est possible qu'ils ont déjà une solution) ou de tester avec une autre version du pilote.

Je laisse le soin aux personnes ayant eu ce souci de vous aider.

Bonne journée,

Abdel

0 Compliments
lee lloyd
Bronze

RE: alienware et linux

Salut ADDAVID,

J'ai réussit à installer linux Mint 18 sur l'Alienware 15R3 en multi-boot. Mais seulement après avoir activer l'IGP (Optimus) via la touche IGP/DGP sous Windows. En mode DGP l'écran restait noir pour l'installation.

Une fois Mint et le driver propriétaire NVIDIA installé via le dépôt officiel, il est possible de re-basculer en mode DGP ONLY sous Windows. Mais avec pour conséquence un problème de banding sous Linux (visible sur les fond dégradés) surement lié au passage de 8Bpc en 6bpc sur l'affichage principale.

Il vaut mieux rester en mode Optimus (IGP) sous Linux. Les performances restes correctes car la carte dédié d'NVIDIA fait du "passtrough" pour les rendu 3D quand nécessaire. Pour des applications OpenCL ou CUDA je n'ai pas encore essayé.

En espérant  que ça pourra te donner des indices sur la marche à suivre pour Suse.

Bonne chance.

0 Compliments
Modérateur
Modérateur

RE: alienware et linux

Bonjour Lee Lloyd,

Je vous remercie pour votre aide concernant ce sujet.

Cordialement,

Abdel

0 Compliments
addavid
Bronze

RE: alienware et linux

merci du retour

par contre tu as une solutions pour les lumière

0 Compliments
lee lloyd
Bronze

RE: alienware et linux

Si tu parles des Tron-lights et du retro éclairage du clavier et touchpad : Non pas encore de solution directement depuis Linux. Je passe par Windows et AlienFX.

0 Compliments
addavid
Bronze

RE: alienware et linux

merci

c'était bien des Tron-lights que je parlé. dommage d'il y a pas un menu dans le bios pour géré sa. (ou dans le menu boot)

par contre j'arrive pas à affichez quoi sur dans l'hdmi

sur kde, il affiche un message "No external Display" qui clignote en permanence quand je branche un vidéoprojecteur dessus

0 Compliments
lee lloyd
Bronze

RE: alienware et linux

Avec le bureau Cinammon Mon 2eme écran est reconnu automatiquement.

Et via nvidia-settings plutôt que le gestionnaire d'affichage de KDE ?
Pour lever le doute, essaye aussi de brancher un autre type d'affichage (écran ou TV).

0 Compliments
addavid
Bronze

RE: alienware et linux

j'arrive pas a t’utilisai le port hdmi

si j'installe bumblebee => rien ne marche

j'ai installer le drivers nvidia depuis le dépots opensuse/nvidia

les 2 carte graphique semble détecter

sur lspci -v j'ai :

00:02.0 VGA compatible controller: Intel Corporation Skylake Integrated Graphics (rev 06) (prog-if 00 [VGA controller])
        Subsystem: Dell Device 0772
        Flags: bus master, fast devsel, latency 0, IRQ 127
        Memory at db000000 (64-bit, non-prefetchable)
        Memory at 70000000 (64-bit, prefetchable) [size=256M]
        I/O ports at f000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [40] Vendor Specific Information: Len=0c <?>
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [100] #1b
        Capabilities: [200] Address Translation Service (ATS)
        Capabilities: [300] #13
        Kernel driver in use: i915
        Kernel modules: i915
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1c20 (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Dell Device 0772
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at dc000000 (32-bit, non-prefetchable) [size=16M]
        Memory at b0000000 (64-bit, prefetchable) [size=256M]
        Memory at c0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at e000 [size=128]
        Expansion ROM at dd000000 [disabled] [size=512K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [250] Latency Tolerance Reporting
        Capabilities: [258] L1 PM Substates
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [420] Advanced Error Reporting
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Capabilities: [900] #19
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia


par contre, j'aimerais voir ton configuration Xorg

0 Compliments
lee lloyd
Bronze

RE: alienware et linux

Mon xorg.conf généré par nvidia-settings :

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 361.42  (buildd@lgw01-18)  Tue Apr  5 14:33:28 UTC 2016

Section "ServerLayout"
    Identifier     "layout"
    Screen      0  "Screen0" 0 0
    Inactive       "intel"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SDC"
    HorizSync       53.0 - 66.0
    VertRefresh     47.0 - 59.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    Option         "AccelMethod" "None"
    BusID          "PCI:0@0:2:0"
EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    Option         "ConstrainCursor" "off"
    BusID          "PCI:1@0:0:0"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1070"
EndSection

Section "Screen"
    Identifier     "intel"
    Device         "intel"
    Monitor        "Monitor0"
EndSection

Section "Screen"
    Identifier     "nvidia"
    Device         "nvidia"
    Monitor        "Monitor0"
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "1920x1080_60 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Mais là c'est en mode DGP.

0 Compliments