Highlighted
YorickT
Bronze

Graphic Card not working in Dell Power Edge 840 Server

Jump to solution

Hello all

I got a Dell PowerEdge 840 Server for free and want to use it as a normal pc at home. Is that possible first? It has Windows 7 installed and works fine, only the graphic card is really bad for videos and so on. Lags in full screen and games doesnt work at all. I bought a new one with a normal PCI slot (I think the PowerEdge doesnt have a PCI-e) 

http://www.amazon.de/ATI-Radeon-Grafikkarte-Anschluss-%C3%A4lternen/dp/B007XDTIS2/ref=sr_1_32?ie=UTF8&qid=1344267004&sr=8-32

I inserted it in one of the free slots and plugged it in. I still have an Image via VGA but the graphical performance didnt increase. I checked the device manager and it says there is a failure at the PCI-PCI bridge. First it says device not working. I delete it and reinstall it and it says Code 12, device has no resources. Please help, I got no Idea, what to do now Smiley Sad

Cheers!

0 Kudos
18 Replies
theflash1932
Diamond

Re: Graphic Card not working in Dell Power Edge 840 Server

Jump to solution

A server is different from a desktop, and as long as you do not expect it to always work like you would expect a desktop to work, then it can be your friend.  Servers, while they might appear similar to desktop hardware, were designed for a very different life from that of a desktop, and as such, is less versatile but is also more robust and powerful.

Dell servers (except for a handful of their very latest models) have never "officially" supported graphics cards.  That is not to say it won't work, but those who have tried needed to use a significant amount of trial/error to find one that will work.  Complications range from not being able to disable the onboard video in the BIOS (and no method to disable automatically like with many desktops), to insufficient system resources available to allocate to such a card.

I would start with a Google search to see what cards (if any) people have been able to get working in the 840.  I would also make sure your system firmware (BIOS, ESM/BMC, etc.) is up to date.  If your 840 has a DRAC in it, you will probably need to remove it.

0 Kudos
YorickT
Bronze

Re: Graphic Card not working in Dell Power Edge 840 Server

Jump to solution

Thanks this was already quite helpful. Can i just install every driver when its for a PowerEdge 840 or is there a desktop with the same name too? Mhhh I'm not sure if it has a DRAC, it has a thing in the first PCI slot, which is connected to the hard disks...but when I remove it it didnt boot anymore. Or is a DRAC a program or something? I already checked and the graphic card shares its IRQ with some others, not sure if that may cause the problem...I will ask google for another graphic card. Could you just help me with the DRAC?

0 Kudos
theflash1932
Diamond

Re: Graphic Card not working in Dell Power Edge 840 Server

Jump to solution

The card in the first slot is your RAID/storage controller, which explains 1) why your drives are connected to it, and 2) why it wouldn't boot when you took it out.

The DRAC (Dell Remote Access Card) is a card used to provide access and information remotely even when the server will not boot ... this includes BIOS/POST screens, hardware logs, console redirection, and even remotely mounting floppy and CD/DVD media.  See the documentation below for the location ... the card will have its own dedicated NIC.

If you install Windows 7 and have devices in Device Manager still showing as "unknown" or not working, then you can use a Server 2008 R2 driver in the absense of a Windows 7 driver (Dell has no Windows 7 drivers for their servers - you might be able to find one at the actual device manufacturers' websites).  A Server 2008 R2 driver will obviously not work for Windows 7 32-bit, as R2 only comes in 64-bit ... in this case - and in the absence of a W7 driver - you might be able to simply use a Server 2008 x86 driver.

There is only one PowerEdge 840, and there is no correlation between a PowerEdge model and any desktop model.

0 Kudos
theflash1932
Diamond

Re: Graphic Card not working in Dell Power Edge 840 Server

Jump to solution

Here is the link to the DRAC in the PE840:

support.dell.com/.../P7878A00.pdf

0 Kudos
YorickT
Bronze

Re: Graphic Card not working in Dell Power Edge 840 Server

Jump to solution

Aaaah indeed I have something similiar under the RAID/storage controller thing. But it only has the thing to put the network cable in. I thought it was for the internet. It got no card video connector. Should I remove it? I think the graphic card always shares its IRQ with slot 1 (the RAID thing). Or try the Server 2008 R2 driver first? Actually the only problem showing in the device manager is the PCI-to-PCI Bridge which says Code 12. I think the manager doesnt even show the graphic card up as unknown. Another thing I dont understand is: Im already USING the new graphic card, I put the VGA cable on the new graphic card but the quality is the same as if I put it on the onboard. Can it be that the card is actually working (showing up the startup and such) but not using its "own" power (it has 1GB storage). If the PCI Bridge/Port wasnt working it should just show up a black screen isnt it? Smiley Surprised

0 Kudos
theflash1932
Diamond

Re: Graphic Card not working in Dell Power Edge 840 Server

Jump to solution

It does not have a video connector, because it interfaces with the integrated video ... which is why you have to remove it for any hope of running an add-in controller.  Your DRAC should also show as some "PCI" device in Device Manager, so remove it and see what you have left.

If your graphics card is actually giving you output (I was under the impression it did not work at all), then yes, you need a driver.  Windows 7 driver for that card would be best.  Does your card require additional power to it (above what the PCI slot provides)?

0 Kudos
YorickT
Bronze

Re: Graphic Card not working in Dell Power Edge 840 Server

Jump to solution

Aah ok so I just remove the hardware isnt it? No need to remove something out of the device manager first? Yes it is giving output, just not in the quality it is supposed to. I installed the driver from the CD already too (came with the card), maybe there are missing some chipset drivers or something? It has no additional power source, just the pci slot.

0 Kudos
theflash1932
Diamond

Re: Graphic Card not working in Dell Power Edge 840 Server

Jump to solution

The chipset and BIOS work together to manage system hardware, to identify the device and its requirements, then to assign the necessary resources to it.  Normally, the chipset driver should be installed first, so that all subsequent hardware can be installed properly, but in this case, there seems to be no chipset driver for this version of Windows.  You could go to Intel.com and let it scan to see if there are any drivers it can find to install/update, but chances are, Windows 7 already has the code.

0 Kudos
YorickT
Bronze

Re: Graphic Card not working in Dell Power Edge 840 Server

Jump to solution

Ok i visited Intel and it actually found a newer chipset driver but that didnt change anything. updated the drivers for the graphic card too and removed the DRAC thing. Will try around with the IRQ again, cause graphic card still lags...

when I visit Control Panel and check the hardware then display and under resolution there is a adv. settings link. It comes up with the properties of the graphic card. In the info section everything is on not avaiable. Under Properties again it opens up the properties of VGAsave and under Resources  it comes up with 3 conflicts with E/A-areas or something. Any ideas left?

0 Kudos