MattTopping
1 Copper

320 Megaraid/fakejbod issues...

Not sure if this is the right subsection of the forum, but here we go anyway....

I'm using a R320 and trying to set the disks in a fake Jbod array in a Debian Wheezy PXE using the following command:

'megacli -cfgeachdskraid0 -aall'

However I am getting the return 'There is no configurable physical drive on adapter 0.'

What is odd is that the server is definitely picking up the disks, as the following command always returns 4 - 'megacli -pdlist --aall | grep 'ID' | wc -l'. I can also clear configuration using 'megacli -cfgclr -aall' and 'megacli -cfgforeign -clear -aall.' The same error also occurs when using the alternative '-CfgLdAdd -r0[Enclosure:Slot] -a0' command.

I am able to create an array using the raid controller, and am able to run the command by setting the disks as 'RAID capable' in the raid controller first - but this does not explain why I am getting the error when the disks are non-raid when the command has worked with disks marked as non-raid hundreds of times before.

This is the first time I have encountered this error accross many, many 320s, and my immediate thought was to swap out the hardware with spare parts - but replacing the PERC, Backplane, and cables, as well as trying different hard drives all give the same response.

I'd appreciate any help or insights, as I am ready to hit my head against a brick wall here! Please let me know if you need any more information!

(The same error also appears in a Debian Jessie PXE)

0 Kudos