M1Combat
Not applicable

Breaking a RAID 1 on a CERC SATA 1.5/2s (RAID 1 capacity upgrade)

Good day all...  

 

I'm upgrading a RAID-1 array on a CERC 2s controller.  After reading through the CERC SATA best practices guide I've found that the 2s does not support the CE or Capacity Expansion feature like the CERC SATA 1.5/6ch does.

 

So...

 

Can I break the RAID 1 array and end up with a single drive that's bootable?  I've already replaced the stock 40GB drives with 1TB drives and rebuilt the array and everything seems to be working fine, but I'd like to have the extra capacity of course.  I've searched the web far and wide (including this discussion board) for a success story from someone doing what I'd like to do.  I haven't found anyone with specifically a 2s and a RAID-1 array that has broken the array with no data loss.  I haven't found anyone who has broken a 2s RAID 1 and lost data either though :).

 

I would like to break the array, then re-size the partitions on the 1TB drive and then re-create the array from that drive.

 

I've read many posts where people have successfully broken RAID1 arrays, but not specifically on the CERC SATA 1.5/2s.

 

 

Thanks in advance.

0 Kudos
5 Replies
pizzapop81
2 Bronze

Re: Breaking a RAID 1 on a CERC SATA 1.5/2s (RAID 1 capacity upgrade)

Hi M1combat, can you please let me know if this process worked for you?

 

I'm in a similar situation.

2 x 160 GB sata drives on the cerc 1.5/2s controller.  12 GB system partition that's full, 145GB data partition that's about half ful. Need to expand/extend the system partition.

I'm thinking of replacing one 160 GB disk with a 500 GB disk, letting it rebuild itself, then adding a second 500 GB disk to rebuild itself again (so that I can play with the new 500 GB disks and keep the original 160's intact), then using GPARTED or some other partition editing software to extend the C:\.

If you managed to extend your C:\ , please let me know how you did it!  thanks so much.

0 Kudos
Anonymous
Not applicable

Re: Breaking a RAID 1 on a CERC SATA 1.5/2s (RAID 1 capacity upgrade)

One a mirror is broken, it can’t be fixed without removing data.  In regards to breaking a mirror, there are a few routes.  The most common is to take one drive used in the RAID 1, boot to the drive off a SATA connection to the system board.  Once booted, there is no going back to a RAID configuration.

In  regards to the gParted route, there are two issues that come up.

1.     When you replace a drive in an existing array, the drive will rebuild to the original drive size.  You will have unallocated space, but that space wouldn’t be redundant. 

2.     gParted isn’t best on a boot partition like C, data drives aren’t an issue as much as the boot partition as issues can arise months down the road due to gParted ‘fixes’ within the file system.

 

execlabeljon
2 Bronze

Re: Breaking a RAID 1 on a CERC SATA 1.5/2s (RAID 1 capacity upgrade)

Todd, I need to expand my capacity also as the others mentioned above.  So, to be straight, you say to remove a drive from the current mirror and plug it directly to a sata port on the mainboard and it will be bootable, correct? Ok, after that, if i destroy the old array and use two new drives and create a new large array on the cerc, what's the best practice to mirror my booting drive (attached to mainboard)  to the new raid 1 array on the cerc? Im trying to avoid a full install again.

 

 

Thanks,

0 Kudos
pcmeiners
4 Germanium

Re: Breaking a RAID 1 on a CERC SATA 1.5/2s (RAID 1 capacity upgrade)

Easiest way is to place one drive of the old array on the SATA interface, setup the new array, use cloning software , cloning from the SATA interface to the new array; whichever software you use, it need to be able to expand the new array' s partition to use the full array size. I use Acronis, but there are a few other softwares which are cheaper or free.

 

 

0 Kudos
tato386
2 Bronze

Re: Breaking a RAID 1 on a CERC SATA 1.5/2s (RAID 1 capacity upgrade)

Hello Todd:

I would greatly appreciate it if you could help me clear up some confusion with my setup.  I have a PE1800 with one 160GB SATA drive that I configured as concatenated on my CERC 1.5/6ch.  I then added a second 160GB drive and wanted to reconfigure both drives as a RAID1 without losing my current OS on the first drive.  According to this doc, it should be possible:

<ADMIN NOTE: Broken link has been removed from this post by Dell>

However, I have tried with OMS 5.5 and 6.4 and both refuse to allow me to do this.  They both claim there is no available space.  I have tried with the second drive unconfigured and as a hot spare and it continues to fail with the same error.

In any case I ran accross this doc:  http://support.dell.com/support/edocs/storage/raid/CERCbest.pdf  which has no mention of reconfiguring a concatenated drive to RAID1. 

So which doc is right?  Can this be done? I have also thought up some other ideas but have not tried them yet.  I was thinking of configuring the second drive as concatenated then trying to reconfig.  I have also thought about using the BIOS or Adaptec instead of OMS. 

What do you think? 

Thank you,

Diego

0 Kudos