Techvet
2 Bronze

Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

We have a number of PowerEdge 1850's and 2850's (along with 860's, 1950's, and 2950's).  I recently upgraded Server Administrator to verison 6.4 on all the boxes and upgraded to Dell IT Assistant 8.8.  Even though the firmware on the 1850's and 2850's is up-to-date, per the OMA 6.3.1 DVD, they are now generating the following warnings every time they are booted up.

Does anyone know how to get rid of these faulty warnings? 

Thanks,

Techvet

Device:<PowerEdge 2850> <IP address>, Service Tag:<SYSTEM TAG>, Asset Tag:, Date:12/20/10, Time:11:15:03:000, Severity:Warning, Message:Alert message ID: 2131, Controller warning. The current firmware version  5B2D is older than the required firmware version 522D for a controller of model 0x016D, system, Controller 0 (PERC 4e/Di)

Device:<PowerEdge 1850> <IP address>, Service Tag:<SYSTEM TAG>, Asset Tag:, Date:12/19/10, Time:23:35:43:000, Severity:Warning, Message:Alert message ID: 2131, Controller warning. The current firmware version  5B2D is older than the required firmware version 522D for a controller of model 0x016C, system, Controller 0 (PERC 4e/Si)

0 Kudos
1 Solution

Accepted Solutions
ScottWhite
2 Bronze

Re: Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

I logged an incident with Dell Support. It does appear to be a bug in OMSA v6.4 as it evidently can't calculate a B is newer than a 2 in hex. If you contact support they can modify a file for you to make the warning go away.

If you want to go with an "unsupported by Dell approach", you can modify the C:\Program Files\Dell\SysMgt\sm\cfg\lsiver.cfg which lists the minimum firmware version. Just use something like Notepad++ that understands lf (line feed) delimited files. Search for the desired controller (PERC 4e/Si in my case) and change the FW value (line 404) to the current value. Save the file and restart the 4 services that start with "DSM SA" or reboot the server.

Original config starting at line 400:
ID=0x016C
VENDORID=0
NAME=PERC 4e/SI
BIOSSP=NA
FW=522D

Modified config starting at line 400:
ID=0x016C
VENDORID=0
NAME=PERC 4e/SI
BIOSSP=NA
FW=5B2D

I got the impression since the PERC 4e/Si is so old, there may not be a permanent fix for the app. Atleast you know have a work-a-round.

View solution in original post

10 Replies
rvandewa
2 Bronze

Re: Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

I am also having this issue with our 2850s.

0 Kudos
ukwalnut
2 Bronze

Re: Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

I'm having the same issue with my 2850.

Does anyone still have their servers under warranty and can contact Dell for answer?

0 Kudos
tommo666
4 Beryllium

Re: Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

The firmware matrix is here.

This is a search result for 522D. On some servers it looks like the 522D is for the 4e/DC while on other servers it's for 4e/DI. Generally speaking the FW package will be compatible with all 4 series controllers but i can't give the definative answer for your circumstances. Dell tech should be able to provide info about correct FW and drivers.

The error message in server admin is down to the pre-requisite checker. When you intall a version of server admin the checker runs first and informs you of any actions required before the install can proceed. If the server is way out of date you may not be able to install until you upgrade FW etc. If it's only a bit behind you can normally install and it will work but give messages about FW revisions.

0 Kudos
theflash1932
7 Thorium

Re: Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

5B2D is the latest firmware for the PERC 4e/Di.

This is one thing that drives me crazy about Dell ... they do not update any of their online docs.  (Granted, I can only imagine how many they must have, but they should also have a plan to maintain them.)  The latest version of OMSA on that matrix is 5.3, which predates the 5B2D firmware. 

My guess?  It's a bug in 6.4.

0 Kudos
ScottWhite
2 Bronze

Re: Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

I logged an incident with Dell Support. It does appear to be a bug in OMSA v6.4 as it evidently can't calculate a B is newer than a 2 in hex. If you contact support they can modify a file for you to make the warning go away.

If you want to go with an "unsupported by Dell approach", you can modify the C:\Program Files\Dell\SysMgt\sm\cfg\lsiver.cfg which lists the minimum firmware version. Just use something like Notepad++ that understands lf (line feed) delimited files. Search for the desired controller (PERC 4e/Si in my case) and change the FW value (line 404) to the current value. Save the file and restart the 4 services that start with "DSM SA" or reboot the server.

Original config starting at line 400:
ID=0x016C
VENDORID=0
NAME=PERC 4e/SI
BIOSSP=NA
FW=522D

Modified config starting at line 400:
ID=0x016C
VENDORID=0
NAME=PERC 4e/SI
BIOSSP=NA
FW=5B2D

I got the impression since the PERC 4e/Si is so old, there may not be a permanent fix for the app. Atleast you know have a work-a-round.

View solution in original post

ukwalnut
2 Bronze

Re: Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

ScottWhite - Thanks for taking time to post fix, this will be great help.

0 Kudos
Techvet
2 Bronze

Re: Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

Scott,

Thanks very much for bugging the issue to Dell and also giving us a workaround.  We have support for these boxes but not through Dell so I would have had no avenue there.  I updated the CFG file on a test server, rebooted the server and it works.  Thanks very much and have a great weekend!

-Tom-

0 Kudos
NCaito
2 Bronze

Re: Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

Thank you for this information.

I just installed the latest OpenManage software, only to be greeted by warnings of out of date firmware. I was confused when it said I needed firmware that was several years old!

I figured since our 2850 was so old, we would be out of luck in getting any help from Dell.

Luckily, I found this page through Google. I made the change to the CFG file (changed 522D to 5B2D), restarted the services, and now everything is back to normal.

Thanks!!

0 Kudos
theflash1932
7 Thorium

Re: Faulty warnings about PE 1850/2850 5B2D Perc controller firmware being out-of-date

Jump to solution

Just a comment NCAITO ... Dell always provides FREE support for servers, whether in or out of warranty.  The ONLY thing that changes when a system goes out of warranty is Dell no longer pays for parts and labor should hardware need to be replaced.  They will help troubleshoot and do anything short of sending parts/technician to repair it.  Even then, you will usually have the option to get the same parts/service as  you would under warranty ... just at your expense instead of Dell's.

0 Kudos