waqark3389
1 Copper

H700 raid card keeps going into Write Through plus bad write speeds

I have a Dell integrated H700 in raid 50. I noticed that the performance is declining on the Xenserver hypervisor the card is in. To force write back, I changed the setting through omconfig and here is what omreport storage vdisk is now showing:

Controller PERC H700 Integrated (Slot 4)
ID : 0
Status : Ok
Name : hv4
State : Ready
Hot Spare Policy violated : Not Assigned
Encrypted : Not Applicable
Layout : RAID-50
Size : 4,467.00 GB (4796404727808 bytes)
Associated Fluid Cache State : Not Applicable
Device Name : /dev/sda
Bus Protocol : SAS
Media : HDD
Read Policy : Adaptive Read Ahead
Write Policy : Force Write Back
Cache Policy : Not Applicable
Stripe Element Size : 64 KB
Disk Cache Policy : Disabled

After setting this policy, I still get bad disk performance. When I set write back only (without force). It says the command is successful but does not does not actually change the setting. I have megacli installed, here is the output for that:

[root@xen12 sbin]# /opt/MegaRAID/MegaCli/MegaCli -LDInfo -Lall -aALL


Adapter 0 -- Virtual Drive Information:
Virtual Drive: 0 (Target Id: 0)
Name :hv12
RAID Level : Primary-5, Secondary-0, RAID Level Qualifier-3
Size : 4.362 TB
Sector Size : 512
Parity Size : 1.089 TB
State : Optimal
Strip Size : 64 KB
Number Of Drives per span:5
Span Depth : 2
Default Cache Policy: WriteBack, ReadAdaptive, Cached, Write Cache OK if Bad BBU
Current Cache Policy: WriteBack, ReadAdaptive, Cached, Write Cache OK if Bad BBU
Default Access Policy: Read/Write
Current Access Policy: Read/Write
Disk Cache Policy : Disk's Default
Encryption Type : None
Bad Blocks Exist: No
Is VD Cached: No


Number of Dedicated Hot Spares: 2
0 : EnclId - 32 SlotId - 10
1 : EnclId - 32 SlotId - 11

Exit Code: 0x00

What does the Is VD Cached option mean? On all of my other machines (with the same card, config) this is set to Yes. How can I set this to Yes. 

Also why does it not want to go into Write back mode and keeps reverting to write through? 

Many Thanks

0 Kudos
5 Replies
Moderator
Moderator

RE: H700 raid card keeps going into Write Through plus bad write speeds

Hi,

What is the status of the PERC battery? If it is in a learn cycle, or failed it will disable write back due to the risk of data lose in the event of a power outage.

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
waqark3389
1 Copper

RE: H700 raid card keeps going into Write Through plus bad write speeds

The status of the battery is Degraded. I have force write back on but this makes no difference to the performance. If I use omreport, I see the vdisk is set to force write back, but in megacli it shows as not cached. I have tried forcing to write back there too but doesnt change.

Power loss isnt too much of an issue as there are multiple UPS's and double power. I rather have the performance back!

0 Kudos
Moderator
Moderator

RE: H700 raid card keeps going into Write Through plus bad write speeds

What version is the firmware at? Have you rebooted after setting to forced write back?

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
waqark3389
1 Copper

RE: H700 raid card keeps going into Write Through plus bad write speeds

Hi Josh

I have since replaced the battery and it is now in a healthy state. However I still cannot set Is VD cached  value to yes. Here is more information:

[MegaCli]# ./MegaCli LDInfo -Lall -aALL

Adapter 0 -- Virtual Drive Information:

Virtual Drive: 0 (Target Id: 0)

Name                :hv4

RAID Level          : Primary-5, Secondary-0, RAID Level Qualifier-3

Size                : 4.362 TB

Sector Size         : 512

Parity Size         : 1.089 TB

State               : Optimal

Strip Size          : 64 KB

Number Of Drives per span:5

Span Depth          : 2

Default Cache Policy: WriteBack, ReadAdaptive, Cached, No Write Cache if Bad BBU

Current Cache Policy: WriteBack, ReadAdaptive, Cached, No Write Cache if Bad BBU

Default Access Policy: Read/Write

Current Access Policy: Read/Write

Disk Cache Policy   : Disk's Default

Encryption Type     : None

Bad Blocks Exist: No

Is VD Cached: No

Number of Dedicated Hot Spares: 2

   0 : EnclId - 32 SlotId - 10

   1 : EnclId - 32 SlotId - 11

Exit Code: 0x00

The firmware version is:

Controller 0 [PERC H700 Integrated]: Firmware '12.0.1-0091'

However a few other machines have out of date firmware and they are able to use the cache perfectly fine. (updating the firmware will cost me a lot of downtime, so would like to find a solution if the firmware isnt the problem in this particular case)

Thanks!

0 Kudos
Moderator
Moderator

RE: H700 raid card keeps going into Write Through plus bad write speeds

Did you power off when you did the battery replacement?

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos