mrpush
1 Nickel

Major CERC SATA 1.5/6 problems

Hi,

Dell PE 1800 with CERC SATA 1.5/6 , W2k3 server, 2- 40 GB drives Raid 1 Windows, 3- 300 GB drives Raid 5 for storage.

Ok, So all I want to do is put in bigger boot drives cause I'm running out of room.  I have a drive image software to make images of partitions.

After asking here I came up with a few possibilities, and so I tried just about all of them except the first which was to "Backup data, create arrays, then re-iinstall OS"  Well who the heck wants to re-iinstall an OS, especially with all the other tweaks I have made, IIS stuff etc?  So I skipped over this option.

Well, now I'm stuck because of an obviously very badly designed CERC and associated software.  (maybe I shuold have just listened) 

While trying to image existing drives and get them to work when put in place of orgianal drives, it was thought that the problem was that my images were not getting the CERC array data on them, so the controller had trouble with the drives.

Well it turns out this is false.  My images put on the new drives HAD array data on them, but they just would not boot windows.

So basically what wrecked my day was that I decided to try the "replace one smaller drive in the mirror with a larger drive and let it rebuild, then do the same for the 2nd larger drive to repalce the 2nd smaller drive. "

Here is what happened:

Removed 1 smaller drive put in 1 larger drive in its place (port1).  Hey, its a full half of the original raid 1 and a good backup drive.

On re-boot CERC BIOS says :

Array 0: RAID-1 degraded

Array 1: RAID-5 optimal

Array 0, RAID-1 degraded.

The CERC obviously saw array data on the new large drive that I had put images on in a previous attempt get this to work.  I did kill the partitions in Disk Manager, but I do not believe I reformatted this larger drive.  

So basically the CERC BIOS sees two degraded RAID 1 arrays (same array 0) and my RAId 5 arry is still fine.

So I boot into windows, and check the CERC in Open Manager.  It sees the same thing.  Without changing anything, I reboot the server.

Now CERC BIOS says: 

Array 0: VOLUME

Array 1:  RAID 5

HUH?  Why did it change?

So now I go back into OM CERC and it staill says Array 0: Degraded, RAID-1, but will not let me do anything.  Available tasks are

Delete, Assign hot spare, Rename, Unmirror

I tried unmirrow, get error:  The operation failed:  Conflicting commands, hardware change prevents this command from being completed, the controller is in a state which prevents this comand from running.

Ok so I try assigning a hot spare, it hangs the server and I must hard restart.

Next I remove both of the existing drives and put back in my mirrored original that had not changed at all in the port 0 slot.  It does not even see the drive! 

Now how can that be, nothing changed on this drive and it should see the original CERC ARRAY DATA on and it boot, right?  (yeah surely not)

The only thing I did not try is CTRL-R from CERC BIOS to try to remirror cause it says only do this if you lost all data on drives or you may lose all data.

So now I have lost reduncancy and I can't change what is there.

 I am at a loss at how bad this whole CERC thing is desinged, so easy to wreck it and lose you data, heck, it also mirrors in the wrong direction and you don't have the option to tell it which way to mirror.  My 20 year old server at least let me choose the direction of mirror.  This CERC stinks and I'd to to talk to whom ever put this thing.........yeah.......I guess this is all besides the point now anyway...so I'll shut up.

Also, with my RAID 5 with 3 disks, I am limited with how many disks I can put in to try to fix.  If I mess with that RAID 5 by changing ports or removing a drive, well I think we all know the outcome is not going to be good on this CERC.    Good grief. 

Anyone with this CERC have any ideas how I can get this back to mirrored state now that its all messed up?

Thanks much,

MP

 

0 Kudos
1 Reply
Highlighted
mrpush
1 Nickel

Re: Major CERC SATA 1.5/6 problems

Hi,

I figured it out.  After trying everything possible to get this image to boot, I happened into the CERC BIOS array manager.  Huh, look at that.  There is a CTRL-B option to change the array boot order.  Who saw that?  Not me.  Who read that in the documentation?  Not me cause its not there!  It mention "boot array" but does not mention that you MUST do this on a new boot array, no instructions.

Turns out that this CERC is in charge period or the Boot devices and their settings.  Try to change the boot stuff on a drive attached to ths CERC that is NOT set as the boot array and forget it.  It prevents changing drive letters as well.  

Once set as the boot array, my images were bootable after running the fixes for boot issues.

I ran FIXBOOT, FIXMBR, and BOOTCFG /rebuild from the Windows OS CD recovery console and it booted right up.

Let me give a warning however.  This CERC is jacked.  It works ok and is consistant, as long as you DON'T MESS WITH IT.

If you think you are going to pop in a few new drives in place of others, move drives onto different ports doing a few reboots in the process and you will have a messed up RAID.  This controller changes setting on you all by itself.

I lost a RAID-1 to a "VOLUME" type in the BIOS and a "DEGRADED" raid-1 in the Dell open manager.  Two different things!  YIKES!  The drive is now stuck that way and cannot be remirrored, not spared or changed.

I REPEAT DO NOT MESS WITH THIS CONTROLLER, YOU WILL BE SORRY YOU DID!