1 Copper

PowerEdge R610 - Boot from OCZ RevoDrive 350 Mystery

PowerEdge R610 - Boot from OCZ RevoDrive 350 Mystery

We have a really annoying problem with our PowerEdge R610 and OCZ RevoDrive 350 combo.


The PowerEdge R610 is absolutely updated from the latest Dell Server Update Utility (Version 16.04.00, A00; Release date: 11 Apr 2016).

The integrated PERC H700 controller is used to manage the 6 SATA SSDs in a RAID5 configuration to a data storage, not host a boot drive or partition.

The server is set to UEFI mode.

The OCZ RevoDrive 350 is in factory default, no firmware update is available at this time, the latest (driver version, release date December 23, 2014) driver is used for the operating system.

The operating system is Windows Server 2012 R2

The Problem

I’ve installed Windows Server 2012 R2 with the UFEI’s Unified Server Configurator and a little help from Working Hard In IT https://blog.workinghardinit.work/2012/08/24/how-to-deploy-windows-server-2012-on-dell-uefi-nownotes...

It was all OK. The EFI partitions was created, Windows was successfully installed, and booted up well. I started to set things up, installed additional roles to the server, updated from windows update, when the first restart came. I was awarded with the automatic recovery mode. I tried all the available options, but none of them helped me out. When I restarted the server, it always brought back the recovery console. So I checked out command prompt and lunched diskpart.

As you can see, Disk 0 is the RAID5 volume from the PERC H700. Disk 1 is a USB drive connected to the back side USB port (contains only the OCZ drivers), Disk 2 and 3 are the iDRAC virtual drives. And YES, there is NO other drive. Especially no OCZ RevoDrive 350, 223 GB. so where could it be? First, I removed it from the slot, reinserted it, checked it if it sits securely in the riser, everything was all right. Put the cover back, and started the machine. Same error, I found myself in the recovery console. Removed the card, inserted in a Precision T5500, no problems at all. The only difference is that the T5500 is not UEFI aware. So I put the card back in the R610 and started the installation process from the beginning. I thought I caused the unbootable state. Back in the USC, OS deployment, next, next, finish. At the end I was convinced the installation will begin after rebooting:

But this is what happened:

If you don’t speak Hungarian, this is the login screen of the Windows Server 2012 R2. It simply booted to Windows. I haven’t seen the Press any key to boot from CD or DVD… line either.

As you can see, the drivers are loaded, the volumes are up and running.

Now I started to dig deeper.

What I found: The PCIe SSD will be lost on boot, if I do anything from the followings:

Update certain things from Windows Update

Install Driver(s)

Update Driver(s)

Update Firmware(s)

Basically anything that triggers a UEFI (re)initialization on boot process.

After this, I have to press F10 and walk through the USC’s OS deployment wizard, to get back in Windows.

But this is not the intended way to operate a server. So ANY idea, help, articles from anywhere are appreciated.