PowerEdge HDD/SCSI/RAID

Last reply by 08-20-2021 Unsolved
Start a Discussion

PowerEdge R900 4TB RAID

I inherited a PowerEdge R900 server that i want to use as a VM box (hyper-V or ESXi - but that's another thread).  it has a PERC 6/i RAID controller.  I got 5 4GB SATA hard drives but found out that the PERC 6 only recognizes them as 2TB capacity.  further research confirmed the 2TB limilt on PERC 6.  

so my question - what are my options to fully leverage 5x 4TB SATA drives in a RAID 5 configuration in the R900?  i would prefer to use a DELL (PERC) solution, but am okay with 3rd party RAID controllers.

is there a a viable solution?  or do i have to sacrifice half the drive capacity?

THanks

B

Replies (6)
7 Thorium

You could try a third party controller - I would recommend an LSI branded controller, as the Dell controllers are based on LSI models, but I would try the H700 first, as mentioned in your other thread.

do you know what part number for the cable i need to connect the H700 to the backplane?

i can't use the cables for the PERC 6/i

THanks

7 Thorium

I'm not sure there is a Dell part number that  will work, as many are exact lengths for specific systems, but you will need an SFF8087 on the controller end and an SFF8484 on the backplane end.

yeah, I was afraid of that.  thanks for the info

Hi Flash,

okay, so here's where my testing went..

I installed the PERC H700 in my PE R900.  i got a couple of SFF-8087 (mini-SAS) to SFF-8484 (SATA backplane) cables.  there are 5 bays in the SAS/SATA cage but only 4 drives show up in the physical disk inventory for RAID configuration.   with the RAID connector 1 connected to backplane port 1 and 2 to 2, i saw that the raid ID's and bay drives mapped like this.

Bay #    RAID ID #
 0          7
 1          
 2          5
 3          4
 4          3

when i swapped the SAS ports on the RAID controller side, i got this

Bay #    RAID ID #
 0          3
 1          
 2          1
 3          0
 4          7

Note that in both cases, the H700 did not see the drive in bay #1.  i moved hard drives, i swapped the cables again, no drive #1.  i know it's not a backplane issue because with the original PERC 6/i installed i could see all 5 drives, but only 2TB of the 4TB capacity.

There is another issue, but it's moot if i can't get the H700 to see all 5 drives.
the H700 is a full height card so there's no room at the top of the chassis to accommodate a regular mini-SAS cable. but it's also so close to the edge that with a cable bending 90 degrees, the release clip has to be under the bend, but no one seems to make any like that.  

if there's a solution to make the H700 work with the R900 i'm all ears.  i can't say for sure that the root cause is the SFF-8087 to SFF-8484 cable but that's what it's looking like.  if it requires a dell proprietary cable (ie. non generic wiring) then i can't find such a cable.  

has anyone gotten a PERC H700 to  work in a PowerEdge R900 with a 5-slot 3.5 drive backplane?

please let me know or i have to either exchange these 4TB drives for 2TB drives, or keep them but lose 50% of their space.  

Thanks in advance

N

2 Bronze
2 Bronze

Hi beeberc,

Have you solved your problem for the H700 recognizing all five hard drives? I need to upgrade the PERC 6i to a newer card to handle the hard drive more than 2T too now.

Top Contributor
Latest Solutions