Highlighted
steverinaz
1 Nickel

Unable to load OS, base adapter not found

Jump to solution

Hello all;

Fire sale, picked up an R520 with 8x4TB drives, The configuration is hosed. I have tried Lifecycle controller, UEFI manager but still no  array found. Gotta start from scratch I guess....any clear path for re-installing?

TIA!

0 Kudos
5 Replies
theflash1932
6 Indium

RE: Unable to load OS, base adapter not found

Jump to solution

Boot to CTRL-R utility (assuming H720 controller), wipe out the configuration and configure a new VD.

steverinaz
1 Nickel

RE: Unable to load OS, base adapter not found

Jump to solution

Thanks @theflash1932. One of the drives has gone south which prevented me from getting into the config. Now I have 7 drives in one array. I'm working with Dell to get the drive replaced under warranty, but when I threw Server 2012R2 on it, it created a 2TB C:\ drive. I'm unable to access the other 22TB; all options are greyed out. MS did a lot of changes I see in 2012. How do I provision the remaining space?

TIA!

0 Kudos
theflash1932
6 Indium

RE: Unable to load OS, base adapter not found

Jump to solution

Nothing new here:

  • Windows cannot use a disk larger than 2TB unless it has been converted to GPT.
  • Windows cannot boot to a GPT disk unless it is installed on a UEFI-enabled system.

Each VD (array) is presented to the OS as a separate disk. If you have 3TB drives, you only have one option: Configure multiple arrays across the disks. In CTRL-R, configure a RAID array across the disks and when asked the size, make sure you specify a value less than 2TB. You can then create a second array across the disks for the data, convert to GPT, and have it be as large as you want.

steverinaz
1 Nickel

RE: Unable to load OS, base adapter not found

Jump to solution

Flash,

It's been awhile since I've been an engineer. You're correct....however when creating the initial VD, I used all disks in R5/R6. Should I not use all? Or use PS to acess the other 22TB? I have an R520 with 8 4TB SAS drives. Trying to get refreshed and caught up on all the new technologies. Would using Dell's setup cd or the Life Cycle controller be of more help?

SR

0 Kudos
theflash1932
6 Indium

RE: Unable to load OS, base adapter not found

Jump to solution

You will never be able to access the other 22TB unless you install in UEFI mode.

Your only options are:

1) Enable UEFI boot mode, then reinstall Windows.

2) Not use all the disks. You could use 2 in RAID 1 for the OS and 6 in RAID 5/6 for data. This will cost you an extra disk's worth of space over having them all in the same disk group. Also, because you are using 4TB disks, even a RAID 1 will be limited to 2TB (unless you install in UEFI mode, in which case, you might as well put them all in the same disk group). You could also get a couple of smaller disks (if your chassis has the space) to use for the OS.

3) Create multiple VD's. Called "slicing", this is what I suggested before, you create two VD's across the disks, one of which would be small enough (<2TB) for the OS in BIOS mode, say 200GB, then create another VD across the disks to use the remaining 21.8TB - convert to GPT and partition as you like.

I would highly recommend you use RAID 6 and not RAID 5. Disks that size are almost guaranteed to experience a read/write failure during a rebuild, so you are much better off having an extra layer of redundancy/error detection/correction.

0 Kudos