Highlighted
Casimur
1 Copper

How-to upgrade the firmware on a Dell R710 (and maybe others) in 2019

Here is a method for updating system components if you cannot enter system services, iDRAC and do not want to install an operating system on the machine. This worked for me as I could not enter system service due to X64 Fatal error with red screen. The linuxISO did also not work as it got fatal error wrong fs type at boot. Tried different memory sticks and both Etcher and Rufus but no dice.

Requirements:

- Dell EMC Repository to download the updates

- Dell Support live CD/USB version 3.0.0 (SLI 3.0.0)

- 2x 4gb+ empty USB memory sticks

 

To find the updates in the EMC repository first click ADD REPOSITORY in upper left corner, enter a name for the repository ex. R710 and then click Manual -> Custom and CHOOSE SYSTEM. Click on the model of your server and click save. Then click ADD. Click on the small arrow beside the name to expand the menu and again on the arrow that says model name and (Linux). Choose all the components in the Linux system and click DOWNLOAD. Choose a folder and let it download. To see the progress of the download click Repository Manager in the upper left and under View choose Jobs. After all the files have downloaded click EXPORT and choose the repository and click SUU ISO. Choose a location and wait for it to complete (seen in Jobs). NOTE if the .iso file is bigger than 4gb it might be not be possible to move it to a USB stick (FAT32 restriction). In that case choose only some of them, with the help of the funnel icon, and make several ISO files. After you have the ISO files move them as is to a USB stick.

 

Next download the Dell support ISO file version 3.0.0 (It says not compatible with gen11 and lower but that does not matter). Install the ISO file on another usb stick with the help of Etcher or Rufus.

 

Now insert the Support ISO USB stick in the server (backside USB works better some say) and start the server. Enter the boot menu by pressing F11 when shown on the screen. In the boot menu choose your USB stick and let it boot. Choose start SLI3.0.0. NOTE: If it does not want to boot enter the BIOS with F2 and change the boot type to UEFI. It should now boot up the live CD version of CentOS. After it has booted up, plug in the other USB stick with the .ISO file(s). In the upper bar there is a menu called Places and there should appear ex. ‘16Gb memory’ for the newly plugged USB stick. Click it. In the folder view navigate to the SUUImage.iso and double click it. This will mount the image file. It will say it want to run, let it by clicking Run. A brief view of a terminal shows with some errors and nothing happens (at least for me). Now go to the Places menu and choose the new CDROM place. In the folder view you should see many different files and folder. Right-Click on a blank spot and choose open terminal here. In the terminal type

 

sudo ./suu -c (check for updates, optional)

 

sudo ./suu -u (start update utility in command line)

If there is a need to only select some packages because others hang or otherwise, use:

 

sudo sh ./autorun.sh

to start the GUI version

 

and hopefully the updater will start. The newer 3.0.0 version has Java already installed and that's why it is good to use that version.

 

Let the installer collect data for a while and it should end up with a list of components to upgrade. Just clicking Upgrade did not work for me as it quickly ended with a premature end of file error. I recommend to upgrade the components one by one starting with the BIOS. The lifecycle controller failed to update at first but after some other components updated it also succeeded in updating. The update also seemed to indefinitely hang on SAS drive firmware update.

 

Hopefully this saves someone else a day or two of googling and problem solving.

 

Casimur

0 Kudos