Highlighted
Themann
1 Nickel

Poweredge R300 Broacom Netxtreme Firmware update - No connectivity

Jump to solution

I am working on an issue with a Poweredge R300.

After I installed Open Manage System Administrator, connectivity was lost. I read online and I gathered that the NIC firmware might be the issue. As soon as I uninstalled OMSA, the NIC came back up. I then proceeded in updating the Firmware of the NIC (Old firmware: 3.x.x) f with new Version 7.x.x downloaded rom the website and now no connectivity even without OMSA installed.

Things already tried:

-Uninstalled NIC driver.

-Downloaded and installed Broadcom driver from Dell's website.

-Reset IP stack

-Tried the second NIC on the back of the server.

And no luck!

Any help is appreciated.. 

Thank you

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator

Re: Poweredge R300 Broacom Netxtreme Firmware update - No connectivity

Jump to solution

The issue may be due to the large skip of updates up to the current one.

If you go to this link and click on OTHER VERSIONs below it will list the prior updates.

http://go.us.dell.com/ar9

Jump back to the one you came from and then run every couple updates and walk it up.

Please run these steps to update the driver. Run this before updating to current, but AFTER flashing back to your previous version.

Go to Device Mgr and delete the NIC driver.

Download this Broadcom pack - www.dell.com/.../poweredge-r300

After it is downloaded then extract files.

Go to Mgmt Apps folder and find Setup.exe,  run that file.

That will start the Broadcom Advanced Control Suite (BACS) install.

After that is installed then restart the server. Upon login to OS you will get a HW wizard pop up, close that.

Boot back in the OS and start BACS. That will load the correct driver for you.

Let me know how it goes.

Chris Hawk

Dell | Social Outreach Services - Enterprise
Get Support on Twitter @DellCaresPro 
Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

3 Replies
Themann
1 Nickel

Re: Poweredge R300 Broacom Netxtreme Firmware update - No connectivity

Jump to solution

Is there a way that I can revert the old firmware back?

0 Kudos
theflash1932
5 Iridium

Re: Poweredge R300 Broacom Netxtreme Firmware update - No connectivity

Jump to solution

When downloading the latest firmware package, on the download page, click on Other Versions ... you can download and flash to an older version.

0 Kudos
Moderator
Moderator

Re: Poweredge R300 Broacom Netxtreme Firmware update - No connectivity

Jump to solution

The issue may be due to the large skip of updates up to the current one.

If you go to this link and click on OTHER VERSIONs below it will list the prior updates.

http://go.us.dell.com/ar9

Jump back to the one you came from and then run every couple updates and walk it up.

Please run these steps to update the driver. Run this before updating to current, but AFTER flashing back to your previous version.

Go to Device Mgr and delete the NIC driver.

Download this Broadcom pack - www.dell.com/.../poweredge-r300

After it is downloaded then extract files.

Go to Mgmt Apps folder and find Setup.exe,  run that file.

That will start the Broadcom Advanced Control Suite (BACS) install.

After that is installed then restart the server. Upon login to OS you will get a HW wizard pop up, close that.

Boot back in the OS and start BACS. That will load the correct driver for you.

Let me know how it goes.

Chris Hawk

Dell | Social Outreach Services - Enterprise
Get Support on Twitter @DellCaresPro 
Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)