PowerEdge Hardware General

Last reply by 03-06-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
4067

R720XD - no physical drives detected

Booted up a second hand R720XD, no OS, everything set back to factory default and wiped. LCC shows a log of the seller removing old drives, installing the new HDD's (10x1Tb Constellation's) setting up a virtual disk, reboot, delete virtual disk, shutdown. it then sat for 3 months before it shows a record of me booting it up after sale. No physical drives detected in BIOS, or H710P raid controller screen whether set to RAID, AHCI or ATA. tried reseating the RAID controller, and disconnecting the battery to double check that the battery was still good, shows good health under battery during self Diagnostic. updated BIOS, H710P firmware and LCC to current gen as per DELL support's driver page going by service tag number. LCC shows when I remove and insert drives, so backplane and cabling seems to be correct (opened up the box and checked by hand as well) and lights come on, on the caddies during POST. tried booting with no drives, CTRL+R to enter RAID controller and reinserting+refreshing to see if it recognized them one at a time. No Dice, not sure where my next step is or whats the next best thing to check, any ideas?

Replies (7)
Moderator
Moderator
4058

Hello

You need to start by figuring out which RAID controller you are using. The RAID, SATA, AHCI settings in the BIOS are for the integrated controller. If you set it to RAID mode it may interfere with the hardware controller. I don't think you can have the integrated RAID controller and a hardware RAID controller running at the same time on this server. If you have a hardware RAID controller make sure the integrated controller is not set to RAID.

If the system was unplugged for more than 72 hours then the PERC battery was drained. If that occurred then it likely lost information about the RAID configuration. The virtual disk would probably show as foreign, so look for a foreign configuration option in the controller BIOS. Importing the foreign configuration will attempt to copy the virtual disk configuration from the drives to the controller. You can find out more in the controller manual.

http://www.dell.com/storagecontrollermanuals/

Thanks

Daniel Mysinger
Dell EMC, Enterprise Engineer

4054

correct I have been mostly testing under AHCI mode, turning SATA settings to RAID causes the S110 set-up to show during boot so I've set it to AHCI and left "integrated RAID controller" set to ENABLED I had the same concerns of conflict as I am trying to use the H710P, however I tried popping into the S110 RAID set-up page wondering if there was a virtual disk taking up the drives.

the H710P's PERC BIOS shows 0 - virtual, 0 - physical, and 0 - foreign drives, both before and after clearing the configuration

4040

You should check the SAS cables to see if they are connected to the H710 or the S110. There should be a diagram on the inside of the chassis cover that lists the slots.

If they are connected to the H710 then you can pull a controller/TTY log to get more information as to what is going on. Also, when you insert the drives make sure the latch is in the open position, if they are the latch style carriers. It is possible for the drives to be partially connected if inserted incorrectly.

You can use our Support Live Image to review logs.

https://www.dell.com/support/contents/article/product-support/self-support-knowledgebase/enterprise-...

Thanks

Daniel Mysinger
Dell EMC, Enterprise Engineer

4035

SAS Cable is definitely connected to the correct ports, LCC still shows the removal and insertion of drives, to the system. would the LCC still show the removal and insertion of they weren't connecting correctly? I have been sliding back in with latch open, I give a bit of a push to make sure its as far in as it'll go and then I close the latch. Looking down the backplane they look to be connected properly. Would a single misconnected drive mess with all 10 drives? I've tried multiple different combinations of drives+ slots and none seem to show no matter which drive and which slot I use.

I just tried installing the firmware update for the backplane, the installer stops me and says its not compatible with R720 and only compatible with R720XD? but this is most definitely an R720XD system based on server tag and configuration. (its a 12-bay 3.5" which, as far  as I know was never an option for vanilla R720) would there maybe be a firmware/driver problem that would cause this/both problems?

3976

I've been having issues getting my server (R720XD) to recognize HDD's, the LCC shows the adding and removal of drives but the H710P BIOS shows no physical, no virtual and no foreign drives connected.

I tried installing the backplane firmware update and it stopped me, reporting that it was only for 720XD's and that I had a vanilla R720, by service tag and drive configuration its definitely an R720XD. since these two servers have different backplanes and drive configurations could this be the reason its not recognizing drives? how to I fix this if the BIOS update tells it, its an R720? I tried updating the BIOS again and it still shows just "R720" in the model line instead of "R720XD"

3965

looks like someone combined my post of changing wrong model number, I've also pulled my logs

2 Bronze
2 Bronze
558

Hello,

 

Sorry for reviving this topic after 4 years. I have found a lot of people having this problem, including myself. In my opinion, this is a backplane or motherboard problem.

Latest Solutions
Top Contributor