PowerEdge Hardware General

Last reply by 11-10-2022 Unsolved
Start a Discussion
1 Amber
1 Amber

R740xd stuck at initializing firmware interface

I have searched similiar posts and tried to disable the the option for Collect System Inventory. Unfortunatly the service is still stuck in the same state. 

Until the last reboot which was an ESX Server update the service booted just fine. This time around it wont boot any more. 

Any suggestion besides disabling the Inventory Collection? 


Replies (7)



I believe this is normally caused by an added device, generally a PCIe card, and the server being out of date. What I suggest is to do the following;


1. Power down the system
2. Removed all PCIe cards.
3. Powered on the system
4. Verify if the iDrac successfully starts
5. If so update the BIOS and iDrac, if they are far behind you will need to walk both up to current together.

6. Reboot and verify every posts successfully.
7. Power down the system
8. Insert each removed devices individually and power on the system
9. For each verify the iDrac successfully starts
10. Repeat steps 7 through 9 for all the devices.


If it fails to start on any of the devices for 7 through 9 then there may be an issue with that device itself. 


Now if it fails to start after removing those then you may want to take the server to its Minimum to Post configuration and trying the steps again.

Minimum to post for the R740xd is;


One processor (CPU) in socket processor 1 
One memory module (DIMM) in socket A1 
One power supply unit 
Right control panel and cable (for power button functionality) 
System board



Let me know what you see.



Chris Hawk
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
2 Jasper
2 Jasper

Agree with Dell-Chris H,

I had the same behavior with a PowerEdge R640 (new one),  in this particular case was caused by  a SAS HBA connection between the server and the storage, for some reason the serve didn't "recognize" the storage path. so after I've initialized the path, the boot was really fast. 

2 Bronze
2 Bronze


absolutely unsure if you face the same issue as me .. my dell R740xd crashed / stopped working overnight and when booting it hanged / got stuck in Initalizing firmware interface. And F2, F10 did not work at all. when i pulled the disks out it booted. When i pushed the disks back in and rebooted: same hanging issue.

After quite some path finding it appeared that the battery of the Raid controller was stuck. I replaced it and (also replaced battery on motherboard but that was not the culprit), the issue was resolved.

Nothing was found in diagnostics. Not in raid controller, not in disks, all diagnostics were OK.


2 Bronze
2 Bronze

A Poweredge R720XD did this to me after I made new disk groups and configured a new raid. The Lifecycle controller said it can take 8 hours to complete. The disk lights certainly were blinking fast. I thought it can do that in the background, but server won't boot, just like the rest of you reported. Maybe if I just let it sit there for a day, it would pass. But I needed the server, so I took the disks out and it booted after complaining that it lost its disks.

Maybe when I have time, I will do this thing again and let it sit.


Hi, how did you initialize the path in idrac?

I have the same error today.




you don't initialize the storage path from iDRAC but from the storage. It depend from what is the attached storage.


Marco B.
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
2 Jasper
2 Jasper

It seems there are no logs showing any issues but the system was halt at POST and not allowing system to initialize it properly, facing the same issue with 740XD hope any of the above statement will work, without error its quite difficult to TS, still need to go for Hit ands trail.


Error In LC is:-SRV019 Unable to start the Storage Controller Log collection because the server is in POST and has not finished the startup process.



Latest Solutions
Top Contributor