guru777
1 Nickel

iDRAC 7/8 cannot download firmware updates via LifeCycle (LCC) using online catalog

Thank in advance to everyone who works hard contributing to the Dell community forums.

My Dell R730 cannot download firmware updates via lifecycle controller. Catalog downloads fine, but updates won't download. Upgrade BIOS manually to latest (2.9.1) and iDRAC (2.60.xxxxx) same issue. Tried ftp.dell.com downloads.dell.com via FTP and HTTP. Confirmed with firewall that all traffic is reaching internet without issue. Most likely submitting a ticket with Dell tomorrow.

Based on the forum posts listed below, this appears to be a problem on Dell's side related to some type of FTP to HTTPS transition and download server name transition.  It seems to be like a botched transition where Dell has broken backwards compatibility and they may not be able to get out of this without re-enabling the older update services or forcing all customers to apply a corrected LifeCycle controller firmware (that does not exist yet) manually.

 

A colleague and I have spent most of the day trying to fix this on a single server. I need to update four servers. Dell does not seem to value my time.

What is Dell's official solution to this issue and why is it not a pinned post in these forums?

 

 

See these posts for background info:

https://www.dell.com/community/Systems-Management-General/ftp-dell-com-system-management-download-is...

https://www.dell.com/community/Systems-Management-General/Firmware-Update-from-Dell-s-repo-failed/m-...

0 Kudos
38 Replies
Moderator
Moderator

Re: R730 cannot download frimware updates via LifeCycle (LCC

Hello

The issue you are experiencing is not related to my post or the transition to HTTPS. HTTPS is not yet forced on our download site.

I tested with ftp.dell.com and the update failed. I tested with downloads.dell.com and the update was successful. That is what was covered in my post. If you experience issues after changing the download location from ftp.dell.com to downloads.dell.com then the issue is unrelated to my post that you referenced. There are several possible points of failure when performing online updates. All issues encountered when performing updates are not the same.

We had a separate issue with several catalog files that were recently released. Those catalog files should have been re-uploaded. I show there was an upload this morning. I suggest trying the update again. I just updated an R530 using platform updates through the LCC without issue.

Thanks

Daniel Mysinger
Dell EMC, Enterprise Engineer

Get support on Twitter @DellCaresPRO

0 Kudos
guru777
1 Nickel

Re: R730 cannot download frimware updates via LifeCycle (LCC

I will try again. We have tried so many different methods it is crazy how hard this is. I should not be this hard. Even the bootable ISO from Dell doesn't seem to boot properly.
0 Kudos
guru777
1 Nickel

Re: R730 cannot download frimware updates via LifeCycle (LCC

tried using FTP update method from LCC on R730 using hostname downloads.dell.com. It does not find the catalog when I do this. When I use ftp.dell.com, it finds the catalog, but I cannot download the updates. what next?
0 Kudos
guru777
1 Nickel

Re: R730 cannot download frimware updates via LifeCycle (LCC

This is still broken and I tried a second server with the same results. I already confirmed my firewall is not blocking, but just to be thorough I added a new firewall rule with no filtering or inspection of any kind and my results were the same.

 

Error message:

Unable to install the update packages. (SUP0531)

0 Kudos
guru777
1 Nickel

Re: R730 cannot download frimware updates via LifeCycle (LCC

If my issue is not related to the HTTP transition, then why does the catalog file from ftp.dell.com (ftp://ftp.dell.com/catalog/Catalog.xml.gz) have the following data near the top of the file:

<Manifest baseLocation="downloads.dell.com" baseLocationAccessProtocols="HTTPS" dateTime="2019-03-26T08:37:23+05:30" identifier="dd5800ef-351a-4868-bfb2-dd3c209abe5e" releaseID="N05D2" version="19.04.00" predecessorID="c998c69f-fedc-42b0-a62f-c0b6e066ecdf">

ftp.dell.com and downloads.dell.com do not resolve to the same IP address so their is some type of transition going on where ftp.dell.com is trying to refer me to downloads.dell.com via HTTPS.

the LC controller connects via ftp to ftp.dell.com and then tries to change folders to "/downloads.dell.com".

 

0 Kudos
dyokley
1 Nickel

Re: R730 cannot download frimware updates via LifeCycle (LCC

Rest assured you aren't alone, I have had this exact same issue with both my T320's and T620 and have yet to find a resolution.  Been trying all week.  Seems this error goes back years and in all the threads I've found there has never been a solution, always just dead ends.  Just figured I'd let you know you aren't alone since you seem to just be talking to yourself at this point.

LordGordon
1 Copper

Re: R730 cannot download frimware updates via LifeCycle (LCC

I am having the same issue trying to update firmware on my R720.

It resolves to ftp.dell.com. 

It tells me what firmware needs to be updated with the current version and new version then the install fails one by one with the 5 identified.

I'm told by support to update manually. I cant do this as I am trying to install the OS VIA the lifecycle controller but the "Install OS" option does not exist. The is just an '*' where the option should be!

Al

Moderator
Moderator

Re: R730 cannot download frimware updates via LifeCycle (LCC

We had several issues with related to catalogs and our download site recently. To my knowledge, all of those issues are currently resolved. I have tested with an iDRAC 7, 8, and 9. I have been unable to reproduce the issue. Since I am unable to reproduce the issue, the issue does not appear to be with the LCC, catalog, or our site.

I suggest making sure the iDRAC/LCC is at the latest firmware and verify your network settings. The preference for download site would be in this order:

  1. downloads.dell.com with HTTPS selected
  2. downloads.dell.com with HTTP selected
  3. ftp.dell.com

Only iDRAC9 supports HTTPS. Some of our other products that use our download site only work with ftp.dell.com. The option selected will depend on the product being used. Review documentation to see what options are available.

http://www.dell.com/idracmanuals/

http://www.dell.com/openmanagemanuals/

Thanks

Daniel Mysinger
Dell EMC, Enterprise Engineer

Get support on Twitter @DellCaresPRO

0 Kudos
dyokley
1 Nickel

Re: R730 cannot download frimware updates via LifeCycle (LCC

Mine are all 12G servers, two T320's and a 620, all get the same message.

I'm trying to perform F/W update using the Lifcycle controller, after choosing the components to update I receive the below error message. 

"

Unable to install the update packages (SUP0531) 

Recommended action : 

Enter another repository location that has the Update Packages and retry the operation. 

 

It pulls the catalog, know what versions I have and what need to be updated and offers them to me.  The iDRAC is already up to date, I always do it first and from iDRAC itself.  I was on 2.60 and am now on 2.61

I'm running it from my home network, no complicated gear between me and the world.  I've tried the HTTP option but just get a different error, don't even get offered updates.

Searching the above error message there are various issues with that exact message going back years, never have I found a solution though, just dead ends.  Edited to add I've seen just about every current generation have the problem, 12,13 and 14.

 

0 Kudos