PowerEdge Hardware General

Last reply by 05-16-2021 Solved
Start a Discussion
3 Silver
1944

iDrac6 virtual console does not start

I have an iDrac6 enterprise (FW 1.99) in my recently acquired T610.

I was trying to get virtual console to work, but I couldn't. The system I'm using for remote access has a very recent version of 64 bit Firefox and the latest Java. I've tried both "Native" and "Java", but it didn't seem to make any difference.

Any idea on how to make it to work?

I have a feeling that I'm either missing something, or I could be blocked by the enhanced security in more recent browsers.

Here are 2 screenshots to show  what's happening:

vc1.pngvc2.png

 

Solution (1)

Accepted Solutions
3 Silver
1498

And the solution is to delete "RC4" from the entry shown below, from the file:
C:\Program Files\Java\[jre_release_dir]\lib\security\java.security
(as posted in an older thread here)

jdk.tls.disabledAlgorithms=SSLv3, TLSv1, TLSv1.1, RC4, DES, MD5withRSA, \
DH keySize < 1024, EC keySize < 224, 3DES_EDE_CBC, anon, NULL, \
include jdk.disabled.namedCurves

This works even with the latest release of jre.   The above line needs to be edited every time jre is updated since the previous file is going to be replaced with a new one.

 

View solution in original post

Replies (5)
3 Silver
1909

I figured I'll update iDrac6 to the latest FW (2.9.2) because there were some possibly relevant fixes.

Well, Firefox no longer works (after login, it throws me back to login), after the update but Chrome still works.   However, virtual console still does not start, although I may be getting a bit further this time.

After trying to execute the .jnlp, I eventually get to:

vc4.png

but not much happens after clicking "Run"

1784

Hi,

 

You have to add the IDRAC URL as a trusted source.

See the article below

https://www.dell.com/support/kbdoc/en-us/000134739/when-trying-to-launch-the-virtual-console-from-th...

 

I remain at your disposal.

 

Regards,


Stéphane Thiallier
Business Intelligence Advisor

To reach support please post a public message into
English Enterprise Community or French Enterprise Community
1707

I've tried those instructions, but as before, after a few steps I ended up with:

conn-failed.png

Does anyone currently have this feature working?   If so, what are browser and java versions, so I can try to duplicate a known good, working setup?   They both changed quite a bit since iDrac6 was first released, so I think that's why it's not working for me.

1698

What browser versions are you testing? The iDRAC firmware also specifies supported browsers, so alternate versions may be worth testing, as well. I'd list the supported browsers, but there are a bunch, so it's probably easier to give you a reference link. The URL below is to the same firmware version you're running now. The first download is a release notes PDF with the information. 

 

https://dell.to/31cCPso

 

If this doesn't change anything, you might see if a different JVM makes a difference, but I'd hesitate to start there.

#Iwork4Dell
3 Silver
1499

And the solution is to delete "RC4" from the entry shown below, from the file:
C:\Program Files\Java\[jre_release_dir]\lib\security\java.security
(as posted in an older thread here)

jdk.tls.disabledAlgorithms=SSLv3, TLSv1, TLSv1.1, RC4, DES, MD5withRSA, \
DH keySize < 1024, EC keySize < 224, 3DES_EDE_CBC, anon, NULL, \
include jdk.disabled.namedCurves

This works even with the latest release of jre.   The above line needs to be edited every time jre is updated since the previous file is going to be replaced with a new one.

 

Latest Solutions
Top Contributor