PowerEdge Hardware General

Last reply by 04-24-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
437

raid setting lost. can't load system

Hello, everyone. I had a R630 server and it was working great for the last year. It's about the RAID controller setting in the server. I wanted to test if it's compatible to SSD hard drive. I took out all existing SAS hard drives and plug one SSD hard drive. I think I messed up the RAID settings even though I tried to avoid it carefully. Now I can't go back to the original ESXi system after I put all SAS hard drives back. I belive I searched many hours online and I think I only need to do the 'retag' and set back the original RAID settings and then it will work. But it didn't.

I tried to import settings but that's the setting from last time not the orignal settings. People said there I can recover from the setting in the hard drive. But I don't know how.

Do you have any suggestions? I am just trying everything to recover the data in the server. Thank you very much and have a wonderful day.

 

 

IMG_4855.jpgIMG_4870.jpgIMG_4871.jpgIMG_4852.jpgIMG_4853.jpg

William

Replies (9)
5 Tungsten
425

Two pictures are not shown to me. Can you repost same. If picture have service tag in it then it will not be shown after uploading.

I could see one of the virtual disk (raid 10) is shown as online(557GB). Is the same virtual disk which you are trying to boot? Select boot device on one of the screenshot is showing VD0 with 836 GB. Can you check whether you can see VD with 557 GB on select boot device option

Can you also share picture of PD mgmt and VD mgmt pages.

You can also check Boot order on BIOS and also check F11 option to select boot option manually.


Thanks,
DELL-Shine K
#IWork4Dell

4 Beryllium
417

Hi William,

normaly it isnt a problem but i am missing the key step within your story. After adding your SAS Disks into the system again the PERC should take notice that there is a "foreign config" found because the RAID infos are also stored on the disks and not only within the PERC.
But your screenshot doesnt display the last "tab" which comes visible when there is a foreign config.

If you manually re-create the VD and init it than all data is lost.

Regards,
Joerg

2 Bronze
2 Bronze
394

Hi, Shine. I believed I used RAID5 before. But I am not 100% sure since it's not working. I tried RAID10 and it doesn't work. I was testing all kinds of RAID in the RAID configuration wizard. The VD0 with 836GB pic is taken from different time than the RAID10 557GB picture. I am very sorry for the confusion. I take the photo again and attach them in this post. Now the settings is configured as RAID5 and all pictures are taken at the same time.

Hello Joerg, I did recreate the VD many times. I also try to import the foreign config, but I guess it's not right after I put them back. So the original “foreign config” in the hard drive had been updated by my newly re-created VD, is that right? Now I can't find the "import foreign" configuration page. Most of the changes I made are in the "configuration wizards: RAID Configuration" page, there are 5 steps. I did try to change to different RAID many times. I guess my data can't be recovered in this case.

Please let me know if you need more information. Thanks a lot.

Sorry, I can't upload picture because " You have already uploaded 10 images during this 24-hour window. You can try to upload more images later."

Please use this link to see the pictures.

https://ibb.co/album/jgBPCz

 

3 Argentum
388

Hi, I will recommend you to use data recovery software such as Advanced Disk Recovery. It can retrieve lost or deleted photos, videos, audio, documents & other files from your Hard Drive, USB & other storage media.

384

Because you have recreate the VD a couple of times with different settings the original config is overriden so the data is lost.

Regards,
Joerg

2 Bronze
2 Bronze
369

Thanks everyone. I guess that's it. Have a nice weekend.

2 Bronze
2 Bronze
330

Hello, I saw this post

https://www.dell.com/community/PowerEdge-Hardware-General/recover-deleted-virtual-disk/td-p/4680185

The OP said s/he deleted the VD and the answers said a 'retag' can recover it. Is it possible? Thank you.

279

You can try that as a last option. There is no guarantee that this will recover the virtual disk. For this you need to use same configuration and disk sequence which used before. Do not initialize the virtual disk once it is created. As you already tried creating multiple virtual disks with these drives I am not sure whether this will work.


Thanks,
DELL-Shine K
#IWork4Dell

279

Hi,

Is it possible? Thank you.-> Shine has already commented on it but I might also add it’s not possible. You may need to seek 3rd party's help for data restoration. Sorry I can’t be of help this time.


DELL-Young E
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell

Did I answer your query? Please click on ‘Accept as Solution’. ‘Kudo’ the posts you like!

Latest Solutions
Top Contributor