wmi.wmi
1 Nickel

2003R2x64 on M610 (M1000e) Broadcom iSCSI Adapter Device Manager Yellow Bang

I have an M1000e enclosure filled with M610 blades, each with 2 dual-port NICs (2 on-board with Broadcom iSCSI offload + 2 Broadcom in Mez. A).  All of my blades are running vSphere, except 1 which is running Windows2003R2x64.  The OS is detecting 4 Broadcom (NDIS) NICs, however it detects the iSCSI offload as 2 additional NICs, which appear in device manager with a yellow bang. 

I've tried to install all of the drivers on the M610 page for Dell, with no luck.  I've also tried to install the Broadcom drivers, Broadcom client software, etc.  However, I still see two Broadcom iSCSI offload NIcs being detected with Yellow bang's in Device manager.  I've even tried to disable the embedded NICs from the M610 Bios (F2 on boot) - however, even after uninstalling them from Windows, they're redetected right away with the yellow bangs in Device manager. 

Anyone have any ideas, or could point me in the right direction?  I've now spent more time messing with these iSCSI NICS than it's taken me to load all of the M610's with vSphere, configure my Equallogics PS6000xv, etc.  I don't even need the iSCSI offload to work, I just need them out of device manager.

Thanks for any help you can provide! 

 

0 Kudos
3 Replies
8 Krypton

Re: 2003R2x64 on M610 (M1000e) Broadcom iSCSI Adapter Device Manager Yellow Bang

The iSCSI NICs, are more like SCSI adapters. Check under Dell's storage downloads to see if there's a Broadcom driver there.

 

Alternatively, see if there's an option in the bios to disable the iSCSI offload part of the NIC and just use them as regular NICs.

Member since 2003

0 Kudos
Highlighted
8 Krypton

Re: 2003R2x64 on M610 (M1000e) Broadcom iSCSI Adapter Device Manager Yellow Bang

The Broadcom Advacance Control suite (BACS3) is used for the configuration of the iSCSI offload feature of the Broadcom devices. To disable the iSCSI Offload feature and make the devices disappear you will need to do the following.

1) Load BASC3
2) Verify in the Device Management window that By Type is selected.
3) Select an adapter under the System devices tree
4) In the riight hand portion of the windows select the Configurations tab.
5) Uncheck the iSCSI option and select Apply

Here is a picture from the Using Broadcom Advanced Control Suite 3: Broadcom NetXtreme 57XX User Guide


 

Regards,
-cjtompsett

wmi.wmi
1 Nickel

Re: 2003R2x64 on M610 (M1000e) Broadcom iSCSI Adapter Device Manager Yellow Bang

That's exactly what I needed - thank you very much.  I was in BASC3, but not looking under the System Devices, and figured I had to be missing something.  Removing the iSCSI offload option from BASC3>Adapter#>System Devices>Configurations tab>Pre-Allocated Resources>iSCSI  did it.  The iSCSI offload NICs with the yellow bang are no longer listed in Device Manager.

Thanks again.

0 Kudos