All Networking Lost after trying to remove Broadcom Team

Dell OMSA on PE2900 WS2001 (R1) reported that access to the BMC via shared adaptor is not available with teaming.

I tried to remove Broadcom's team from a server. I wanted to get to the BMC to see if it could confirm a strange progressive sequence of storage controller and disk failures reported by OMSA 7.4, though I wasn't sure whether it could since I've only used the iDRAC before.

Now, the server shares the same NetBIOS name as its replacement domain but not the same DNS domain name.

Removal of the team continued for over 90 minutes so I decided to look into it. The only seemingly relevant Event Log entry that I'd not seen before was that the OLD server was attempting registration or deregistration against the NEW server server name record <OldMachineName>$ record type $1B. This happened every 30 minutes.

I downed the NEW domain controller and an application server on the NEW domain to all the new domain was offline. Still the process of team removal continued unendingly. Over 6 hours later, I terminated the process of removal and rebooted.

All the networking failed with exclamation marks against the adaptors.

I removed the Broadcom management software and uninstalled the Broadcom drivers from the NICs, choosing for the final NIC to remove the driver.

I then proceeded to search for NIC drivers through device manager and tried the Microsoft one presented.

Still no networking. I installed the latest Broadcom drivers and utilities. The drivers wouldn't install.

I fitted an alternative NIC, non-Broadcom. That wouldn't install either.

How do I (start to) repair this, presumably, TCP/IP stack corruption, please? Does anybody know?

0 Kudos