velda_ebel
1 Copper

Dell Open Manage on RHEL 5

Dear All,
I am having a problem putting up a Dell Open Manage on one of my servers.
About server :
Dell Power Edge 750
About operating system :
RedHat Enetrprise 5
Kernel - -2.6.18-8.el5
Dell Open Manage :
Trying from the : OM_5.5.0_ManNode_A00.tar.gz, got it from Dell site.
*******************
It installs with no errors, BUT when I try to run it, I get the following :
*******************
# ./srvadmin-services.sh start
Starting Systems Management Device Drivers:
Building dcdbas using DKS:                                 [FAILED]
DKS failed to find kernel source at /lib/modules/2.6.18-8.el5PAE/build.
DKS requires kernel source to build device drivers.
Starting dell_rbu: Already started                         [  OK  ]
Starting Systems Management Device Drivers:
Building dcdbas using DKS:                                 [FAILED]
DKS failed to find kernel source at /lib/modules/2.6.18-8.el5PAE/build.
DKS requires kernel source to build device drivers.
Starting dell_rbu: Already started                         [  OK  ]
Starting DSM SA Shared Services:                           [  OK  ]
Starting DSM SA Connection Service:                        [  OK  ]
*********************
And in a /var/log/messages is the following :
instsvcdrv: dcdbas device driver build failed for kernel 2.6.1
8-8.el5PAE. DKS failed to find kernel source at /lib/modules/2.6.18-8.el5PAE/build. DKS
requires kernel source to build device drivers.
*********************
Also :
# ./srvadmin-services.sh status
dcdbas (module) is stopped
dell_rbu (module) is running
dsm_sa_datamgr32d is stopped
dsm_sa_eventmgr32d is stopped
dsm_sa_snmp32d is stopped
dsm_om_shrsvc32d (pid 25195) is running
dsm_om_connsvc32d (pid 25257 25256) is running

Any ideas???

Best regards,
Velda

0 Kudos
1 Reply
Highlighted
Kaerka
1 Copper

Re: Dell Open Manage on RHEL 5

I've installed Dell OpenManage on many servers with RHEL5, both 32 and 64bit versions, but didn't have to install kernel source for this.  For your case, it might be because of the PAE kernel, all of my PAE RHEL5 servers had OpenManage initially installed with a regular RHEL5 32bit kernel.  You could try installing the kernel-devel package that matches your kernel version and see if it at least gets you further along.

Alternately, you could also try installing the dell_rbu rpm, detailed here: http://linux.dell.com/libsmbios/main/dell_drivers.html

A word aside- all of the RHEL5 servers I've installed OpenManage on are of the 1950,2650-2950, or R90x class server; none are the PE750 you have listed.

0 Kudos