theflash1932
6 Indium

Re: Poweredge R210 & XP Pro

The S300 has no XP drivers, as it has not ever been used in or designed for a system that supports XP.  You might try the 2003 drivers ... they occasionally work, but chances are, you won't get XP installed on an S300.

 

0 Kudos
vgbraymond
1 Copper

Re: Poweredge R210 & XP Pro

Hello, I have the same problem with XP Pro. I have a R210 Poweredge server with PERC100 (and I also find SAS 6/iR Integrated RAID Controller of LSILogic/Symbios Logic in a hardware list and this controller is at slot 01 according to the list).

Does my hardware config fit with a XP Pro?

I tried to search drivers from dell's driver download page, but no matching result was found..

Raymond

0 Kudos
theflash1932
6 Indium

Re: Poweredge R210 & XP Pro

Your ONLY option is to use the 2003 drivers for the S100, as the S100 is only available on systems for which XP drivers were never developed.  XP and 2003 are very similar, but maybe not similar enough.  As XP is not supported on any Dell server, there is a very good chance you'll never get XP installed with an S100.

0 Kudos
vgbraymond
1 Copper

Re: Poweredge R210 & XP Pro

I see. If I want to installed a XP on it, is the only possible way to get a server with SAS 6/iR controller instead of a S100 one? 

 

Raymond

0 Kudos
theflash1932
6 Indium

Re: Poweredge R210 & XP Pro

Yes, in theory, because the SAS 6/iR is also used in the Precision Tx500 systems, for which XP drivers are readily available.  These can also be configured with lots of RAM, ECC RAM, and dual processors, so in many cases, these would actually be preferable to a server.

0 Kudos
vgbraymond
1 Copper

Re: Poweredge R210 & XP Pro

I am a little bit confused about my system.. I can see in a hardwire list loaded from a DELL boot disc that I can find a SAS 6/iR /integrated RAID Controller (Vendor: LSILogic/ Symbios Logic, Slot: 01), and on the other hand, before entering the Windows installation, I can see on the screen asking me to press Ctrl+S to configure the PERC S100 controller..

Do this mean I get two RAID controllers at the same time, such that I can remove one to let another one work individually?

I am a beginner on RAID...

Thanks..

Raymond

0 Kudos
Moderator
Moderator

Re: Poweredge R210 & XP Pro

SWith regards to unsure what the unit has, I would advise going here: http://support.dell.com/support/topics/global.aspx/support/my_systems_info/details?c=us&cs=555&l=en&...

You can enter your service tag and view the original system configuration to ensure you have the cards in the unit as you are seeing.  Also, are you getting two different RAID controller prompts when the unit is booting up?

The S100 is a software RAID controller for Windows based operating systems only. The SAS 6/iR is a much more robust card than the S100, but the first step is identifying what card(s) are in the unit, from there seeing which card is in use that is connected to the hard drives to ensure you have the proper driver to get in place for the installation after the array is in place as intended.

 

#iwork4Dell
Get Support on Twitter: @DellCaresPRO

Tags (2)
0 Kudos
spekl1
1 Copper

Re: Poweredge R210 & XP Pro

FYI - I have the S100 Controller PE R210 and attempted the following:

I downloaded the PERC S100 driver for Windows 2003 Server x64 (http://support.dell.com/support/downloads/download.aspx?c=us&cs=2684&l=en&s=pub&releaseid=R245788&Sy...<ADMIN NOTE: Service tag removed per privacy policy>&os=WX64&osl=en&deviceid=20887&devlib=0&typecnt=0&vercnt=2&catid=-1&impid=-1&formatcnt=0&libid=46&ty...).

  • Slip-stream the drivers into the XP Pro SP3 install.  Results in "bcraid.sys file is corrupt", and stops process.
  • F6 when prompted in XP install to select the driver from a floppy.  Results in "Bcraid.sys file is corrupt", and stops process.

So, I'm beginning to believe TheFlash1932's theory that it cannot be done.   Anyone have any other suggestions, thoughts, etc...?

0 Kudos
spekl1
1 Copper

Re: Poweredge R210 & XP Pro

ATKTST,

We're you ever successful with your slipstream attempt?  I ask because we might go the route of purchasing the 6/ir controlller (same as your system, I believe) and wanted to see if it allows an XP OS build on the server.

Tags (3)
0 Kudos
SamirD
1 Nickel

Re: Poweredge R210 & XP Pro

I'm trying to do the same thing with an R410 and have gotten everything to work except the sas 6ir that I've confirmed is in the server.  (I even opened the server and pulled the card out and confirmed the part number online.)

I have tried drivers from everyone from the Dell R165652 (and several other Dells) to IBM's drivers, to LSI's drivers and always end up with a 'code 10' error.

XP is currently booting off an SATA drive that will be moved to the SAS controller once the driver is properly loaded.  (We used this method to install XP on a 2950 gen 1 as well with success once we got the correct sas driver to install.)

Any ideas and assistance appreciated.

 

0 Kudos