Highlighted
illiumrex
1 Copper

Window Server 2008 Dell PowerEdge with PERC 6iR - ERROR 0x80070015

Heya,

So, I'm doing a clean install of Windows Server 2008 R2 Enterprise SP1 on a PowerEdge R300 with the SAS 6/ iR controller card installed on LUN 0, (riser 1 in the chassis), with 2x(two) Dell Drives (GY581- Dell 73GB SAS drives) attached.

When I init the machine, and go into the PERC controller, all appears normal EXCEPT that the drives are marked "WRG TYPE" and cannot be init'd to a RAID. Okay... it appears that this model of controller is *not* a RAID card. Sure.

So, I ripped an ISO of the Windows install media, and burned to USB thumbdrive (using the *nix usb pen drive installer; I selected the "win8" installer for media). No problem.

I boot from the usb drive, the windows installer starts. I choose "clean install", it drops to the drive selector.

both the (0) and the (1) drives appear in the selection, but both are "Offline". When I click "ok", the machine attempts to online the drives and fails with error 0x80070015, which is the default windows "i'm stupid and can't make a proper error message and your device is not ready" error message.

Any advice? I can't force the drives to come online in the LSI/Dell bios, and I can't init them via the windows installation gui.

0 Kudos
2 Replies
theflash1932
6 Indium

RE: Window Server 2008 Dell PowerEdge with PERC 6iR - ERROR 0x80070015

You said you went "into the PERC controller", but you said you have a "SAS 6/iR". Which do you have? The SAS 6/iR is NOT a PERC. I'll assume a SAS 6/iR. It supports both RAID and non-RAID. When you go to CTRL-C, can you delete any existing volumes on them? Configure them in an IS/IM?

0 Kudos
illiumrex
1 Copper

RE: Window Server 2008 Dell PowerEdge with PERC 6iR - ERROR 0x80070015

The card is the Dell-branded UCS-61 - E2K-UCS-61-(B). LSI 1068e, so, SAS 6/iR. Sorry for the incorrect nomenclature.

The drives aren't manipulatable AT ALL in the CRTL-C menu. It shows the drives are attached, lists them as "wrg type" when I enter the raid config. When I attempt to use to the ALT-D keys to attempt to verify the disks, they automatically fail with no activity on the disks. Both drives show their type, speed, negotiated speed and serial number, but no other information will populate.

The only other weirdness I can detect is that during the Controller init of the boot process, the card inits, then searches for boot devices on HBA0, which it doesn't find any of. Then, the drives appear on HBA1, slots 0 and 1.

I tried using the Dell Management ISO to "prep" the disks, but I can't get the machine to boot off the darn thing. So I'm kind of stuck on how to proceed.

Yes, the drives are dell branded.

No, I don't know how old the drives are.

Yes, they worked the last time anyone checked this server (couple of months ago)

No, I don't have another R300 laying around to test the drives in.

0 Kudos