E155
1 Nickel

Windows Server 2016 guest VM - low performance on R 720, Hyper-V

Hello.

I have an issue with low guest VM performance with VM 2016 OS under R720 hardware
I have a Hyper-V cluster based on Dell PE720 with Xeon E5-2620 CPUs. Both nodes running Windows 2016 Dtc. Host BIOS and drivers updated to last versions. Network adapters VMQ is disabled.


This cluster hosts runs 2012R2 HV before and was upgraded to 2016 Dtc. There was a clean install, not inplace upgrade.

I have migrated there a lot of VMs running Windows and Linux machines from old 2012Rs host. Most ot these machines running under 2012R2 or below. All these machines works properly after migration from 2012R2 host.


Only one inctance of 2016 based VM exisit on this cluster before hosts was upgraded to 2016, and that 2016 based VM works slowly then.


When I setup new machine on 2016 Std I've seen completely low performance on programs gui responce and program execution relatively to 2012 machines.

For testing i setup second 2016 VM of 1 generation on my R720 host - had the same issue.

For example: i started to prepare new 2016 based VM for CCM and needed to install Windows ADK first, but ADK install hang for a long time on files download stage, and fail after a few hours of running. Seems on connection timeout.

VM config are: 8 cores, 12Gb of static assigned RAM.
Generation of VM = 2
VM configuration = 8.0
ClusterFunctionalLevel = 9 (2016 native)
Integration components version: 10.0.14393

I exported this VM for test and run it under another 2016 Host on old Dell R415 with Opteron CPU. And guest runs quiqly as he should. ADK setup utility runs correctly.


Also I have another equal cluster with 2016 Hyper-V host, only difference is Xeon E5-2620 v2 CPUs. There 2016 guset VMs run normally. All system drivers equal on both hypervisors running R720s, There are only CPUs are different.

Please advice what can cause low performance for 2016 machines on my 2016 hypervisor? Have no ideas at all.

0 Kudos
4 Replies

RE: Windows Server 2016 guest VM - low performance on R 720, Hyper-V

Hi,

Have you had any response on this topic as yet?

I have a 4 node 2016 cluster running on Dell FC630 Blades in a FX2S chassis. Prior to it running on 2012 R2 the performance was 100% but after performing the Rolling cluster updates to 2016 there is a slight performance degradation on the guest VM's.

Thanks,

0 Kudos
Highlighted
E155
1 Nickel

RE: Windows Server 2016 guest VM - low performance on R 720, Hyper-V

Hi. 

Has no any response  yet. 

Which CPU your blades operating?

0 Kudos

RE: Windows Server 2016 guest VM - low performance on R 720, Hyper-V

Hi,

I am running Intel(R) Xeon(R) CPU E5-2667 v4 @ 3.20GHz in all 4 nodes.

I did find that SR-IOV global setting was disabled in the BIOS, I enabled it on one of the nodes in the cluster, moved a test workload and it seems to have improved.

Also have you applied the latest MS CU for 2016?

0 Kudos
TiagoFreitas87
1 Copper

RE: Windows Server 2016 guest VM - low performance on R 720,

Hello,

Were you able to solve this?

Having the exact same problem, same server and CPU and applications are slow but are not using much CPU, RAM or Disk, just slow gui and sometimes everything including SQL becomes slow with no apparent reason.

Thanks

0 Kudos