Highlighted
1 Copper

EMC powerdevices gives the following error <drive type unknown>

Hi,

I installed EMC Powerpath on Solaris 10 Intel Platform.

Powerpath Version:

====

root@server1 # powermt version

EMC powermt for PowerPath (c) Version 5.3 (build 473)

root@server1 #

====

Solaris Version:

====

root@server1 # uname -a

SunOS server1 5.10 Generic_144489-17 i86pc i386 i86pc

root@server1 # cat /etc/release

                    Oracle Solaris 10 9/10 s10x_u9wos_14a X86

     Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.

                            Assembled 11 August 2010

root@server1 #

====

I have 3 LUNs presented from EMC VMAX Storage. When I try to access the direct LUN device it work fine, I can create slices and mount the filesystem also.

But when I try to access the LUN using the EMC Power Device, it gives me error. In the format command itself it shows the following:

====

root@server1 # format

Searching for disks...

Error: can't open selected disk '/dev/rdsk/emcpower1p4p0'.

done

AVAILABLE DISK SELECTIONS:

       0. c0t0d0 <DEFAULT cyl 8917 alt 2 hd 255 sec 63>

          /pci@0,0/pci8086,3a40@1c/pci103c,3245@0/sd@0,0

       1. c6t500009740806D59Cd0 <DEFAULT cyl 13051 alt 2 hd 255 sec 63>

          /pci@0,0/pci8086,340a@3/pci103c,3315@0,2/fp@0,0/disk@w500009740806d59c,0

       2. c6t500009740806D59Cd1 <DEFAULT cyl 6523 alt 2 hd 255 sec 63>

          /pci@0,0/pci8086,340a@3/pci103c,3315@0,2/fp@0,0/disk@w500009740806d59c,1

       3. c6t500009740806D59Cd2 <DEFAULT cyl 13050 alt 2 hd 255 sec 63>

          /pci@0,0/pci8086,340a@3/pci103c,3315@0,2/fp@0,0/disk@w500009740806d59c,2

       4. c7t500009740806D5A4d0 <DEFAULT cyl 13051 alt 2 hd 255 sec 63>

          /pci@0,0/pci8086,340a@3/pci103c,3315@0,3/fp@0,0/disk@w500009740806d5a4,0

       5. c7t500009740806D5A4d1 <DEFAULT cyl 6523 alt 2 hd 255 sec 63>

          /pci@0,0/pci8086,340a@3/pci103c,3315@0,3/fp@0,0/disk@w500009740806d5a4,1

       6. c7t500009740806D5A4d2 <DEFAULT cyl 13050 alt 2 hd 255 sec 63>

          /pci@0,0/pci8086,340a@3/pci103c,3315@0,3/fp@0,0/disk@w500009740806d5a4,2

       7. emcpower0p <DEFAULT cyl 13050 alt 2 hd 255 sec 63>

          /pseudo/emcp@0

       8. emcpower1p4 <drive type unknown>

          /pseudo/emcp@1

       9. emcpower2o <DEFAULT cyl 6523 alt 2 hd 255 sec 63>

          /pseudo/emcp@2

Specify disk (enter its number): 8

AVAILABLE DRIVE TYPES:

        0. Auto configure

        1. DEFAULT

        2. DEFAULT

        3. DEFAULT

        4. DEFAULT

        5. other

Specify disk type (enter its number): ^C

root@server1 #

====

Each option in the above list gives different sizes for the disk. And even after that when i label the disk and issue format again, it will ask the same question.

Below is the powermt display

====

root@server1 # powermt display dev=emcpower1a

Pseudo name=emcpower1a

Symmetrix ID=000xxxx00xxx

Logical device ID=0A6E

state=alive; policy=SymmOpt; priority=0; queued-IOs=0;

==============================================================================

--------------- Host ---------------   - Stor -   -- I/O Path --  -- Stats ---

###  HW Path               I/O Paths    Interf.   Mode    State   Q-IOs Errors

==============================================================================

3074 pci@0,0/pci8086,340a@3/pci103c,3315@0,2/fp@0,0 c6t500009740806D59Cd0s0 FA  8gA   active  alive       0      0

3076 pci@0,0/pci8086,340a@3/pci103c,3315@0,3/fp@0,0 c7t500009740806D5A4d0s0 FA 10gA   active  alive       0      0

root@server1 #

====

I deleted the power device and reconfigured powermt still, I have the same problem.

Can someone guide me how the power device can be made usable.

Reply
3 Replies
Highlighted
3 Argentium

Re: EMC powerdevices gives the following error <drive type unknown>

Hi.  Have you seen Primus case emc207479?  Thanks.

-Brion

Reply
Highlighted
1 Copper

Re: EMC powerdevices gives the following error <drive type unknown>

Can you please help me in viewing the case.

I have powerlink access, but when ever i click on support, it just keeps on processing but never shows any page. same thing when i try to search also. If you have a direct link to see the case, it will be helpfull for me.

Thanks for your update.

Reply
Highlighted
3 Argentium

Re: EMC powerdevices gives the following error <drive type unknown>

Please e-mail me directly and I will send the Primus case.

brion.stultz@emc.com

Thanks.

Reply